Bug 491482 - IndexError: list index out of range on "yum install ...."
IndexError: list index out of range on "yum install ...."
Status: CLOSED DUPLICATE of bug 491508
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 491772 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-21 13:16 EDT by Tom London
Modified: 2014-01-21 18:08 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-23 13:17:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom London 2009-03-21 13:16:10 EDT
Description of problem:

[root@tlondon ~]# yum install gnome-games
Loaded plugins: dellsysidplugin2, fastestmirror, refresh-packagekit
Existing lock /var/run/yum.pid: another copy is running as pid 4571.
Another app is currently holding the yum lock; waiting for it to exit...
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 306, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 170, in main
    show_lock_owner(e.pid)
  File "/usr/share/yum-cli/yummain.py", line 104, in show_lock_owner
    if data[1].endswith(' kB'):
IndexError: list index out of range
[root@tlondon ~]# 

Immediately rerunning succeeded.

Version-Release number of selected component (if applicable):
yum-3.2.21-16.fc11.noarch

How reproducible:
???

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tim Lauridsen 2009-03-22 04:48:24 EDT
could you please post the output from

cat /proc/XXXX/status

where XXXX is the pid shown in the

another copy is running as pid XXXX. 

line
Comment 2 Tom London 2009-03-22 11:55:59 EDT
(In reply to comment #1)
> could you please post the output from
> 
> cat /proc/XXXX/status
> 
> where XXXX is the pid shown in the
> 
> another copy is running as pid XXXX. 
> 
> line  

OK, here is how I reproduce:

I start a "yum update" in one terminal window.

While it is "running" (i.e., after I enter "y" to do the update), I start a "yum update in another terminal window.

Here is what I get:

[root@tlondon ~]# yum update
Loaded plugins: dellsysidplugin2, fastestmirror, refresh-packagekit
Existing lock /var/run/yum.pid: another copy is running as pid 3869.
Another app is currently holding the yum lock; waiting for it to exit...
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 306, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 170, in main
    show_lock_owner(e.pid)
  File "/usr/share/yum-cli/yummain.py", line 104, in show_lock_owner
    if data[1].endswith(' kB'):
IndexError: list index out of range
[root@tlondon ~]# cat /proc/3869/status
Name:	yum
State:	S (sleeping)
Tgid:	3869
Pid:	3869
PPid:	3578
TracerPid:	0
Uid:	0	0	0	0
Gid:	0	0	0	0
Utrace: 0
FDSize:	256
Groups:	0 1 2 3 4 6 10 
VmPeak:	  407356 kB
VmSize:	  403456 kB
VmLck:	       0 kB
VmHWM:	  123512 kB
VmRSS:	  120160 kB
VmData:	  130484 kB
VmStk:	     144 kB
VmExe:	       4 kB
VmLib:	   16840 kB
VmPTE:	     764 kB
Threads:	1
SigQ:	0/40448
SigPnd:	0000000000000000
ShdPnd:	0000000000000000
SigBlk:	0000000000000000
SigIgn:	0000000001001000
SigCgt:	0000000180014007
CapInh:	0000000000000000
CapPrm:	ffffffffffffffff
CapEff:	ffffffffffffffff
CapBnd:	ffffffffffffffff
Cpus_allowed:	f
Cpus_allowed_list:	0-3
Mems_allowed:	00000000,00000000,00000000,00000000,00000000,00000000,00000000,00000000,00000000,00000000,00000000,00000000,00000000,00000000,00000000,00000001
Mems_allowed_list:	0
voluntary_ctxt_switches:	7599
nonvoluntary_ctxt_switches:	5352
[root@tlondon ~]#
Comment 3 Michal Schmidt 2009-03-23 13:17:20 EDT
It's a kernel bug, the "Utrace: ..." line has a space and not tab like all other lines.

*** This bug has been marked as a duplicate of bug 491508 ***
Comment 4 James Antill 2009-03-23 17:51:34 EDT
This should be "fixed" in yum in upstream commit:

http://yum.baseurl.org/gitweb?p=yum.git;a=commitdiff;h=29ce5770b8e85d9e7a5e052f82d164a605dd7a26
Comment 5 James Antill 2009-03-23 23:15:17 EDT
*** Bug 491772 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.