Bug 491523 - yum tries to remove rpms under repositories on local disk
yum tries to remove rpms under repositories on local disk
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 491764 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-22 11:47 EDT by Mamoru TASAKA
Modified: 2014-01-21 18:08 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-23 11:23:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum transaction log (3.61 KB, text/plain)
2009-03-22 11:47 EDT, Mamoru TASAKA
no flags Details

  None (edit)
Description Mamoru TASAKA 2009-03-22 11:47:38 EDT
Created attachment 336201 [details]
yum transaction log

Description of problem:
Well, when I try the following:

1. create /var/lib/mock/LOCALRPMS/i386 directory
2. put 2 binary rpms (actually modified boost, boost-devel
   i586 binary rpms) under the directory written in 1.
3. go to /var/lib/mock/LOCALRPMS, then
   $ createrepo -d $(pwd)
4. as root, cd /var/lib/mock/LOCALRPMS and
   $ find . -type f | xargs chattr +i
5. as root create /etc/yum.repos.d/LOCAL.repo, with
   the content as below:
------------------------------------------------------
[LOCAL]
name=LOCAL - locally created rpms
baseurl=file:///var/lib/mock/LOCALRPMS/i386/
enabled=1
gpgcheck=0
------------------------------------------------------
6. Then try "yum -y upgrade boost"

Then yum transaction tries to remove 2 binary rpms under
/var/lib/mock/LOCALRPMS/i386 directory (see attached)

Version-Release number of selected component (if applicable):
yum-3.2.21-16.fc11.noarch
createrepo-0.9.6-12.fc11.noarch

How reproducible:
100%

Steps to Reproduce:
1. See above
2.
3.

Additional info:
I don't know when this issue began...

Some debugging shows:
- At verifyPkg(self, fo, po, raiseError) in __init__.py,
  po.verifyLocalPkg() returns false

  <- At verifyLocalPkg(self) in packages.py,
     self.localPkg() returns "//var/cache/yum/LOCAL/packages/boost-1.37.0-4.1.fc11.i586.rpm", which does not exist at this time.
     and filesum = misc.checksum(csum_type, self.localPkg())
     returns Errors.MiscError
Comment 1 seth vidal 2009-03-23 11:23:56 EDT
I've changed yum so that file:// urls will still make a local copy of pkgs. This means we'll make a temp copy of things but it is safer than guessing the kind of baseurl we _might_ be dealing with.
Comment 2 James Antill 2009-03-23 23:24:40 EDT
*** Bug 491764 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.