Bug 491764 - Yum removes the content of a local repository instead of installing from it
Yum removes the content of a local repository instead of installing from it
Status: CLOSED DUPLICATE of bug 491523
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Target
  Show dependency treegraph
 
Reported: 2009-03-23 17:51 EDT by Nicolas Mailhot
Modified: 2014-01-21 18:08 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-23 23:24:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2009-03-23 17:51:28 EDT
Description of problem:

Yum removes the content of a local repository instead of installing from it

Version-Release number of selected component (if applicable):

yum-3.2.21-16.fc11.noarch
rpm-4.7.0-0.beta1.6.fc11.x86_64

How reproducible:

Always, see following logs



# cat /etc/yum.repos.d/local.repo ; echo "[Before]" ; ls -tlr /srv/rpm ;  yum -y update ; echo "[After]" ; ls -tlr /srv/rpm ; echo "[End]"
[local]
name=local
baseurl=file:///srv/rpm
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-nim
enabled=1
gpgcheck=1
[Before]
total 7132
drwxr-xr-x 2 nim nim    4096 mars 23 22:50 repodata
-rw-r--r-- 1 nim nim 1250715 mars 23 22:50 gnu-free-serif-fonts-20090104-10.fc11.noarch.rpm
-rw-r--r-- 1 nim nim  652803 mars 23 22:50 gnu-free-sans-fonts-20090104-10.fc11.noarch.rpm
-rw-r--r-- 1 nim nim  437352 mars 23 22:50 gnu-free-mono-fonts-20090104-10.fc11.noarch.rpm
-rw-r--r-- 1 nim nim    4068 mars 23 22:50 gnu-free-fonts-compat-20090104-10.fc11.noarch.rpm
-rw-r--r-- 1 nim nim   68439 mars 23 22:50 gnu-free-fonts-common-20090104-10.fc11.noarch.rpm
-rw-r--r-- 1 nim nim 4846169 mars 23 22:50 gnu-free-fonts-20090104-10.fc11.src.rpm
Loaded plugins: dellsysidplugin2, refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package gnu-free-fonts-compat.noarch 0:20090104-10.fc11 set to be updated
--> Processing Dependency: gnu-free-serif-fonts = 20090104-10.fc11 for package: gnu-free-fonts-compat
--> Processing Dependency: gnu-free-sans-fonts = 20090104-10.fc11 for package: gnu-free-fonts-compat
--> Processing Dependency: gnu-free-mono-fonts = 20090104-10.fc11 for package: gnu-free-fonts-compat
--> Running transaction check
---> Package gnu-free-mono-fonts.noarch 0:20090104-10.fc11 set to be updated
--> Processing Dependency: gnu-free-fonts-common = 20090104-10.fc11 for package: gnu-free-mono-fonts
---> Package gnu-free-sans-fonts.noarch 0:20090104-10.fc11 set to be updated
---> Package gnu-free-serif-fonts.noarch 0:20090104-10.fc11 set to be updated
--> Running transaction check
---> Package gnu-free-fonts-common.noarch 0:20090104-10.fc11 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

======================================================================================================================================================================
 Package                                         Arch                             Version                                       Repository                       Size
======================================================================================================================================================================
Installing:
 gnu-free-fonts-compat                           noarch                           20090104-10.fc11                              local                           4.0 k
     replacing  freefont.noarch 20080323-2.fc11

Installing for dependencies:
 gnu-free-fonts-common                           noarch                           20090104-10.fc11                              local                            67 k
 gnu-free-mono-fonts                             noarch                           20090104-10.fc11                              local                           427 k
 gnu-free-sans-fonts                             noarch                           20090104-10.fc11                              local                           638 k
 gnu-free-serif-fonts                            noarch                           20090104-10.fc11                              local                           1.2 M

Transaction Summary
======================================================================================================================================================================
Install      5 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 2.3 M
Downloading Packages:


Error Downloading Packages:
  gnu-free-sans-fonts-20090104-10.fc11.noarch: failure: gnu-free-sans-fonts-20090104-10.fc11.noarch.rpm from local: (256, 'No more mirrors to try.')
  gnu-free-fonts-common-20090104-10.fc11.noarch: failure: gnu-free-fonts-common-20090104-10.fc11.noarch.rpm from local: (256, 'No more mirrors to try.')
  gnu-free-fonts-compat-20090104-10.fc11.noarch: failure: gnu-free-fonts-compat-20090104-10.fc11.noarch.rpm from local: (256, 'No more mirrors to try.')
  gnu-free-mono-fonts-20090104-10.fc11.noarch: failure: gnu-free-mono-fonts-20090104-10.fc11.noarch.rpm from local: (256, 'No more mirrors to try.')
  gnu-free-serif-fonts-20090104-10.fc11.noarch: failure: gnu-free-serif-fonts-20090104-10.fc11.noarch.rpm from local: (256, 'No more mirrors to try.')

[After]
total 4752
drwxr-xr-x 2 nim nim    4096 mars 23 22:50 repodata
-rw-r--r-- 1 nim nim 4846169 mars 23 22:50 gnu-free-fonts-20090104-10.fc11.src.rpm
[End]
Comment 1 James Antill 2009-03-23 23:24:39 EDT

*** This bug has been marked as a duplicate of bug 491523 ***

Note You need to log in before you can comment on or make changes to this bug.