This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 491588 - acpi error message at boot: [CS03] Namespace lookup failure, AE_NOT_FOUND
acpi error message at boot: [CS03] Namespace lookup failure, AE_NOT_FOUND
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tony Camuso
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-23 03:21 EDT by bsvtmail
Modified: 2014-08-27 05:06 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 710720 (view as bug list)
Environment:
Last Closed: 2009-09-01 15:13:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dmesg (31.85 KB, text/plain)
2009-03-23 03:21 EDT, bsvtmail
no flags Details
ACPI Errors of our Tylersburg platform. (61.97 KB, image/x-png)
2009-04-24 01:23 EDT, Lin Avator
no flags Details
ouptut of /proc/cpuinfo (4.75 KB, text/plain)
2009-06-07 09:58 EDT, Frederic Medery
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 9586 None None None Never

  None (edit)
Description bsvtmail 2009-03-23 03:21:26 EDT
Created attachment 336253 [details]
dmesg

Description of problem:
The problem is that the following ACPI Error messages appeared in boot log of the servers.

Version-Release number of selected component (if applicable):
OS:
Linux 2.6.18-128.1.1.el5 #1 SMP Mon Jan 26 13:58:24 EST 2009 x86_64 x86_64 x86_64 GNU/Linux
RHEL:
Red Hat Enterprise Linux v5
Red Hat Enterprise Linux, Standard L3 (for up to 2 sockets)

Hardware:
HP BladeSystem BL460c G1: 
2 x Quad-Core Intel Xeon E5405, 2.00 GHz, 1333 FSB
2 x 2048MB PC2-5300 Fully Buffered DIMMs, 667 MHz
4 x  512MB PC2-5300 Fully Buffered DIMMs, 667 MHz
1 x HP Smart Array E200i RAID, 128MB Battery-backed write-cache
2 x HP 72GB 3G SAS 15K SFF DP HDD
2 x Broadcom NC373i Multifunction Gigabit Server Adapter
1 x Integrated Lights-Out 2 Management 10/100Mb Network Adapter
1 x QLogic Dual-Port Fibre Channel FC HBA, QMH2462 4Gb


How reproducible:
It happens at evey boot.

Steps to Reproduce:
1. reboot the server
2. cat /var/log/dmesg
...
Allocate Port Service[0000:05:01.0:pcie20]
Allocate Port Service[0000:05:01.0:pcie21]
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
ACPI (exconfig-0456): Dynamic SSDT Load - OemId [HP    ] OemTableId [ CPU0CST] [20060707]
ACPI Error (psargs-0355): [CS03] Namespace lookup failure, AE_NOT_FOUND
ACPI Error (psparse-0537): Method parse/execution failed [\_PR_.CPU0._CST] (Node ffff8101affb0a10), AE_NOT_FOUND
ACPI (exconfig-0456): Dynamic SSDT Load - OemId [HP    ] OemTableId [ CPU1CST] [20060707]
ACPI Error (psargs-0355): [CS03] Namespace lookup failure, AE_NOT_FOUND
ACPI Error (psparse-0537): Method parse/execution failed [\_PR_.CPU1._CST] (Node ffff8101affb0a30), AE_NOT_FOUND
ACPI (exconfig-0456): Dynamic SSDT Load - OemId [HP    ] OemTableId [ CPU2CST] [20060707]
ACPI Error (psargs-0355): [CS03] Namespace lookup failure, AE_NOT_FOUND
ACPI Error (psparse-0537): Method parse/execution failed [\_PR_.CPU2._CST] (Node ffff8101affb0ad0), AE_NOT_FOUND
ACPI (exconfig-0456): Dynamic SSDT Load - OemId [HP    ] OemTableId [ CPU3CST] [20060707]
ACPI Error (psargs-0355): [CS03] Namespace lookup failure, AE_NOT_FOUND
ACPI Error (psparse-0537): Method parse/execution failed [\_PR_.CPU3._CST] (Node ffff8101affb09f0), AE_NOT_FOUND
ACPI (exconfig-0456): Dynamic SSDT Load - OemId [HP    ] OemTableId [ CPU4CST] [20060707]
ACPI Error (psargs-0355): [CS03] Namespace lookup failure, AE_NOT_FOUND
ACPI Error (psparse-0537): Method parse/execution failed [\_PR_.CPU4._CST] (Node ffff8101affb0a50), AE_NOT_FOUND
ACPI (exconfig-0456): Dynamic SSDT Load - OemId [HP    ] OemTableId [ CPU5CST] [20060707]
ACPI Error (psargs-0355): [CS03] Namespace lookup failure, AE_NOT_FOUND
ACPI Error (psparse-0537): Method parse/execution failed [\_PR_.CPU5._CST] (Node ffff8101affb0ab0), AE_NOT_FOUND
ACPI (exconfig-0456): Dynamic SSDT Load - OemId [HP    ] OemTableId [ CPU6CST] [20060707]
ACPI Error (psargs-0355): [CS03] Namespace lookup failure, AE_NOT_FOUND
ACPI Error (psparse-0537): Method parse/execution failed [\_PR_.CPU6._CST] (Node ffff8101affb09d0), AE_NOT_FOUND
ACPI (exconfig-0456): Dynamic SSDT Load - OemId [HP    ] OemTableId [ CPU7CST] [20060707]
ACPI Error (psargs-0355): [CS03] Namespace lookup failure, AE_NOT_FOUND
ACPI Error (psparse-0537): Method parse/execution failed [\_PR_.CPU7._CST] (Node ffff8101affb0a70), AE_NOT_FOUND
ACPI: Thermal Zone [THM0] (8 C)
Real Time Clock Driver v1.12ac
hpet_resources: 0xfed00000 is busy
...

  
Actual results:


Expected results:


Additional info:
Comment 1 Lin Avator 2009-04-24 01:22:13 EDT
We have the same issues of "ACPI Error" on our Tylersburg platform . The OS is RHEL 4.7. Please help to solve it. Thanks a lot.
Comment 2 Lin Avator 2009-04-24 01:23:54 EDT
Created attachment 341061 [details]
ACPI Errors of our Tylersburg platform.

ACPI Errors of our Tylersburg platform.
Comment 3 Robert Lopez 2009-04-30 13:22:05 EDT
Same issue on each of three Red Hat Enterprise Linux Server release 5.3 (Tikanga) installations on HP ProLiant DL360 G5.

dmesg output:

ACPI (exconfig-0456): Dynamic SSDT Load - OemId [HP    ] OemTableId [ CPU0CST] [
20060707]
ACPI Error (psargs-0355): [CS03] Namespace lookup failure, AE_NOT_FOUND
ACPI Error (psparse-0537): Method parse/execution failed [\_PR_.CPU0._CST] (Node
 ffff81022f531290), AE_NOT_FOUND
ACPI (exconfig-0456): Dynamic SSDT Load - OemId [HP    ] OemTableId [ CPU1CST] [
20060707]
ACPI Error (psargs-0355): [CS03] Namespace lookup failure, AE_NOT_FOUND
ACPI Error (psparse-0537): Method parse/execution failed [\_PR_.CPU1._CST] (Node
 ffff81022f5312b0), AE_NOT_FOUND
ACPI (exconfig-0456): Dynamic SSDT Load - OemId [HP    ] OemTableId [ CPU2CST] [
20060707]
ACPI Error (psargs-0355): [CS03] Namespace lookup failure, AE_NOT_FOUND
ACPI Error (psparse-0537): Method parse/execution failed [\_PR_.CPU2._CST] (Node
 ffff81022f531350), AE_NOT_FOUND
ACPI (exconfig-0456): Dynamic SSDT Load - OemId [HP    ] OemTableId [ CPU3CST] [
20060707]
ACPI Error (psargs-0355): [CS03] Namespace lookup failure, AE_NOT_FOUND
ACPI Error (psparse-0537): Method parse/execution failed [\_PR_.CPU3._CST] (Node
 ffff81022f531270), AE_NOT_FOUND
ACPI: Thermal Zone [THM0] (8 C)
Comment 6 Mark Goodwin 2009-05-04 21:00:13 EDT
kernel.org bugzilla #9586 seems related.
Comment 9 Tony Camuso 2009-06-02 07:25:00 EDT
Pleas ask the customers to run the following command so we can determine the BIOS information.

# dmidecode | grep -e Date -e Vendor -e Version -e Product | head -n 4
Comment 10 Issue Tracker 2009-06-02 07:41:31 EDT
Info from sosreport :	

Vendor: HP
Version: P58
Release Date: 06/25/2008
Product Name: ProLiant DL360 G5

Thanks.


This event sent from IssueTracker by pyaduvan 
 issue 302491
Comment 11 Chris Van Hoof 2009-06-02 09:33:49 EDT
(In reply to comment #9)
> Pleas ask the customers to run the following command so we can determine the
> BIOS information.
> 
> # dmidecode | grep -e Date -e Vendor -e Version -e Product | head -n 4  

	Vendor: HP
	Version: I15
	Release Date: 11/02/2008
	Product Name: ProLiant BL460c G1
Comment 12 Kipp Glover 2009-06-02 14:08:53 EDT
I did a quick boot on my DL360 G5 just now and didn't see the mentioned errors.  However, my CPUs are different.   I have the Intel 5150 installed.   Let me look into getting the E5405 procs and see if I can see the issue.  I suspect I will.  

I will run point on this from the HP side. 

Cheers!
/Kipp
Comment 13 Matthew Garrett 2009-06-02 14:48:30 EDT
Net effect of this is that processor idle C states will probably not be functional. What does /proc/acpi/processor/*/power look like on an affected machine?

Per upstream conversation here: http://markmail.org/message/eiodqm526mtejbpj#mid:srmaa4qaqkucz4gf+state:results this may be a BIOS issue.
Comment 14 Tony Camuso 2009-06-02 14:52:38 EDT
I was unable to reproduce the error. Here is what those boot messages look like. This information was taken from a bl460g5 with  (see below). 

Question for the reporter(s):
Did you see this problem after performing a CPU upgrade?

The processor family in this system is 

cpu family	: 6
model		: 23
model name	: Intel(R) Xeon(R) CPU           L5430  @ 2.66GHz
stepping	: 10


Allocate Port Service[0000:05:01.0:pcie20]
Allocate Port Service[0000:05:01.0:pcie21]
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
ACPI (exconfig-0456): Dynamic SSDT Load - OemId [HP    ] OemTableId [   SSDT0] [20060707]
ACPI (exconfig-0456): Dynamic SSDT Load - OemId [HP    ] OemTableId [ CPU0CST] [20060707]
ACPI: CPU0 (power states: C1[C1] C2[C2] C3[C3])
ACPI (exconfig-0456): Dynamic SSDT Load - OemId [HP    ] OemTableId [   SSDT1] [20060707]
ACPI (exconfig-0456): Dynamic SSDT Load - OemId [HP    ] OemTableId [ CPU1CST] [20060707]
ACPI: CPU4 (power states: C1[C1] C2[C2] C3[C3])
ACPI (exconfig-0456): Dynamic SSDT Load - OemId [HP    ] OemTableId [   SSDT2] [20060707]
ACPI (exconfig-0456): Dynamic SSDT Load - OemId [HP    ] OemTableId [ CPU2CST] [20060707]
ACPI: CPU2 (power states: C1[C1] C2[C2] C3[C3])
ACPI (exconfig-0456): Dynamic SSDT Load - OemId [HP    ] OemTableId [   SSDT3] [20060707]
ACPI (exconfig-0456): Dynamic SSDT Load - OemId [HP    ] OemTableId [ CPU3CST] [20060707]
ACPI: CPU6 (power states: C1[C1] C2[C2] C3[C3])
ACPI (exconfig-0456): Dynamic SSDT Load - OemId [HP    ] OemTableId [   SSDT4] [20060707]
ACPI (exconfig-0456): Dynamic SSDT Load - OemId [HP    ] OemTableId [ CPU4CST] [20060707]
ACPI: CPU1 (power states: C1[C1] C2[C2] C3[C3])
ACPI (exconfig-0456): Dynamic SSDT Load - OemId [HP    ] OemTableId [   SSDT5] [20060707]
ACPI (exconfig-0456): Dynamic SSDT Load - OemId [HP    ] OemTableId [ CPU5CST] [20060707]
ACPI: CPU5 (power states: C1[C1] C2[C2] C3[C3])
ACPI (exconfig-0456): Dynamic SSDT Load - OemId [HP    ] OemTableId [   SSDT6] [20060707]
ACPI (exconfig-0456): Dynamic SSDT Load - OemId [HP    ] OemTableId [ CPU6CST] [20060707]
ACPI: CPU3 (power states: C1[C1] C2[C2] C3[C3])
ACPI (exconfig-0456): Dynamic SSDT Load - OemId [HP    ] OemTableId [   SSDT7] [20060707]
ACPI (exconfig-0456): Dynamic SSDT Load - OemId [HP    ] OemTableId [ CPU7CST] [20060707]
ACPI: CPU7 (power states: C1[C1] C2[C2] C3[C3])
ACPI: Thermal Zone [THM0] (8 C)
Comment 15 Kipp Glover 2009-06-03 10:03:30 EDT
Yesterday I replaced the processor in my BL460c G1 with a E5405 proc.  I still did not see the error.  I will try and source a second E5405 proc to add.   I also tried some older BIOS revisions, but still did not see the error. 

If anybody with a HP server has this issue, can you please get me the file /proc/cpuinfo and also the BIOS revision.  Also please check you BIOS setting (Processor power control).  I would like to see the BIOS reset back to the defaults and see if the issue still occurs. 

I was just did a standard RHEL 5.3 Install  2.6.18-128.el5 (x86_64).
Comment 17 Frederic Medery 2009-06-07 09:58:42 EDT
Created attachment 346785 [details]
ouptut of /proc/cpuinfo

I had the same bug today on 2 of 3 xen cluster nodes. Same HW for all nodes :
Vendor: HP
Version: P56
Release Date: 09/29/2008
Product Name: ProLiant DL380 G5

I attached the cpuinfo ouptut
Comment 18 Kipp Glover 2009-06-08 11:51:30 EDT
Frederic in Comment #17, your server is not running the latest BIOS revision from HP.  Can you please update to the latest 11.01.2008 and see if you still have the same issue.  

Since only 2 of the 3 nodes have this issue can you please provide the same information you provided (BIOS, server, /proc/cpuinfo) for the working server. 

Thanks!
Comment 19 Frederic Medery 2009-06-08 18:08:37 EDT
I just updated all servers with the latest BIOS and all errors are gone.

Tx Kipp !
Comment 20 Mark Goodwin 2009-06-08 19:55:26 EDT
Frederic, that's good news. For the record, could you please post the
BIOS version number. An earlier post from HP said this was dated
11.01.2008, but it would be good if we had the version numbers posted
too, just to close this out cleanly.

Thanks
-- Mark Goodwin, RedHat Support Engineering Group.
Comment 21 Frederic Medery 2009-06-09 10:28:48 EDT
Sure.
Info about the servers :
HP ProLiant DL380 G5 36 GB of RAM used as Dom0 in a Xen/RH Cluster setup.


What is strange is that the Version is still P56 BUT the Release Date is now 11/01/2008 (instead of 09/29/2008).

So To fixe the problem you need the BIOS with at least a Release Date of 11/01/2008.
Comment 22 Kipp Glover 2009-06-09 11:54:22 EDT
The P56 is not the BIOS version.  It is the BIOS family meaning that it is for the DL380 G5 server.  You will see the P56 on all DL380 G5 BIOS revisions.  

The date 11/01/2008 tells us the version of the BIOS you are running on the server. 

Glad to hear that this resolved your issue. 

Cheers!
/Kipp
Comment 24 Robert Lopez 2009-06-15 12:27:46 EDT
Each of the systems I reported have this result

dmidecode | grep -e Date -e Vendor -e Version -e Product | head -n 4 
	Vendor: HP
	Version: P58
	Release Date: 08/03/2008
	Product Name: ProLiant DL360 G5
Comment 25 Kipp Glover 2009-06-15 17:56:01 EDT
Robert,  

Please update the ROM on your three DL360 G5 servers to the 11.2.2008 ROM  for the DL360 G5 and let me know if still have the issue. 

Cheers!
/Kipp
Comment 27 Chris Van Hoof 2009-06-24 14:03:46 EDT

(In reply to comment #25)
> Robert,  
> 
> Please update the ROM on your three DL360 G5 servers to the 11.2.2008 ROM  for
> the DL360 G5 and let me know if still have the issue. 
> 
> Cheers!
> /Kipp  

Kipp we updated at my customers site and so far no errors.  I appreciate the assistance.

--chris
Comment 28 Kipp Glover 2009-06-24 15:56:13 EDT
In reference to (Comment #27),  the customer was running BL460c G1 servers.  The ROM supplied is the 5.12.2009 (released on June 12th).  This ROM resolved this issue on the BL460c G1 servers and is available on hp.com.

Do you think we can close this with the resolution being the updated system ROM? 

Cheers!
/Kipp

Note You need to log in before you can comment on or make changes to this bug.