Bug 491676 - (cluster.ng, sleeptime) system-config-cluster cluster.ng - ip sleeptime not defined
system-config-cluster cluster.ng - ip sleeptime not defined
Status: CLOSED DUPLICATE of bug 606826
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-cluster (Show other bugs)
5.2.z
All Linux
low Severity high
: rc
: ---
Assigned To: Ryan McCabe
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-23 11:26 EDT by Gaetan QUENTIN
Modified: 2010-11-09 08:27 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-01 15:07:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gaetan QUENTIN 2009-03-23 11:26:25 EDT
Description of problem:
/usr/share/cluster/ip.sh allow to use a "sleeptime" attribut in IP ressources in cluster.conf.

cluster.ng, used with xmllint, do not understand this attribut.

Version-Release number of selected component (if applicable):

rgmanager-2.0.43-1.el5
system-config-cluster-1.0.55-1.0


How reproducible:


Steps to Reproduce:
1. in /etc/cluster/cluster.conf : declare a ip ressource like this:
<ip ref="192.***" sleeptime="0">

2. propagate the config with ccs_tool update /etc/cluster/cluster.conf

3. Test the service with the IP: start, stop. The sleeptime attribut is well taken.

4. Test xml file:
do:
xmllint --shell --relaxng /usr/share/system-config-cluster/misc/cluster.ng cluster.conf


  
Actual results:

/etc/cluster/cluster.conf:51: element ip: Relax-NG validity error : Invalid attribute sleeptime for element ip
Relax-NG validity error : Extra element rm in interleave
/etc/cluster/cluster.conf:2: element cluster: Relax-NG validity error : Element cluster failed to validate content
/etc/cluster/cluster.conf fails to validate

Expected results:
/etc/cluster/cluster.conf validates

Additional info:

"sleeptime" is miising from cluster.ng
Comment 1 Lon Hohberger 2010-07-01 15:07:30 EDT

*** This bug has been marked as a duplicate of bug 606826 ***

Note You need to log in before you can comment on or make changes to this bug.