Bug 491725 - RFE: Trivial USB Installation Method (distribute .img files)
RFE: Trivial USB Installation Method (distribute .img files)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-23 14:46 EDT by Daniel Qarras
Modified: 2014-03-16 23:18 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-23 16:45:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Qarras 2009-03-23 14:46:42 EDT
Description of problem:

Fedora installation from USB stick should be trivial to do and possible from small (128 MB or at least 256 MB) USB sticks. People using other distributions that Fedora should also be able to transfer the installation image to a USB stick with standard tools, like dd. So basically something for USB what boot.iso is for CD/DVD is needed.

Ideally, it should be possible to do something like this:

# wget http://path/to/fedora/os/images/usb.img
# dd if=./usb.img of=/dev/sdb

I am aware of live image and possibility to install Fedora from there but it takes huge amount of space, it is pointless to boot to a live system when one wants to install to hard drive, and its creation is cumbersome especially on non-Fedora systems.
Comment 1 Chris Lumens 2009-06-08 14:44:30 EDT
I think the liveusb-creator tools has a program that allows you to create a "boot.iso" USB drive out of the existing images.  At least, this capability sounds really familiar.
Comment 2 Daniel Qarras 2009-09-06 09:19:20 EDT
Hi,

correct, that would be possible but the issue was that why not put such an image already to FTP sites? After that users of other distributions / operating systems could just download it for use - not everyone can run liveusb-creator.

Thanks.
Comment 3 Christopher Beland 2009-09-11 03:59:29 EDT
I think instead of "dd" above, you want to use "livecd-iso-to-disk", which can put any ISO intended for a CD or DVD onto a USB stick.  See:

https://fedoraproject.org/wiki/How_to_create_and_use_Live_USB#Command_Line_Method_-_Linux_only

Does that satisfy your request?

This bug is filed against liveusb-creator, which is a graphical program that runs under Linux or Windows, that does pretty much the same thing as the command-line livecd-iso-to-disk.
Comment 4 Daniel Qarras 2009-09-11 17:12:52 EDT
Thanks for looking into this.

I originally filed this against anaconda since this is related to system installation. As said, I am hoping to see a trivial method to create a bootable Fedora USB install stick with standard tools on non-Fedora distributions or even on Windows.

Please take this constructively: if you compare these two guides for those who want to use USB stick for booting the OS installer, I'm pretty sure you'll see differences:

https://fedoraproject.org/wiki/How_to_create_and_use_Live_USB
https://help.ubuntu.com/community/Installation/FromImgFiles

So basically I'd just like to see alongside boot.iso also boot.img under Fedora/i386/os/images/ on FTP sites.

I realize that liveusb-creator is probably wrong component for this, please readjust if needed.

Thanks!
Comment 5 Christopher Beland 2009-09-22 13:12:54 EDT
I'm not sure why .img+dd is much better than .iso+livecd-iso-to-disk.  It looks like the distribution intentionally changed to ISO-only in Fedora 9:

http://docs.fedoraproject.org/release-notes/f9/en_US/sn-Installer.html#sn-Changes-in-Anaconda

But it's not up to me to decide.  Since this would be a change to the way the software is distributed, changing component to "distribution" and leaving for release engineering folks.
Comment 6 Christopher Beland 2009-10-20 11:21:17 EDT
It sounds like this feature is now available in Fedora 12.  From the F12 Beta release announcement:

>>
* Hybrid live images - The Live images provided in this release can be
directly imaged onto a USB stick using dd (or any equivalent tool) to
create bootable Live USB keys. The Fedora Live USB Creator for Windows
and the livecd-tools for Fedora are still recommended for data
persistence and non-destructive writes. Thanks to Jeremy Katz.
<<
Comment 7 Daniel Qarras 2009-10-23 15:59:32 EDT
Actually no, what I mean is to have for USB as is

fedora/linux/releases/test/12-Beta/Fedora/i386/iso/Fedora-12-Beta-i386-netinst.iso

for CD/DVD. I see

fedora/linux/releases/test/12-Beta/Live/i686/F12-Beta-i686-Live.iso

but that's a Live image, not the installer image. Ok, one could perhaps use it for installation but that would be rather clumsy. I really do not see why this couldn't be done easily, all what would be needed is to provide Fedora-12-Beta-i386-netinst.img so just using extlinux in addition to syslinux when creating these images. That .img file could then dd'ed to a USB stick and start installation.
Comment 8 Jesse Keating 2009-10-23 16:45:50 EDT
netinst.iso is the hybrid iso.  You can dd it to a USB stick.
Comment 9 Daniel Qarras 2009-10-24 08:06:07 EDT
Thanks for the info. I tested the image but it failed. However, since it seems to be an anaconda issue I filed bug 530710.

Perhaps the suitability of this ISO image for USB should be documented since this took half a year and four people were involved until this got cleared out.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.