Bug 491772 - Yum exited with a traceback when a lock was freed
Yum exited with a traceback when a lock was freed
Status: CLOSED DUPLICATE of bug 491482
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-23 18:46 EDT by Bruno Wolff III
Modified: 2014-01-21 18:08 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-23 23:15:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2009-03-23 18:46:06 EDT
Description of problem:
I started a second copy of yum to do some local updates and when the first copy finished the second exited with a traceback instead of doing the work. I do this fairly often and never saw it do this before.

Version-Release number of selected component (if applicable):
yum-3.2.21-16.fc11.noarch

How reproducible:
Unknown, but probably less than 100%

Steps to Reproduce:
1.
2.
3.
  
Actual results:
[root@bruno bruno]# yum update -y --nogpgcheck kern*279*
/usr/lib/yum-plugins/merge-conf.py:22: DeprecationWarning: the md5 module is deprecated; use hashlib instead
  import os, sys, md5
Loaded plugins: allowdowngrade, dellsysidplugin, dellsysidplugin2, keys, list-
              : data, merge-conf, priorities, protect-packages, protectbase,
              : refresh-packagekit, upgrade-helper, verify, versionlock
Existing lock /var/run/yum.pid: another copy is running as pid 28168.
Another app is currently holding the yum lock; waiting for it to exit...
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 306, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 170, in main
    show_lock_owner(e.pid)
  File "/usr/share/yum-cli/yummain.py", line 104, in show_lock_owner
    if data[1].endswith(' kB'):
IndexError: list index out of range


Expected results:


Additional info:
Comment 1 James Antill 2009-03-23 23:15:17 EDT

*** This bug has been marked as a duplicate of bug 491482 ***

Note You need to log in before you can comment on or make changes to this bug.