Bug 491837 - WINE completely broken in F10 after the latest update: it is not able to start anymore.
WINE completely broken in F10 after the latest update: it is not able to star...
Status: CLOSED DUPLICATE of bug 491813
Product: Fedora
Classification: Fedora
Component: wine (Show other bugs)
rawhide
i686 Linux
low Severity high
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-24 07:37 EDT by Michele Belluomini
Modified: 2009-03-26 06:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-26 06:57:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michele Belluomini 2009-03-24 07:37:52 EDT
Description of problem:
After a system update by "yum update" (I don't exactly remember which packages were updated, I am sure only about something related to xorg-x11...) wine suddenly doesn't work anymore.
I tried to remove the ".wine" dir, then to uninstall wine and to install it again: I had no success, no way :-(
Neither winecfg is able to run, it hangs also from command line...

Version-Release number of selected component (if applicable):
i)   system: Linux xxx 2.6.27.19-170.2.35.fc10.i686 #1 SMP Mon Feb 23 13:21:22 EST 2009 i686 i686 i386 GNU/Linux
ii)  wine: wine-1.1.15-1.fc10.i386
iii) xorg: xorg-x11-server-Xorg-1.5.3-15.fc10.i386

How reproducible:
Let's do the latest update and try to use wine.

Steps to Reproduce:
1. yum update
2. winecfg (or anything from wine graphical interface menu)
3. 
  
Actual results:


Expected results:


Additional info:
Before the update wine perfectly run fine.
Please let me know which conf/log file could you help to investigate on the bug, I'll provide it to you.
Comment 1 Jon Dufresne 2009-03-24 11:30:06 EDT
Please provide a stack trace of the problem. Make sure you have all debug packages installed. Please see http://fedoraproject.org/wiki/StackTraces for information on obtaining a stack trace.

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Michele Belluomini 2009-03-25 13:45:16 EDT
The application does not crash, it simply hang... for some reason (I guess something related to some selinux new policy imported with the latest update) the window does not come up.
From the super user wine works fine :-/

Hoping that help you in find an explanation to that.

PS:
[user@host :~]$ rpm -qa|grep -i selinux
selinux-policy-3.5.13-49.fc10.noarch
libselinux-devel-2.0.73-1.fc10.i386
libselinux-2.0.73-1.fc10.i386
libselinux-utils-2.0.73-1.fc10.i386
libselinux-python-2.0.73-1.fc10.i386
selinux-policy-targeted-3.5.13-49.fc10.noarch
Comment 3 Jon Dufresne 2009-03-25 22:41:20 EDT
This looks like bug 491813. Can you post the output of "rpm -q libX11"?
Comment 4 Michele Belluomini 2009-03-26 04:56:25 EDT
Here it is:
[user@host :~]$ rpm -qa|grep  X11
libX11-devel-1.1.5-1.fc10.i386
libX11-1.1.5-1.fc10.i386

Thanks for your help, I am going to have a look to the bug 491813 you point at so to figure out what's happening.
Thanks again all of you.
Comment 5 Michele Belluomini 2009-03-26 05:10:21 EDT
Hi,
at comment 15 of the bug 491813 I've found a similar problems of that I arose in this bug I created.
Daniel Sjoholm (steelside@gmail.com) had similar problem (hanging!) using some X applications (including "wine") having in the system the libX11-1.1.5.1.fc10.i386 installed as well.

May be this bug ticket should be closed and may be attached/linked to the bug 491813.

Thanks all of you, your help is so precious...
you are the added value!
Comment 6 Michele Belluomini 2009-03-26 06:57:32 EDT

*** This bug has been marked as a duplicate of bug 491813 ***

Note You need to log in before you can comment on or make changes to this bug.