Bug 491813 - various problems after upgrading to last version (libX11-1.1.5-1.fc10.i386)
various problems after upgrading to last version (libX11-1.1.5-1.fc10.i386)
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: libX11 (Show other bugs)
10
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
: 491837 491915 491979 492085 492102 492132 492143 492219 492261 492500 492505 492525 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-24 02:58 EDT by Haim Ashkenazi
Modified: 2009-12-13 06:50 EST (History)
57 users (show)

See Also:
Fixed In Version: 1.1.5-3.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 491979 (view as bug list)
Environment:
Last Closed: 2009-03-27 10:51:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The imsettings crash report (229.53 KB, text/plain)
2009-03-24 02:58 EDT, Haim Ashkenazi
no flags Details
Traces created with strace for skype and vlc (43.58 KB, application/x-gzip)
2009-03-24 18:06 EDT, Johannes Postler
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 20897 None None None Never

  None (edit)
Description Haim Ashkenazi 2009-03-24 02:58:40 EDT
Created attachment 336427 [details]
The imsettings crash report

Description of problem:
After last update (which includes several packages, but only when I reverted this package the problem disappeared) I experienced a few problems:

1. Whenever I logged in and started some java systray application (which is the first application I run when I log in) it wouldn't appear in the systray but imsettings-applet would crash (see attached file).
2. opera wouldn't start
3. Almost all java gui applications wouldn't run (accept input - maybe because of imsettings crash).

All of the java applications are running with java 6u12 from SUN.

reverting to version 1.1.4-6 solved this (I also reverted xorg-x11-drv-vesa and gtk2 but reverting these didn't solve the problem).

Version-Release number of selected component (if applicable):
libX11-1.1.5-1.fc10.i386

How reproducible:
I don't know. try running opera or some java gui applications with SUN's jdk.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
compiz window manager (not sure if it's connected).
Comment 1 bobpoljakov 2009-03-24 09:00:39 EDT
Same situation here. After updating to libX11-1.1.5-1.fc10.i386, java applications and VirtualBox stopped working. After i start them, i can see them on the process list. I tried to switch user in terminal and worked for that user, but not for the user logged in to gnome
Comment 2 Luis Garrido 2009-03-24 09:59:24 EDT
Same here, problem seems to affect to all Qt4 applications, which get stuck before opening up any window. I launched one from the CLI with gdb (qtconfig-qt4) and interrupted it with Ctrl-C: it seemed caught up in some part of the event loop.

Reverting to 1.1.4-6 will solve the issue.
Comment 3 Mikko Huhtala 2009-03-24 11:55:25 EDT
I can also confirm this. The latest Emacs 23 pretest compiled with Xft support would not start at all on libX11-1.1.5. The Java GUI app FigTree-1.2.2 opens a window and displays widgets but hangs immediately after that. These were reproducible every time the programs were started. Reverting to Xlib-1.1.4-6 fixed the problems.
Comment 4 T. ONAY 2009-03-24 17:29:16 EDT
Same problems here. Now i've updated libX11-1.1.5-1.fc10.i386, i can't launch Netbeans neither Virtualbox.
When i run Netbeans the progress bar freezes at "Loading core modules".
imsettings crashes too.

I've switched from compiz to metacity without better results.
libX11-1.1.5-1 has too much dependencies to revert to 1.1.4-6

Regards
Comment 5 Johannes Postler 2009-03-24 18:04:36 EDT
I'm also experiencing problems with VLC and Skype. Both start without any errors, but their GUI does not show up. VLC even plays sound, but without showing the movie.

I did try to investigate the Skype problem with strace and will attach the output to this bugreport.

Link to thread in the Skype-forums: http://forum.skype.com/index.php?showtopic=310111
Comment 6 Johannes Postler 2009-03-24 18:06:02 EDT
Created attachment 336557 [details]
Traces created with strace for skype and vlc
Comment 7 DiGGeR2 2009-03-24 18:57:49 EDT
Additional information for Skype... it run when launch it with root access... but not when I'm a normal user.
Comment 8 Hubert Verstraete 2009-03-25 07:12:09 EDT
Oops I had not seen that bug and therefore created another bug #492085
The problem is that the function XOpenIM never ends, so the programs get stuck.
Comment 9 Kelvin J. Hill 2009-03-25 08:01:49 EDT
Opera (opera-9.64.gcc4-shared-qt3.i386.rpm) no longer functions after the update on my 2 Fedora10 systems. It will run as root, but not as a non-priv user.
Comment 10 Rackam 2009-03-25 11:41:41 EDT
Same thing with Mathematica and qt-octave, both using qt, whtether root or normal user. Had to downgrade libX11.
Comment 11 Paul Lipps 2009-03-25 13:01:18 EDT
I cannot launch Stellarium on Fedora 10 after updating the libX11 on March 24, 09. No error is given, just a blinking cursor in the terminal window when launched via terminal.

From my yum.log:

Mar 24 07:17:21 Updated: libX11-1.1.5-1.fc10.i386

I downgraded to libX11-1.1.4-6.fc10.i386.rpm by downloading the rpm from here:

http://koji.fedoraproject.org/koji/buildinfo?buildID=70105

and then performed the following command:

rpm -Uvh --oldpackage --replacepkgs libX11*.rpm

After restarting the X server, I was able to launch Stellarium successfully.
Comment 12 bloodandsoil76 2009-03-25 13:17:51 EDT
After yum update to libX11-1.1.5-1.fc10.i386, the two 3D games that I play--neverwinter nights and urban terror--fail to load.  Either from a launcher or from terminal, they just simply fail to load without any error output.  After downgrading to the previous version libX11-1.1.4-6.fc10.i386 and rebooting, both of the 3D games work again.
Comment 13 Nelson Chan 2009-03-25 13:19:32 EDT
I just want to say that everything is still fine after i updated libX11 on my box. I tested Google Earth and Torcs, they all good. and i run KDE with kwin enabled.
the video card i used is : VGA compatible controller: ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500]
and its driver in use :  Kernel modules: radeonfb, radeon
Comment 14 Jason Farrell 2009-03-25 13:22:45 EDT
FWIW, i cannot reproduce any of the above problems on f10 x86_64 (w/ nvidia binary) after getting the libX11-1.1.5-1.fc10.* updates back on March 5th from updates-testing. Perhaps interaction with other updates from updates-testing or rpmfusion-nonfree-updates-testing makes the difference.
Comment 15 Daniel Sjoholm 2009-03-25 13:36:56 EDT
I got this same problem, so i did the same like #11, and these 3 applications which suddenly stopped to work a few days ago started to work again:
Wine,Kdevelop,Quanta+
F10 i386, using the proprietary nvidia driver from rpmfusion.
Comment 16 Scott Williams 2009-03-25 13:42:55 EDT
This has been a common complaint by several users in #Fedora today.  It seems to be affecting a wide user base.
Comment 17 Luis Garrido 2009-03-25 13:51:33 EDT
(In reply to comment #14)
> FWIW, i cannot reproduce any of the above problems on f10 x86_64 (w/ nvidia
> binary) after getting the libX11-1.1.5-1.fc10.* updates back on March 5th from
> updates-testing. Perhaps interaction with other updates from updates-testing or
> rpmfusion-nonfree-updates-testing makes the difference.  

Maybe. This is a list of my active repos:

 * epel
 * livna
 * rpmfusion-nonfree-updates
 * fedora
 * rpmfusion-free-updates
 * rpmfusion-free
 * rpmfusion-nonfree
 * updates

As further deviations from the standard, I am using the planetccrma kernel-rt (2.6.26.8-1.rt16.1.fc10.ccrma.i686.rt) and installed customized versions of some packages (pixman, freetype, fontconfig, libXft & cairo) to get improved control on the font rendering as described here (I don't care for Gnome hijacking my .fonts.conf settings):

http://forums.fedoraforum.org/showthread.php?t=186789
Comment 18 Paul Lipps 2009-03-25 15:26:28 EDT
I failed to state on my comment #11 that I am using the kmod-nvidia-PAE package from RPMFusion running F10 i386. (PAE)

Linux hostname 2.6.27.19-170.2.35.fc10.i686.PAE #1 SMP Mon Feb 23 13:09:26 EST 2009 i686 i686 i386 GNU/Linux

Name       : kmod-nvidia-PAE
Arch       : i686
Version    : 180.29
Release    : 1.fc10.1


I can also confirm that it does not seem to be an issue with any testing repos, as I have none enabled.

 * livna
 * fedora
 * rpmfusion-free-updates
 * rpmfusion-nonfree-updates
 * rpmfusion-free
 * updates
 * rpmfusion-nonfree
Comment 19 pinguino 2009-03-25 17:14:00 EDT
I downgrade libX11-1.1.5-1 to libX11-1.1.4-5; Skype is working again.
Comment 20 Ilya Ryabinkin 2009-03-25 18:05:46 EDT
> Version-Release number of selected component (if applicable):
> libX11-1.1.5-1.fc10.i386

I confirm this bug. emacs, lyx simply do no start. Running for instance strace lyx, one may see:

read(9, 0x95692dc, 4096)                = -1 EAGAIN (Resource temporarily unavailable)
select(10, [9], [], NULL, NULL)         = 1 (in [9])
read(9, "\34\326\355\1\200\0\0\0W\1\0\0kT\32\0\0004\211\277\372\250\10\10X4\211\277\200\0\0\0\34"..., 4096) = 64
read(9, 0x95692dc, 4096)                = -1 EAGAIN (Resource temporarily unavailable)
select(10, [9], [], NULL, NULL^C <unfinished ...>
Comment 21 Mikko Huhtala 2009-03-25 18:30:56 EDT
I see the problem on a system that only has Fedora RPMs installed (no RPM Fusion or others). The graphics card is 

01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R200 QL [Radeon 8500 LE]

and Xorg.0.log says

(II) Module radeon: vendor="X.Org Foundation"
        compiled for 1.5.3, module version = 6.10.0
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 4.1

Using libX11-1.1.5-1, Java GUI programs hang, and reverting to libX11-1.1.4 fixes the problem. The problem does not seem to be with the proprietary drivers (I've also tested F10 systems with the Nvidia driver and they behave in the same way).
Comment 22 Stuart D Gathman 2009-03-25 18:43:43 EDT
I found that xterm would not load with libX11-1.1.5.  It would just hang - no window, no crash.  I would have to open a gnome-terminal and kill the xterms.  (Glad there are two terminal apps.)  Downgrading only libX11 to libX11-1.1.4 fixed the problem.
Comment 23 Charles Tryon 2009-03-25 20:06:20 EDT
I have the same behaviour.  I noticed it first with Skype, but found that Opera was having problems too.  It would bring up the window boarder and decorations, but nothing inside of it.

Reverting to 1.1.4-5.fc10 (from rpmfind) fixed the problem.
Comment 24 Peter Hutterer 2009-03-25 20:25:11 EDT
*** Bug 492085 has been marked as a duplicate of this bug. ***
Comment 25 Peter Hutterer 2009-03-25 20:25:36 EDT
*** Bug 492143 has been marked as a duplicate of this bug. ***
Comment 26 Peter Hutterer 2009-03-25 20:50:15 EDT
Weird. I can't reproduce it, at least not consistently. quanta sometimes freezes but usually only once immediately after login. The same happends sometimes with 1.1.4 though.

Anyway, I looked at the commit log between 1.1.4 and 1.1.5 and there's only one commit that may cause this issue. Please try the scratch build below, it has this one commit reverted.

http://koji.fedoraproject.org/koji/taskinfo?taskID=1258987
Comment 27 Stuart D Gathman 2009-03-25 21:16:51 EDT
I upgraded to libX11-1.1.5-2 linked above, and xterm still works (xterm was broken with 1.1.5-1).
Comment 28 Tom Davidson 2009-03-25 21:49:17 EDT
Installing libX11-1.1.5-2 (and libX11-devel) linked at comment #26 and restarting X did *NOT* fix this problem for me.

I can't launch emacs either from the command line or from the 'Fedora' menu. 'su'ing to superuser doesn't help, but I *can* launch it using 'sudo emacs'. (I can also launch emacs text-only using the -nw option)

I also can't run Matlab, haven't tried many other apps. Firefox works, as does gnome-terminal.

I have this problem whether I use the 'radeon' module, or the proprietary fglrx drivers from the rpmfusion repo.

About to try the 1.1.4-6 downgrade and see if that helps any.
Comment 29 Tom Davidson 2009-03-25 21:56:40 EDT
While Peter's 1.1.5-2 did not help, downgrading to 1.1.4-6 as per comment #11 did fix the issue.

I'd say the severity deserves to be more than 'medium'--many users will find their systems unusable until it's fixed.

Happy to report any more needed details on my system on request.
Comment 30 Charles Tryon 2009-03-25 22:32:58 EDT
I tried the 1.1.5-2 rpms linked to here, and this did NOT fix the problem for
me.  Both Skype and Opera hang almost immediately on start.

I am using the nvidia (xorg-x11-drv-nvidia-96xx-96.43.11-1.fc10.i386) drivers
from rpmfusion.
Comment 31 Chuck Liggett 2009-03-25 22:41:26 EDT
I experienced the same problem and reported it on a different bug report that
was consolidated into this one where I noted that xmms and xterm both were
experiencing this problem.

An strace revealed that reads on /tmp/.X11-unix/X0 where looping on EAGAIN
errors.

This afternoon, I downgraded from libX11-1.1.5-1 to libX11-1.1.4-6 and the
problem went away.

I have just again, re-upgraded libX11 back to 1.1.5-1 so I can test the patch
put forth by Peter Hutterer and I must unfortunately agree with Tom Davidson
that indeed the problem has not been resolved with the scratch build 1.1.5-2.
Comment 32 Peter Hutterer 2009-03-25 22:51:15 EDT
We did some bisecting on IRC and found that the following build seems to work:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1259084

Can you confirm this?
Comment 33 Tom Davidson 2009-03-25 23:00:12 EDT
Yes, this one works here.

I yum updated from 1.1.4-6 to 1.1.5-1 to confirm that I could still see the problem, then I downloaded and yum localinstalled the 1.1.5-9 packages linked at comment #32 and restarted X. All symptoms disappeared.

Thanks for the late night hacking, Peter!
Comment 34 Anthony Horton 2009-03-25 23:14:16 EDT
Ditto, 1.1.5-1 broke Skype for me but the 1.1.5-9 package that Peter links to fixed it.
Comment 35 Peter Hutterer 2009-03-25 23:25:17 EDT
Ok, last one, just to make sure it was the right patch:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1259096

Note that this has a -2 version, I'm planning to commit this one.
The -9 scratch had two patches reverted, the one in the -2 scratch build above and another one. I think it's just the second patch that needs to be reverted. If this scratch build works, I'll commit it and push the update out.
Comment 36 Tom Davidson 2009-03-25 23:33:04 EDT
Yes, the new 1.1.5-2 (i386 build linked from comment #35) fixes the problem here.
Comment 37 Anthony Horton 2009-03-25 23:37:03 EDT
Tom beat me to it by a matter of minutes... but yes, the new 1.1.5-2 also works fine for me.
Comment 38 Fedora Update System 2009-03-25 23:58:51 EDT
libX11-1.1.5-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/libX11-1.1.5-2.fc10
Comment 39 T. ONAY 2009-03-26 03:41:30 EDT
When i try to install the new packages, i've the following message :

rpm -ivh libX11-1.1.5-2.fc10.i386.rpm libX11-devel-1.1.5-2.fc10.i386.rpm 
Preparing...                ########################################### [100%]
	file /usr/share/X11/locale/en_US.UTF-8/Compose from install of libX11-1.1.5-2.fc10.i386 conflicts with file from package libX11-1.1.5-1.fc10.i386

Any solution ?
Comment 40 T. ONAY 2009-03-26 03:43:29 EDT
(In reply to comment #39)
> When i try to install the new packages, i've the following message :
> 
> rpm -ivh libX11-1.1.5-2.fc10.i386.rpm libX11-devel-1.1.5-2.fc10.i386.rpm 
> Preparing...                ########################################### [100%]
>  file /usr/share/X11/locale/en_US.UTF-8/Compose from install of
> libX11-1.1.5-2.fc10.i386 conflicts with file from package
> libX11-1.1.5-1.fc10.i386
> 
> Any solution ?  

it worked with : yum install libX11-1.1.5-2.fc10.i386.rpm libX11-devel-1.1.5-2.fc10.i386.rpm --nogpgcheck
Comment 41 Schtroumpf grognon 2009-03-26 04:49:44 EDT
I had the same problem with VLC and ATI-Catalyst-Control-Center. Downloading the following packages: libX11-1.1.5-2.fc10.i386.rpm and libX11-devel-1.1.5-2.fc10.i386.rpm and installing them with #rpm -Uvh --replacepkgs libX11*.rpm fixed the problem.
Comment 42 Jindrich Novy 2009-03-26 04:59:06 EDT
*** Bug 492219 has been marked as a duplicate of this bug. ***
Comment 43 Jonathan Underwood 2009-03-26 06:19:10 EDT
This also breaks emacs - see bug 491979.
Comment 44 Kieran Clancy 2009-03-26 06:19:24 EDT
FWIW I am getting the same problem with various gnome-config-* programs, evince and texdoc.
Comment 45 Jonathan Underwood 2009-03-26 06:26:59 EDT
*** Bug 491979 has been marked as a duplicate of this bug. ***
Comment 46 Jonathan Underwood 2009-03-26 06:44:07 EDT
The libX11-1.1.5-2 packages fix the emacs problem for me.
Comment 47 Kieran Clancy 2009-03-26 06:53:13 EDT
1.1.5-2 from the build system seems to fix it for me.

I don't understand how such a trivial patch could break all these things?!
Comment 48 Michele Belluomini 2009-03-26 06:56:19 EDT
This also breaked wine - see bug 491837
Comment 49 Michele Belluomini 2009-03-26 06:57:32 EDT
*** Bug 491837 has been marked as a duplicate of this bug. ***
Comment 50 Hubert Verstraete 2009-03-26 06:59:47 EDT
1.1.5-2 fixes it: xarkeia, mgdiff and xterm are now working again.

Comment #47 leads to the question: how a package can break all these things when it was first released in update-testing ?
Comment 51 Jonathan Underwood 2009-03-26 07:36:42 EDT
(In reply to comment #50)
> 1.1.5-2 fixes it: xarkeia, mgdiff and xterm are now working again.
> 
> Comment #47 leads to the question: how a package can break all these things
> when it was first released in update-testing ?  

The sad reality is, very few people install and test the updates in updates-testing.
Comment 52 Darryl L. Pierce 2009-03-26 09:34:44 EDT
(In reply to comment #46)
> The libX11-1.1.5-2 packages fix the emacs problem for me.  

Same here. I had to upgrade libX11 and libX11-devel, then reboot.
Comment 53 Stuart D Gathman 2009-03-26 10:06:17 EDT
xterm was broken after upgrading to libX11-1.1.5-1.  It was fixed after upgrading to libX11-1.1.5-2.  However, it stayed fixed while I tried various experimental releases up to 10 confusing the developer.  And it *stayed* fixed when I downgraded back to libX11-1.1.5-1.  So, must have been another bug, we think.  So I upgrade *another* PC (laptop) to libX11-1.1.5-1.  xterm breaks.  Upgrade to libX11-1.1.5-2, and xterm starts working again.  

BTW, it is not necessary to log out and log back in again to test whether xterm is fixed.
Comment 54 Fedora Update System 2009-03-26 10:55:16 EDT
libX11-1.1.5-2.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libX11'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-3065
Comment 55 Rackam 2009-03-26 11:25:37 EDT
Update tested. Mathematica, qt-octave now work. Thanks guys, good job!
Comment 56 Ken Lee 2009-03-26 11:37:21 EDT
I can duplicate the java rendering issue under Gnome, works fine under KDE.  This may be from the latest gtk update.
Comment 57 Ola Thoresen 2009-03-26 13:03:43 EDT
The package in Comment #35 fixed my problems with sun-java-plugin freezing firefox.
Comment 58 pelle2004 2009-03-26 13:35:09 EDT
My xmms stopped due to latest yum.

I found out that is has to with the present of environment variable

XMODIFIERS="@im=imsettings"

Removing it and xmms works.
Comment 59 pelle2004 2009-03-26 13:59:56 EDT
Comment #58 with 1.1.5-1.fc10
Comment 60 Michael J Gruber 2009-03-26 15:51:54 EDT
This seems to be a problem on x86_64 also. pinentry-qt would not start up any more. Installing 1.1.5-2.fc10 from koji fixed the problem.
So, platform += x86_64, and pushing the 64 bit build to updates?
Comment 61 Bob Cochran 2009-03-26 17:27:31 EDT
arduino-0013 (from http://www.arduino.cc) works after applying the two rpm's from updates-testing per comment #54. 

Bob
Comment 62 Vinny Murphy 2009-03-26 19:00:58 EDT
https://bugzilla.redhat.com/show_bug.cgi?id=491813#c54 fixed my problem with xterms not showing up.  Thanks.
Comment 63 Peter Hutterer 2009-03-26 20:18:22 EDT
Upstream bug: http://bugs.freedesktop.org/show_bug.cgi?id=20897

libX11-1.1.5-2 has been pushed to stable, thanks for all the feedback. In the interest of keeping the noise down, please don't add any further comments if it was broken for you but has now been fixed with 1.1.5-2.
Comment 64 Rex Dieter 2009-03-26 22:26:05 EDT
*** Bug 492500 has been marked as a duplicate of this bug. ***
Comment 65 Rex Dieter 2009-03-26 23:06:05 EDT
*** Bug 492505 has been marked as a duplicate of this bug. ***
Comment 66 Steve Tyler 2009-03-27 06:39:31 EDT
*** Bug 492102 has been marked as a duplicate of this bug. ***
Comment 67 Rex Dieter 2009-03-27 09:19:17 EDT
*** Bug 492525 has been marked as a duplicate of this bug. ***
Comment 68 Fedora Update System 2009-03-27 10:51:46 EDT
libX11-1.1.5-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 69 Dr John Landstreet 2009-03-30 09:16:01 EDT
Following the release of the latest version of the X11 libraries, this bug has
vanished from my computer. Both emacs and xmgrace appear to run perfectly
normally. THANK YOU VERY MUCH to the person or persons who found the problem
and fixed it.
Comment 70 Peter Hutterer 2009-03-30 20:53:30 EDT
We're still trying to find the cause of the bug upstream. Since we have not seen the issue in rawhide which ships a newer release of libX11 this bug must have been fixed there. A potential cause is a patch that didn't get cherry-picked onto libX11 1.1. May I request users affected by the bug in 1.1.5-1 to try out the scratch build below:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1266817

Note that this may reinstate the bug, so better keep your libX11-1.1.5-2 rpms around. Please let me know if this package works for you.
Comment 71 Miroslav Lichvar 2009-03-31 09:38:36 EDT
*** Bug 492261 has been marked as a duplicate of this bug. ***
Comment 72 Rajeesh 2009-04-01 07:46:44 EDT
In all probability, this update libX11-1.1.5-2 fixed couple of long-standing bugs - "No further keystrokes will be recognized by Java application (here, SAPGui) if I 'miss-pressed' a key", and "No further keystrokes will be recognized by Citrix ICAClient applications after a Java application (SAPGui) starts".

I may be able to confirm this by downgrading to 1.1.5-1, but until then, THANKS!
Comment 73 Peter Hutterer 2009-04-01 19:01:15 EDT
guys, please try to reproduce the bug with the scratch build from 
http://koji.fedoraproject.org/koji/taskinfo?taskID=1266817

it only takes a few minutes of your time and it helps getting upstream better and all other distros that rely on libX11 1.1 stable updates.
Comment 74 Paul Lipps 2009-04-01 20:53:22 EDT
I tested with the new scratch build 1.1.5-2, and I was not able to reproduce the problem. My test case, Stellarium, the application launched as expected.
Comment 75 Paul Lipps 2009-04-01 20:56:05 EDT
Error, that was scratch build 1.1.5-3 from the link in Comment #73
Comment 76 Charles Tryon 2009-04-01 21:42:27 EDT
I went to that link (http://koji.fedoraproject.org/koji/taskinfo?taskID=1266817) and I'm seeing a version 1.1.5-3.  Is THAT the version you want us to test, or was it still called 1.1.5-1 (or -2)?

I'm happy to test, but I want to make sure I'm loading the right rpm.
Comment 77 Peter Hutterer 2009-04-01 21:55:31 EDT
version 1.1.5-3 is the build that needs testing. thanks.
Comment 78 Charles Tryon 2009-04-01 22:40:31 EDT
OK.  I tested the 1.1.5.3 scratch build from the link above, and my results were the same as for Paul.  Both of the applications I tested (Skype and Opera browser) started and operated with no apparent difficulties.

(For testing purposes, since 1.1.5-3 appears to work normally, would you like us to keep using it and report any other anomalies?)
Comment 79 Johannes Postler 2009-04-02 03:14:29 EDT
1.1.5-3 works fine on my system for the testing applications skype and vlc.
Comment 80 davidgf 2009-04-02 10:11:56 EDT
1.1.5-3 works as 1.1.4 used to work!! The performace is goood again!
Thanks a lot! You could push it to stable!
Comment 81 Stuart D Gathman 2009-04-02 22:40:04 EDT
1.1.5-3 not only didn't break xterm, but an annoying glitch in firefox where scrolling would leave "dirt" (removed by zooming and and out) has gone away.
Comment 82 Kieran Clancy 2009-04-03 04:25:57 EDT
1.1.5-3 seems to work fine here - thanks for your hard work.
Comment 83 Peter Hutterer 2009-04-05 21:19:43 EDT
Thanks all for testing. 1.1.5-3 has been committed and will be available in stable soon. Don't forget to give it good karma to accelerate the process :)
Comment 84 Fedora Update System 2009-04-05 21:22:59 EDT
libX11-1.1.5-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/libX11-1.1.5-3.fc10
Comment 85 Peter Hutterer 2009-04-16 19:17:02 EDT
*** Bug 492132 has been marked as a duplicate of this bug. ***
Comment 86 Peter Hutterer 2009-04-16 19:30:02 EDT
*** Bug 491915 has been marked as a duplicate of this bug. ***
Comment 87 Borut Oblak 2009-04-22 11:27:19 EDT
I have 64 bit Fedora 10. When doing regular updates from gnome, I get also  libX11-1.1.5-2.fc10 (i386) as a bug fix update among other updates. This update can not be installed:
 Test Transaction Errors:   file /usr/share/X11/locale/en_US.UTF-8/Compose from install of libX11-1.1.5-2.fc10.i386 conflicts with file from package libX11-1.1.5-1.fc10.x86_64

This is so for weeks now.

I would like to warn that this is a i386 package in x86_64 updates repository! Is this OK? If it is please fix it that it could be installed.
Comment 88 Peter Hutterer 2009-04-22 19:03:57 EDT
Borut: please open a separate bug report for this issue. AFAICT, the koji build was successful with different arch packages. If yum tries to install a i386 file, then something is wrong with yum or the settings.
Comment 89 Fedora Update System 2009-04-24 15:53:57 EDT
libX11-1.1.5-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 90 Dean Stathos 2009-05-28 17:01:31 EDT
I've installed libX11-1.1.5-3.fc10 on my system using fc10, vlc, and ati drivers from rpmfusion and am getting the same results--that is, my desktop hangs.  First the screen hangs, then the system (and the monitor goes blank).  A hard reset is the only way to "recover".

By the way, I uninstalled vlc thinking that was the issue and I no longer can see any video from fc10...  doesn't matter the format/codec...

Let me know what you need and I will provide it...

Thanks!
Comment 91 Dean Stathos 2009-05-28 17:02:51 EDT
By the way, I actually have 1.1.5-4 and still have the same problem...
Comment 92 Dean Stathos 2009-05-28 17:49:46 EDT
OK, sorry about that.  I found my problem.  It had to do with video settings.  Somewhere between installing ATI drivers from rpmfusion and/or vlc, the video settings changed everywhere.

I made the appropriate settings and it was fixed.

I apologize for re-opening this bugfix--please disregard my comments.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.