Bug 491851 - Rawhide installs fail with PartitionException: Attempting to remove a partition that is not owned by any disk.
Rawhide installs fail with PartitionException: Attempting to remove a partiti...
Status: CLOSED DUPLICATE of bug 491845
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
ppc Linux
medium Severity medium
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
anaconda_trace_hash:f6230373d86f19a3b...
:
Depends On:
Blocks: F11Beta/F11BetaBlocker
  Show dependency treegraph
 
Reported: 2009-03-24 09:17 EDT by James Laska
Modified: 2013-09-02 02:33 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-24 09:27:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (79.04 KB, text/plain)
2009-03-24 09:17 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2009-03-24 09:17:24 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.36 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/site-packages/parted/disk.py", line 194, in removePartition
    if self.__disk.remove_partition(partition.getPedPartition()):
  File "/tmp/updates/storage/devicetree.py", line 698, in _removeDevice
    dev.disk.partedDisk.removePartition(dev.partedPartition)
  File "/tmp/updates/storage/devicetree.py", line 732, in registerAction
    self._removeDevice(action.device)
  File "/tmp/updates/storage/__init__.py", line 597, in destroyDevice
    self.devicetree.registerAction(action)
  File "/tmp/updates/storage/partitioning.py", line 332, in clearPartitions
    storage.destroyDevice(part)
  File "/tmp/updates/storage/partitioning.py", line 170, in doAutoPartition
    clearPartitions(anaconda.id.storage)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1317, in nextClicked
    self.anaconda.dispatch.gotoNext()
PartitionException: Attempting to remove a partition that is not owned by any disk.
Comment 1 James Laska 2009-03-24 09:17:29 EDT
Created attachment 336460 [details]
Attached traceback automatically from anaconda.
Comment 2 James Laska 2009-03-24 09:18:36 EDT
Testing updates=http://dlehman.fedorapeople.org/updates-boot.img  for dlehman.
Comment 3 James Laska 2009-03-24 09:27:59 EDT

*** This bug has been marked as a duplicate of bug 491845 ***

Note You need to log in before you can comment on or make changes to this bug.