Bug 491845 - PartitionException: Attempting to remove a partition that is not owned by any disk
PartitionException: Attempting to remove a partition that is not owned by any...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:57e1f88ea8ba6eed7...
:
: 491851 491921 (view as bug list)
Depends On:
Blocks: F11Beta/F11BetaBlocker
  Show dependency treegraph
 
Reported: 2009-03-24 08:45 EDT by Ronald Warsow
Modified: 2009-04-06 04:07 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-06 04:07:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (54.23 KB, text/plain)
2009-03-24 08:45 EDT, Ronald Warsow
no flags Details
Attached traceback automatically from anaconda. (91.72 KB, text/plain)
2009-03-24 09:26 EDT, James Laska
no flags Details
Attached traceback automatically from anaconda. (107.15 KB, text/plain)
2009-03-25 18:54 EDT, Russell Harrison
no flags Details

  None (edit)
Description Ronald Warsow 2009-03-24 08:45:45 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.36 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/site-packages/parted/disk.py", line 194, in removePartition
    if self.__disk.remove_partition(partition.getPedPartition()):
  File "/usr/lib/anaconda/storage/devicetree.py", line 697, in _removeDevice
    dev.disk.partedDisk.removePartition(dev.partedPartition)
  File "/usr/lib/anaconda/storage/devicetree.py", line 731, in registerAction
    self._removeDevice(action.device)
  File "/usr/lib/anaconda/storage/__init__.py", line 600, in destroyDevice
    self.devicetree.registerAction(action)
  File "/usr/lib/anaconda/storage/partitioning.py", line 332, in clearPartitions
    storage.destroyDevice(part)
  File "/usr/lib/anaconda/storage/partitioning.py", line 170, in doAutoPartition
    clearPartitions(anaconda.id.storage)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1317, in nextClicked
    self.anaconda.dispatch.gotoNext()
PartitionException: Attempting to remove a partition that is not owned by any disk.
Comment 1 Ronald Warsow 2009-03-24 08:45:51 EDT
Created attachment 336450 [details]
Attached traceback automatically from anaconda.
Comment 2 Ronald Warsow 2009-03-24 08:52:49 EDT
the above is from an VM install via boot.iso.

chosen was "replace all linux partitions" (iirc), with review the layout.

nothing to review. only the trace above ...
Comment 3 James Laska 2009-03-24 09:26:21 EDT
Created attachment 336461 [details]
Attached traceback automatically from anaconda.
Comment 4 James Laska 2009-03-24 09:27:59 EDT
*** Bug 491851 has been marked as a duplicate of this bug. ***
Comment 5 Joel Andres Granados 2009-03-24 10:22:06 EDT
this should be fixed in the next version of anaconda  11.5.0.37
Comment 6 Joel Andres Granados 2009-03-24 12:51:21 EDT
*** Bug 491921 has been marked as a duplicate of this bug. ***
Comment 7 Orion Poplawski 2009-03-24 12:54:26 EDT
I think it's better to leave bugs open until they are confirmed fixed and the fix is released to avoid duplicates.  I did a search (of open bugs as is the default) before filing but didn't find anything.
Comment 8 Russell Harrison 2009-03-25 18:54:25 EDT
Created attachment 336716 [details]
Attached traceback automatically from anaconda.
Comment 9 David Lehman 2009-03-25 19:30:37 EDT
(In reply to comment #8)
> Created an attachment (id=336716) [details]
> Attached traceback automatically from anaconda.  

I think your mirror has some issues that are causing you to end up with an outdated install.img. There are several entries in the logs that should not be in logs from anaconda-11.5.0.37. Please try to get your tree from somewhere else and see if your problems remain.
Comment 10 Ronald Warsow 2009-04-05 10:55:07 EDT
to be closed !

Note You need to log in before you can comment on or make changes to this bug.