This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 491910 - RAID0 Kickstart install fails - PartitionException: Unable to satisfy all constraints on the partition.
RAID0 Kickstart install fails - PartitionException: Unable to satisfy all con...
Status: CLOSED DUPLICATE of bug 491348
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:3b7dbe6e9b6c3cd55...
:
Depends On:
Blocks: F11Blocker/F11FinalBlocker
  Show dependency treegraph
 
Reported: 2009-03-24 12:01 EDT by James Laska
Modified: 2013-09-02 02:33 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-24 13:00:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (110.70 KB, text/plain)
2009-03-24 12:01 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2009-03-24 12:01:43 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.36 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/site-packages/parted/disk.py", line 181, in addPartition
    constraint.getPedConstraint()):
  File "/tmp/updates/storage/partitioning.py", line 751, in allocatePartitions
    constraint=constraint)
  File "/tmp/updates/storage/partitioning.py", line 553, in doPartitioning
    allocatePartitions(disks, partitions)
  File "/tmp/updates/storage/partitioning.py", line 191, in doAutoPartition
    exclusiveDisks=anaconda.id.storage.clearPartDisks)
  File "/tmp/updates/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/tmp/updates/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/tmp/updates/dispatch.py", line 227, in currentStep
    self.gotoNext()
  File "/tmp/updates/gui.py", line 1350, in setScreen
    (step, anaconda) = self.anaconda.dispatch.currentStep()
  File "/tmp/updates/gui.py", line 1513, in setup_window
    self.setScreen()
  File "/tmp/updates/gui.py", line 1523, in run
    self.setup_window(runres)
  File "/tmp/updates/gui.py", line 1270, in run
    self.icw.run (self.runres)
  File "/tmp/updates/anaconda", line 1033, in <module>
    anaconda.intf.run(anaconda)
PartitionException: Unable to satisfy all constraints on the partition.
Comment 1 James Laska 2009-03-24 12:01:54 EDT
Created attachment 336490 [details]
Attached traceback automatically from anaconda.
Comment 2 James Laska 2009-03-24 12:23:58 EDT
Testing raid0 kickstart install

# Partition clearing information
clearpart --all --initlabel 

# Disk partitioning information
part /boot --asprimary --fstype="ext3" --size=200 --label=BOOT
part  --fstype="swap" --grow --maxsize=3936 --recommended --size=1968 --label=SWAP
part /multi-stage --fstype="ext3" --size=100 --label=MULTISTAGE
part  --grow --size=2048
part  --grow --size=2048
raid /  --device=0 --fstype="ext3" --level=RAID0 raid.01 raid.02
Comment 3 Chris Lumens 2009-03-24 13:00:02 EDT

*** This bug has been marked as a duplicate of bug 491348 ***

Note You need to log in before you can comment on or make changes to this bug.