Bug 491348 - Traceback in partitioning - unable to satisfy constraints
Traceback in partitioning - unable to satisfy constraints
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Joel Andres Granados
Fedora Extras Quality Assurance
anaconda_trace_hash:24225af8310144a9f...
:
: 491493 491910 492471 493140 493498 493502 494029 494184 494807 (view as bug list)
Depends On:
Blocks: F11Blocker/F11FinalBlocker
  Show dependency treegraph
 
Reported: 2009-03-20 11:04 EDT by Orion Poplawski
Modified: 2009-04-14 16:59 EDT (History)
19 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-14 16:59:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (106.77 KB, text/plain)
2009-03-20 11:04 EDT, Orion Poplawski
no flags Details
anaconda-log (6.58 KB, text/plain)
2009-04-01 14:59 EDT, Ronald Warsow
no flags Details
blkid (894 bytes, text/plain)
2009-04-01 14:59 EDT, Ronald Warsow
no flags Details
fdisk (1.24 KB, text/plain)
2009-04-01 15:00 EDT, Ronald Warsow
no flags Details
program.log (163 bytes, text/plain)
2009-04-01 15:00 EDT, Ronald Warsow
no flags Details
storage.log (5.78 KB, text/plain)
2009-04-01 15:01 EDT, Ronald Warsow
no flags Details
syslog (44.28 KB, text/plain)
2009-04-01 15:01 EDT, Ronald Warsow
no flags Details
Traceback while testing 02-04-2009-1351-x86_64.img (124.77 KB, text/plain)
2009-04-02 10:14 EDT, James Laska
no flags Details
anaconda traceback (196.96 KB, text/plain)
2009-04-03 13:27 EDT, Orion Poplawski
no flags Details
anaconda traceback (118.42 KB, text/plain)
2009-04-07 11:55 EDT, Stefan Ring
no flags Details

  None (edit)
Description Orion Poplawski 2009-03-20 11:04:22 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.34 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.6/site-packages/parted/disk.py", line 181, in addPartition
    constraint.getPedConstraint()):
  File "/usr/lib/anaconda/storage/partitioning.py", line 754, in allocatePartitions
    constraint=constraint)
  File "/usr/lib/anaconda/storage/partitioning.py", line 556, in doPartitioning
    allocatePartitions(disks, partitions)
  File "/usr/lib/anaconda/storage/partitioning.py", line 191, in doAutoPartition
    exclusiveDisks=anaconda.id.storage.clearPartDisks)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 227, in currentStep
    self.gotoNext()
  File "/usr/lib/anaconda/gui.py", line 1350, in setScreen
    (step, anaconda) = self.anaconda.dispatch.currentStep()
  File "/usr/lib/anaconda/gui.py", line 1513, in setup_window
    self.setScreen()
  File "/usr/lib/anaconda/gui.py", line 1523, in run
    self.setup_window(runres)
  File "/usr/lib/anaconda/gui.py", line 1270, in run
    self.icw.run (self.runres)
  File "/usr/bin/anaconda", line 1017, in <module>
    anaconda.intf.run(anaconda)
PartitionException: Unable to satisfy all constraints on the partition.
Comment 1 Orion Poplawski 2009-03-20 11:04:27 EDT
Created attachment 336057 [details]
Attached traceback automatically from anaconda.
Comment 2 Chris Lumens 2009-03-23 10:12:14 EDT
*** Bug 491493 has been marked as a duplicate of this bug. ***
Comment 3 Chris Lumens 2009-03-24 13:00:02 EDT
*** Bug 491910 has been marked as a duplicate of this bug. ***
Comment 4 Orion Poplawski 2009-03-25 12:23:46 EDT
Still present with 11.5.0.37 today.
Comment 5 Ronald Warsow 2009-03-26 10:39:16 EDT
and 11.5.0.38
Comment 6 James Laska 2009-03-26 12:11:21 EDT
My bug#491910 was found during a RAID kickstart install.  

Orion and Ronald: Are you seeing this during a kickstart installation, or a manual install on using dmraid hardware?
Comment 7 Orion Poplawski 2009-03-26 12:26:07 EDT
kickstart, but so far only on a machine with 2 existing non-linux partitions that are preserved.  Installs on pure linux machines on which all partitions are first removed by kickstart are fine.
Comment 8 James Laska 2009-03-26 13:11:51 EDT
Orion, thanks for the feedback.  The anaconda team will be focusing on improving the kickstart experience post-beta.  The focus for beta is around manual installations.

I've added this issue to the known issues list for F11 Beta (https://fedoraproject.org/wiki/Fedora_11_Beta_release_notes#Anaconda_installer_issues).
Comment 9 Ronald Warsow 2009-03-26 13:43:20 EDT
- manual install !
- no RAID


00:12.0 SATA controller: ATI Technologies Inc SB600 Non-Raid-5 SATA (prog-if 01 [AHCI 1.0])

is this dmraid hardware ?
Comment 10 Chris Lumens 2009-03-30 15:27:06 EDT
*** Bug 492471 has been marked as a duplicate of this bug. ***
Comment 11 Chris Lumens 2009-03-31 15:07:00 EDT
*** Bug 493140 has been marked as a duplicate of this bug. ***
Comment 12 Joel Andres Granados 2009-04-01 12:29:39 EDT
Been following this bug for some time and think I have a hack for it. Would appreciate people testing with one of the following update images:

http://jgranado.fedorapeople.org/storage/testing/01-04-2009-1826-i586.img
http://jgranado.fedorapeople.org/storage/testing/01-04-2009-1826-x86_64.img
Comment 13 Joel Andres Granados 2009-04-01 14:12:23 EDT
The following updates are the same solution but less hackish.  Would appreciate a test for each comment image, if you have time :).

http://jgranado.fedorapeople.org/storage/testing/01-04-2009-2010-i586.img
http://jgranado.fedorapeople.org/storage/testing/01-04-2009-2010-x86_64.img
Comment 14 Ronald Warsow 2009-04-01 14:58:32 EDT
Thanks !

but no luck.
installer stops with a popup message "Filesystem error detected, cannot continue"
with an OK "button"

attached all file under /tmp.
add. blkid and fdisk -l /dev/sd?

hint: sda2 is Solaris ZFS
Comment 15 Ronald Warsow 2009-04-01 14:59:09 EDT
Created attachment 337616 [details]
anaconda-log
Comment 16 Ronald Warsow 2009-04-01 14:59:41 EDT
Created attachment 337617 [details]
blkid
Comment 17 Ronald Warsow 2009-04-01 15:00:05 EDT
Created attachment 337618 [details]
fdisk
Comment 18 Ronald Warsow 2009-04-01 15:00:48 EDT
Created attachment 337619 [details]
program.log
Comment 19 Ronald Warsow 2009-04-01 15:01:12 EDT
Created attachment 337620 [details]
storage.log
Comment 20 Ronald Warsow 2009-04-01 15:01:34 EDT
Created attachment 337621 [details]
syslog
Comment 21 James Laska 2009-04-01 15:05:22 EDT
Testing with the x86_64 updates image posted in comment#13 results in ...

Running anaconda 11.5.0.38, the Fedora system installer - please wait...       
Traceback (most recent call last):
  File "/tmp/updates/anaconda", line 549, in <module>
    import signal, string, isys, iutil, time
  File "/tmp/updates/isys.py", line 38, in <module>
    import block
  File "/tmp/updates/block/__init__.py", line 20, in <module>
    import dm
ImportError: /tmp/updates/block/dmmodule.so: wrong ELF class: ELFCLASS32

This was tested by performing a raid0 kickstart install of rawhide while booting with updates=http://jgranado.fedorapeople.org/storage/testing/01-04-2009-2010-x86_64.img
Comment 22 Eric Sandeen 2009-04-01 16:07:57 EDT
I hit this (see bug 491493) when attempting to format a partition as xfs in the custom partitioning screen, in the x86 F11 Beta installer.

-Eric
Comment 23 Joel Andres Granados 2009-04-02 07:29:17 EDT
(In reply to comment #14)
> Thanks !
> 
> but no luck.
> installer stops with a popup message "Filesystem error detected, cannot
> continue"
> with an OK "button"
This means your hitting another bug before this one.  thx for testing!
Comment 24 Joel Andres Granados 2009-04-02 07:57:45 EDT
The images I created for comment 12 and 13 were a little off.  These new images should correct the problem and hopefully take care of the bug :)

http://jgranado.fedorapeople.org/storage/testing/02-04-2009-1351-{i586,x86_64}.img
Comment 25 Chris Lumens 2009-04-02 09:58:30 EDT
*** Bug 493498 has been marked as a duplicate of this bug. ***
Comment 26 Chris Lumens 2009-04-02 09:58:38 EDT
*** Bug 493502 has been marked as a duplicate of this bug. ***
Comment 27 James Laska 2009-04-02 10:14:15 EDT
Created attachment 337821 [details]
Traceback while testing 02-04-2009-1351-x86_64.img

Testing with rawhide + updates=http://jgranado.fedorapeople.org/storage/testing/02-04-2009-1351-x86_64.img yields the attached traceback.
Comment 28 Andrew Ross 2009-04-02 17:58:14 EDT
Couple of points from  Bug 493498.

HD:
 - no RAID
 - EXT3
 - Encrypted /home (though installing into free space)

Install Media:
 - Boot.iso (rawhide-20090331)
Comment 29 Igor Miletic 2009-04-02 22:18:25 EDT
Also couple of points from https://bugzilla.redhat.com/show_bug.cgi?id=493498

320 GB HD
Ext4
No encryption

Booted from Boot.iso (rawhide-20090402)
Comment 30 Orion Poplawski 2009-04-03 13:27:01 EDT
Created attachment 338089 [details]
anaconda traceback

Testing with rawhide 20090403 +
updates=http://jgranado.fedorapeople.org/storage/testing/02-04-2009-1351-x86_64.img
yields the attached traceback. 

Different than the other one posted.
Comment 31 Chris Lumens 2009-04-03 16:31:40 EDT
*** Bug 494029 has been marked as a duplicate of this bug. ***
Comment 32 Chris Lumens 2009-04-06 10:15:08 EDT
*** Bug 494184 has been marked as a duplicate of this bug. ***
Comment 33 Stefan Ring 2009-04-07 11:55:54 EDT
Created attachment 338526 [details]
anaconda traceback

I got a very similar error today when I tried to install Fedora 11 Beta.

The disk layout is as follows:

Disk /dev/sda: 60801 cylinders, 255 heads, 63 sectors/track
Units = cylinders of 8225280 bytes, blocks of 1024 bytes, counting from 0

   Device Boot Start     End   #cyls    #blocks   Id  System
/dev/sda1          0+   4145    4146-  33302713+   7  HPFS/NTFS
/dev/sda2       4146    4158-     13-     97657   83  Linux
/dev/sda3       4158+  52720   48563- 390081030+   5  Extended
/dev/sda4   *  52721   60801-   8081-  64905151+  bf  Solaris
/dev/sda5       4158+   6589-   2432-  19531250+  83  Linux
/dev/sda6       6589+   7075-    487-   3906250+  82  Linux swap / Solaris
/dev/sda7       7076+   9687    2612-  20980862+  83  Linux

There is plenty of room in the extended partition. I used the graphical installer, no RAID, nothing unusual. I just pressed the "New" button and tried to create a new root (/) partition, format as ext4, sized 20000MB, and immediately got the traceback when I pressed the "Ok" button (or whatever its name is).
Comment 34 Joel Andres Granados 2009-04-08 08:26:41 EDT
This is addressed in current anaconda.
Comment 35 Chris Lumens 2009-04-08 10:19:59 EDT
*** Bug 494807 has been marked as a duplicate of this bug. ***
Comment 36 Orion Poplawski 2009-04-09 12:22:58 EDT
Getting different traceback today (bug #495076)- no idea if I got farther or not.
Comment 37 James Laska 2009-04-09 12:45:58 EDT
I have a similar experience as Orion in comment#36.  I'm not seeing this issue anymore, but am now seeing bug#495077.
Comment 38 Orion Poplawski 2009-04-14 16:59:06 EDT
No more partitioning tracebacks for me with 11.5.0.44.

Note You need to log in before you can comment on or make changes to this bug.