Bug 491921 - PartitionException: Attempting to remove a partition that is not owned by any disk
PartitionException: Attempting to remove a partition that is not owned by any...
Status: CLOSED DUPLICATE of bug 491845
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Beta/F11BetaBlocker
  Show dependency treegraph
 
Reported: 2009-03-24 12:44 EDT by Orion Poplawski
Modified: 2009-03-24 12:51 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-24 12:51:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2009-03-24 12:44:08 EDT
Description of problem:

Trying to install rawhide on system with existing windows and linux install. kickstart partition commands:

clearpart --linux
part /boot --fstype ext3 --size=100
part / --fstype ext3 --size=8000
part swap --recommended
part /export --fstype ext3 --size=100 --grow
bootloader --location=mbr

....
 File "/usr/lib/anaconda/devicetree.py", line 697, in _removeDevice
   dev.disk.partedDisk.removePartition(dev.partedPartition)
 File "/usr/lib64/python2.6/site-packages/parted/disk.py", line 194, in removePartition
   if self.__disk.remove_partition(partition.getPedPartition()):
_ped.PartitionException: Attempting to remove a partition that is not owned by any disk

VT3:
DEBUG: clearpart: looking at sda1
DEBUG: clearpart: looking at sda2
DEBUG: clearpart: looking at sda3
DEBUG: clearing sda3
DEBUG: partitions: ['sda1','sda2']
DEBUG: getFormat('None') returning DeviceFormat instance
DEBUG: registered action: Destroy Format None on sda3 (partition)

Version-Release number of selected component (if applicable):
11.5.0.36
Comment 1 Joel Andres Granados 2009-03-24 12:51:21 EDT

*** This bug has been marked as a duplicate of bug 491845 ***

Note You need to log in before you can comment on or make changes to this bug.