This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 491927 - DeviceError: parent device does not exist
DeviceError: parent device does not exist
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
anaconda_trace_hash:86d5f83cb5150c3ba...
:
: 496116 (view as bug list)
Depends On:
Blocks: F11AnacondaBlocker
  Show dependency treegraph
 
Reported: 2009-03-24 12:57 EDT by James Laska
Modified: 2013-09-02 02:33 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-27 15:20:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (293.20 KB, text/plain)
2009-03-24 12:57 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2009-03-24 12:57:53 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.36 exception report
Traceback (most recent call first):
  File "/tmp/updates/storage/devices.py", line 262, in createParents
    raise DeviceError("parent device does not exist")
  File "/tmp/updates/storage/devices.py", line 1650, in create
    self.createParents()
  File "/tmp/updates/storage/deviceaction.py", line 206, in execute
    self.device.create(intf=intf)
  File "/tmp/updates/storage/devicetree.py", line 659, in processActions
    action.execute(intf=self.intf)
  File "/tmp/updates/storage/__init__.py", line 211, in doIt
    self.devicetree.processActions()
  File "/tmp/updates/packages.py", line 115, in turnOnFilesystems
    anaconda.id.storage.doIt()
  File "/tmp/updates/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/tmp/updates/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/tmp/updates/gui.py", line 1317, in nextClicked
    self.anaconda.dispatch.gotoNext()
DeviceError: parent device does not exist
Comment 1 James Laska 2009-03-24 12:57:58 EDT
Created attachment 336498 [details]
Attached traceback automatically from anaconda.
Comment 2 James Laska 2009-03-24 13:03:29 EDT
Steps to reproduce:
 1) Boot rawhide/i386 on KVM guest
 2) Add remote iSCSI drive (IP:192.168.33.219, IQN:iqn.rhel5.i386)
 3) Select the local KVM disk ('vda') as the boot drive
 4) Select "Use entire disk" and [X] Review partition selections
 5) Click Next 
 6) (optional) ... rearrange partitions to ensure that 'vda' gets the /boot partition
 7) Click Next
Comment 3 David Lehman 2009-04-16 12:13:40 EDT
Can you retest this at your convenience? I expect that it was fixed shortly after beta.
Comment 4 Chris Lumens 2009-04-17 11:36:18 EDT
*** Bug 496116 has been marked as a duplicate of this bug. ***
Comment 5 James Laska 2009-04-27 15:20:15 EDT
Tested and confirmed fixed with anaconda-11.5.0.47

Note You need to log in before you can comment on or make changes to this bug.