Bug 491999 - ibus candidate selection up/down arrow keys broken in xchat
ibus candidate selection up/down arrow keys broken in xchat
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Peng Huang
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: 481098
  Show dependency treegraph
 
Reported: 2009-03-24 17:59 EDT by Warren Togami
Modified: 2009-04-01 10:12 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-01 10:12:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2009-03-24 17:59:35 EDT
ibus-1.1.0.20090311-1.fc11.x86_64
ibus-pinyin-1.1.0.20090303-1.fc11.noarch
ibus-anthy-1.1.0.20090211-2.fc11.x86_64
xchat-2.8.6-7.fc11.x86_64

ibus during candidate selection, the up/down arrow keys are broken in xchat.  SCIM is fine.
Comment 1 Peng Huang 2009-03-27 22:57:14 EDT
This problem is because xchat filters those key events, and ibus can not receive them. It is better to let xchat does not filter those key events when im is active (The pre-edit text is visible).
Comment 2 Warren Togami 2009-03-28 03:03:08 EDT
How is this not an issue for SCIM, IIIMF and XIM?
Comment 3 Peng Huang 2009-03-28 19:34:46 EDT
For IIIMF & XIM, I am not very sure. Properly, Key events will be sent to XIM server before delivering to GDK library.

But for SCIM, I know the detail. SCIM registers a gtk keyboard snooper to get all key events  before events are delivered to widgets. I think it is not a right way. It does not follow gtk im context design. It is just an workaround for those applications.

I think the better solution is fixing it in application, or consider changing the gtk im context's design.
Comment 4 Kevin Kofler 2009-03-28 19:48:25 EDT
It is an issue for IIIMF, we used to have a patch for that, but it broke XIM. See bug 295331.

As far as I know, the current code works fine for XIM and SCIM.
Comment 5 Peng Huang 2009-03-29 02:02:54 EDT
Yeah. It is because SCIM has a workaround for this problem. But it does not follow gtk im context design. I just went through xchat source code. I did not find easy way to know if im context is active. So I fixed it in ibus im module.

But I will file a new bug on gtk upstream. Maybe they will change design of gtk im context.
Comment 6 Warren Togami 2009-03-29 02:06:29 EDT
Do not close as RAWHIDE if the bug is not actually fixed.  Keeping it open for now.

Note You need to log in before you can comment on or make changes to this bug.