Bug 492026 - Crash in rawhide 2009-03-24
Crash in rawhide 2009-03-24
Status: CLOSED DUPLICATE of bug 491997
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:1ff78d6ab26abd9d6...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-24 20:30 EDT by Chris Adams
Modified: 2009-03-25 14:48 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-24 23:23:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (131.44 KB, text/plain)
2009-03-24 20:31 EDT, Chris Adams
no flags Details
Attached traceback automatically from anaconda. (117.01 KB, text/plain)
2009-03-25 14:48 EDT, Matthieu Araman
no flags Details

  None (edit)
Description Chris Adams 2009-03-24 20:30:59 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.36 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.6/site-packages/parted/disk.py", line 194, in removePartition
    if self.__disk.remove_partition(partition.getPedPartition()):
  File "/usr/lib/anaconda/storage/devicetree.py", line 697, in _removeDevice
    dev.disk.partedDisk.removePartition(dev.partedPartition)
  File "/usr/lib/anaconda/storage/devicetree.py", line 731, in registerAction
    self._removeDevice(action.device)
  File "/usr/lib/anaconda/storage/__init__.py", line 600, in destroyDevice
    self.devicetree.registerAction(action)
  File "/usr/lib/anaconda/storage/partitioning.py", line 332, in clearPartitions
    storage.destroyDevice(part)
  File "/usr/lib/anaconda/storage/partitioning.py", line 170, in doAutoPartition
    clearPartitions(anaconda.id.storage)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1317, in nextClicked
    self.anaconda.dispatch.gotoNext()
PartitionException: Attempting to remove a partition that is not owned by any disk.
Comment 1 Chris Adams 2009-03-24 20:31:07 EDT
Created attachment 336574 [details]
Attached traceback automatically from anaconda.
Comment 2 Chris Lumens 2009-03-24 23:23:00 EDT

*** This bug has been marked as a duplicate of bug 491997 ***
Comment 3 Matthieu Araman 2009-03-25 14:48:30 EDT
Created attachment 336689 [details]
Attached traceback automatically from anaconda.

Note You need to log in before you can comment on or make changes to this bug.