Bug 492044 - anaconda LVM softraid storage/formats/fs.py
anaconda LVM softraid storage/formats/fs.py
Status: CLOSED DUPLICATE of bug 492086
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:c3a2a69d9cc282e10...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-24 23:10 EDT by Nicolas Chauvet (kwizart)
Modified: 2009-04-01 20:07 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-25 10:02:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (87.39 KB, text/plain)
2009-03-24 23:10 EDT, Nicolas Chauvet (kwizart)
no flags Details
Attached traceback automatically from anaconda. (164.02 KB, text/plain)
2009-04-01 20:07 EDT, Andrew Ross
no flags Details

  None (edit)
Description Nicolas Chauvet (kwizart) 2009-03-24 23:10:08 EDT
The following was filed automatically by anaconda:
anaconda None exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/formats/fs.py", line 1015, in _deviceCheck
    if not ":" in devspec:
  File "/usr/lib/anaconda/storage/formats/fs.py", line 1023, in _setDevice
    self._deviceCheck(devspec)
  File "/usr/lib/anaconda/storage/formats/fs.py", line 1030, in <lambda>
    lambda f,d: f._setDevice(d),
  File "/usr/lib/anaconda/storage/formats/__init__.py", line 163, in __init__
    self.device = kwargs.get("device")
  File "/usr/lib/anaconda/storage/formats/fs.py", line 150, in __init__
    DeviceFormat.__init__(self, *args, **kwargs)
  File "/usr/lib/anaconda/iw/partition_ui_helpers_gui.py", line 199, in createFSTypeMenu
    format = device_formats[name]()
  File "/usr/lib/anaconda/iw/lvm_dialog_gui.py", line 420, in editLogicalVolume
    ignorefs = ["software RAID", "physical volume (LVM)", "efi", "PPC PReP Boot", "Apple Bootstrap"])
  File "/usr/lib/anaconda/iw/lvm_dialog_gui.py", line 704, in editCurrentLogicalVolume
    self.editLogicalVolume(lv)
  File "/usr/lib/anaconda/iw/lvm_dialog_gui.py", line 735, in editLogicalVolumeCB
    self.editCurrentLogicalVolume()
TypeError: argument of type 'NoneType' is not iterable
Comment 1 Nicolas Chauvet (kwizart) 2009-03-24 23:10:22 EDT
Created attachment 336581 [details]
Attached traceback automatically from anaconda.
Comment 2 Chris Lumens 2009-03-25 10:02:33 EDT

*** This bug has been marked as a duplicate of bug 492086 ***
Comment 3 Andrew Ross 2009-04-01 20:07:37 EDT
Created attachment 337694 [details]
Attached traceback automatically from anaconda.

Note You need to log in before you can comment on or make changes to this bug.