Bug 492086 - anaconda TypeError: argument of type 'NoneType' is not iterable
anaconda TypeError: argument of type 'NoneType' is not iterable
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:8cc3c595e1ad4cbd6...
:
: 492044 492141 492512 (view as bug list)
Depends On:
Blocks: F11Beta/F11BetaBlocker
  Show dependency treegraph
 
Reported: 2009-03-25 07:03 EDT by Ronald Warsow
Modified: 2009-04-06 10:40 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-06 10:37:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (124.62 KB, text/plain)
2009-03-25 07:03 EDT, Ronald Warsow
no flags Details
Attached traceback automatically from anaconda. (125.40 KB, text/plain)
2009-03-25 07:56 EDT, James Laska
no flags Details
Attached traceback automatically from anaconda. (157.45 KB, text/plain)
2009-03-25 08:06 EDT, Vinagre
no flags Details
Attached traceback automatically from anaconda. (83.86 KB, text/plain)
2009-03-26 07:35 EDT, Daniel Mach
no flags Details

  None (edit)
Description Ronald Warsow 2009-03-25 07:03:00 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.37 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/formats/fs.py", line 1015, in _deviceCheck
    if not ":" in devspec:
  File "/usr/lib/anaconda/storage/formats/fs.py", line 1023, in _setDevice
    self._deviceCheck(devspec)
  File "/usr/lib/anaconda/storage/formats/fs.py", line 1030, in <lambda>
    lambda f,d: f._setDevice(d),
  File "/usr/lib/anaconda/storage/formats/__init__.py", line 163, in __init__
    self.device = kwargs.get("device")
  File "/usr/lib/anaconda/storage/formats/fs.py", line 150, in __init__
    DeviceFormat.__init__(self, *args, **kwargs)
  File "/usr/lib/anaconda/iw/partition_ui_helpers_gui.py", line 199, in createFSTypeMenu
    format = device_formats[name]()
  File "/usr/lib/anaconda/iw/partition_dialog_gui.py", line 321, in __init__
    availablefstypes = restrictfs)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1118, in editPartition
    restrictfs = restrictfs)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 976, in newCB
    self.editPartition(device, isNew=1)
TypeError: argument of type 'NoneType' is not iterable
Comment 1 Ronald Warsow 2009-03-25 07:03:07 EDT
Created attachment 336615 [details]
Attached traceback automatically from anaconda.
Comment 2 Ronald Warsow 2009-03-25 07:38:23 EDT
... quark collision (**kwargs) with an Solaris partition ...

lambda,quarks, ..., quantum physics ?


seriously:

it was a native (non VM) install via boot.iso.
chosen was a manual partitioning on free space on sdaN with N > 3 


Disk /dev/sda: 200.0 GB, 200049647616 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        1044     8385898+  83  Linux
/dev/sda2            1045        3477    19543072+  bf  Solaris
/dev/sda3            3478       10773    58605120   8e  Linux LVM

Disk /dev/sdb: 40.0 GB, 40060403712 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1         765     6144831    7  HPFS/NTFS
/dev/sdb2             766        3377    20980890    7  HPFS/NTFS
/dev/sdb3            3378        3403      204800    7  HPFS/NTFS
/dev/sdb4            3403        4871    11788288    7  HPFS/NTFS
Comment 3 James Laska 2009-03-25 07:56:39 EDT
Created attachment 336622 [details]
Attached traceback automatically from anaconda.
Comment 4 Vinagre 2009-03-25 08:06:08 EDT
Created attachment 336625 [details]
Attached traceback automatically from anaconda.
Comment 5 Chris Lumens 2009-03-25 09:54:22 EDT
This should be fixed in the next build of anaconda.  Thanks for the report.
Comment 6 Chris Lumens 2009-03-25 10:02:33 EDT
*** Bug 492044 has been marked as a duplicate of this bug. ***
Comment 7 Chris Lumens 2009-03-25 11:35:22 EDT
*** Bug 492141 has been marked as a duplicate of this bug. ***
Comment 8 Daniel Mach 2009-03-26 07:35:37 EDT
Created attachment 336780 [details]
Attached traceback automatically from anaconda.
Comment 9 Radek Vykydal 2009-03-27 05:48:47 EDT
*** Bug 492512 has been marked as a duplicate of this bug. ***
Comment 10 Joel Andres Granados 2009-03-27 06:18:03 EDT
This is fixed in anaconda 11.5.0.38 and over
Comment 11 Ronald Warsow 2009-03-27 09:30:11 EDT
when does "over" hit the mirror's ?
Comment 12 Vinagre 2009-03-27 17:06:16 EDT
@ Ronald Warsow
This was fixed in 11.5.0.38 you don't need the next release.

I test it using the net install iso image:
http://download.fedora.redhat.com/pub/fedora/linux/development/$basearch/os/images/boot.iso

replace $basearch with x86_64 or i386 according to your system.
Comment 13 Ronald Warsow 2009-03-27 18:19:56 EDT
@Vinagre

Thanks for the hint. 
Each morning I look at this link since ~10 days..., and koji (anaconda), and in the directory "Packages".

Frustrating !

But you are right I'm in the wrong anaconda bug - one of my ~5 -.

the remaining/todays bug/trace is called "Unable to satisfy all constraints ..."

So it looks like I need anaconda version "over"
Comment 14 Ronald Warsow 2009-04-05 10:54:50 EDT
to be closed !

Note You need to log in before you can comment on or make changes to this bug.