Bug 49208 - ps (and killall, shutdown) hangs
ps (and killall, shutdown) hangs
Status: CLOSED DUPLICATE of bug 61503
Product: Red Hat Linux
Classification: Retired
Component: procps (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Alexander Larsson
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-16 17:38 EDT by Mark H Johnson
Modified: 2007-04-18 12:34 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-01 09:27:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mark H Johnson 2001-07-16 17:38:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2smp i686)

Description of problem:
We are developing a large multi-tasking application (using Linux Threads).
We use ps in scripts to kill jobs that are "hung" due to our own bugs.
After several runs/kills, the system gets into a state where ps will no
longer list all of the selected processes - it hangs. In a similar manner,
"killall -9 (our program here)" will also hang instead of killing the
selected application. Attempts to cleanly shut down the system also fail at
the step where it attempts to kill all the running jobs.


How reproducible:
Sometimes

Steps to Reproduce:
1. Run script to start our application. Debug, get stuck.
2. Run script to kill our application (killall -9 [our app]).
[repeat 1 & 2 until system begins to hang]
	

Actual Results:  Several iterations of these two steps work OK. After first
failure, always fails to kill the application. Other utilities like ps,
top, and shutdown also begin to fail to work. 

Expected Results:  Application runs after [1]. Application is dead after
[2].

Additional info:

If we use the reset button after attempting to shutdown the system, the
file system is not save properly [and e2fsck runs on next boot].
Comment 1 Joerg Krause 2001-07-19 09:27:05 EDT
We have the same problem here. After more than 200 processes ps stops to work. We could solve this problem after
switching back to a patched procps-2.06 instead of 2.07.
Comment 2 Wagner T. Correa 2002-03-22 21:02:13 EST
I'm experiencing the same problem running kernel 2.4.9-31 and procps-2.0.7-11 on
a AMD Athlon.
Comment 3 Alexander Larsson 2002-06-20 09:35:14 EDT
Bug 61503 is likely related to this.
Comment 4 Alexander Larsson 2002-08-08 09:50:34 EDT

*** This bug has been marked as a duplicate of 61503 ***

Note You need to log in before you can comment on or make changes to this bug.