Bug 492159 - Multiple errors when starting Monitoring (NPBootstrap) service
Multiple errors when starting Monitoring (NPBootstrap) service
Status: CLOSED DUPLICATE of bug 492150
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Monitoring (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
Brandon Perkins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-25 12:58 EDT by Milan Zazrivec
Modified: 2009-03-26 12:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-26 12:58:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log from starting NPBoostrap (33.76 KB, text/plain)
2009-03-25 12:58 EDT, Milan Zazrivec
no flags Details

  None (edit)
Description Milan Zazrivec 2009-03-25 12:58:31 EDT
Created attachment 336676 [details]
log from starting NPBoostrap

Description of problem:
Multiple error messages are being printed into system console when
Monitoring service (NPBoostrap part) start on a Satellite with enabled
monitoring.

Version-Release number of selected component (if applicable):
SatConfig-general-1.216.8-1.el5sat / Satellite-5.3.0-RHEL5-re20090323.0

How reproducible:
Always

Steps to Reproduce:
1. Install Satellite 5.3.0, enable monitoring, restart satellite via webui,
   monitoring scout, do scout configuration push.
2. /usr/sbin/rhn-satellite stop
3. /usr/sbin/rhn-satellite start
  
Actual results:
See attachment

Expected results:
No errors.

Additional info:
Following two errors are present in /var/log/httpd/error_log:

[error] returning 1 at /usr/lib/perl5/vendor_perl/5.8.8/RHN/Access.pm line 74.
[error] [client 127.0.0.1] Can't locate object method "main" via package
"Apache2::RequestRec" at
/usr/lib/perl5/vendor_perl/5.8.8/NOCpulse/MonitoringAccessHandler.pm line 34.\n
Comment 1 Brandon Perkins 2009-03-26 12:58:40 EDT

*** This bug has been marked as a duplicate of bug 492150 ***

Note You need to log in before you can comment on or make changes to this bug.