Bug 492150 - /usr/sbin/rhn-satellite restart, NPBootStrap pukes html on restart
/usr/sbin/rhn-satellite restart, NPBootStrap pukes html on restart
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Monitoring (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Jan Pazdziora
wes hayutin
na
:
: 492159 494916 495927 503549 (view as bug list)
Depends On:
Blocks: 463877 484962
  Show dependency treegraph
 
Reported: 2009-03-25 12:28 EDT by wes hayutin
Modified: 2015-09-18 17:46 EDT (History)
6 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 511052 (view as bug list)
Environment:
Last Closed: 2009-09-10 14:49:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
restart log (9.83 KB, application/octet-stream)
2009-03-25 12:28 EDT, wes hayutin
no flags Details
output of restart (40.97 KB, text/plain)
2009-06-01 15:01 EDT, wes hayutin
no flags Details

  None (edit)
Description wes hayutin 2009-03-25 12:28:08 EDT
Created attachment 336669 [details]
restart log

Description of problem:

Satellite-5.3.0-RHEL5-re20090323.0-i386-embedded-oracle.iso

recreate.
1. enable monitoring, monitoring scout
2. /usr/sbin/rhn-satellite restart

watch NPBootStrap vomit html


see attachment
Comment 1 Brandon Perkins 2009-03-26 12:58:40 EDT
*** Bug 492159 has been marked as a duplicate of this bug. ***
Comment 2 Miroslav Suchý 2009-04-09 12:16:38 EDT
*** Bug 494916 has been marked as a duplicate of this bug. ***
Comment 3 Miroslav Suchý 2009-04-15 11:32:00 EDT
*** Bug 495927 has been marked as a duplicate of this bug. ***
Comment 4 Devan Goodwin 2009-04-21 11:17:13 EDT
Some extra info, the error HTML indicates there's been an ISE.

From error_log:

[Tue Apr 21 14:47:22 2009] [notice] Apache configured -- resuming normal operations
[Tue Apr 21 14:47:24 2009] [error] returning 1 at /usr/lib/perl5/vendor_perl/5.8.8/RHN/Access.pm line 74.
[Tue Apr 21 14:47:36 2009] [error] returning 1 at /usr/lib/perl5/vendor_perl/5.8.8/RHN/Access.pm line 74.
[Tue Apr 21 14:47:47 2009] [error] returning 1 at /usr/lib/perl5/vendor_perl/5.8.8/RHN/Access.pm line 74.
[Tue Apr 21 14:47:59 2009] [error] returning 1 at /usr/lib/perl5/vendor_perl/5.8.8/RHN/Access.pm line 74.
[Tue Apr 21 14:48:10 2009] [error] returning 1 at /usr/lib/perl5/vendor_perl/5.8.8/RHN/Access.pm line 74.
[Tue Apr 21 14:48:14 2009] [error] [client 127.0.0.1] Can't locate object method "main" via package "Apache2::RequestRec" at /usr/lib/perl5/vendor_perl/5.8.8/NOCpulse/MonitoringAccessHandler.pm line 34.\n
[Tue Apr 21 14:48:16 2009] [error] returning 1 at /usr/lib/perl5/vendor_perl/5.8.8/RHN/Access.pm line 74.
[Tue Apr 21 14:48:17 2009] [error] returning 1 at /usr/lib/perl5/vendor_perl/5.8.8/RHN/Access.pm line 74.
[Tue Apr 21 14:48:21 2009] [error] returning 1 at /usr/lib/perl5/vendor_perl/5.8.8/RHN/Access.pm line 74.
Comment 5 Miroslav Suchý 2009-04-22 03:58:17 EDT
Hmm, this error should be fixed by recent commit of Jan 74bf1a9dbc75b5021f6ff379c3f640e5984caa36 which is in eventReceivers-2.20.12-1
Comment 6 Devan Goodwin 2009-04-22 08:51:47 EDT
I have this version of eventReceivers on my F10 spacewalk box subscribed to the devel repo, the HTML dump is no longer happening! A separate error is but it is a new bug. :)
Comment 7 Miroslav Suchý 2009-04-22 09:30:21 EDT
Good, 
changing assigner to Jan since he done the work...
Comment 9 Jan Pazdziora 2009-05-04 03:53:00 EDT
Packages eventReceivers-2.20.11-2.el?sat.noarch.rpm are on Satellite-5.3.0-RHEL?-re20090501.1 ISOs, moving ON_QA.
Comment 10 wes hayutin 2009-05-19 15:21:14 EDT
5/7.1 verified
Comment 11 wes hayutin 2009-06-01 14:56:48 EDT
recreate 5/29 build rhel 5
Comment 12 wes hayutin 2009-06-01 15:01:08 EDT
Created attachment 346121 [details]
output of restart
Comment 13 wes hayutin 2009-06-02 10:28:50 EDT
*** Bug 503549 has been marked as a duplicate of this bug. ***
Comment 14 Miroslav Suchý 2009-06-02 10:40:56 EDT
last fail was due to manual editing of database with wrong values.
after some investigation we come to resolution that it works.
Comment 15 Miroslav Suchý 2009-08-25 05:50:30 EDT
[root@xen5 ~]# /usr/sbin/rhn-satellite restart
Shutting down rhn-satellite...
Stopping RHN Taskomatic...
Waiting for RHN Taskomatic to exit...
Stopped RHN Taskomatic.
Stopping cobbler daemon:                                   [  OK  ]
Stopping rhn-search...
Stopped rhn-search.
Stopping MonitoringScout ...
        Stopping Dispatcher ...  [ OK ]
        Stopping Dequeuer ...  [ OK ]
        Stopping SputLite ...  [ OK ]
        Stopping NPBootstrap ...  [ OK ]
        Stopping InstallSoftwareConfig ...  [ OK ]
[ OK ]
Stopping Monitoring ...
        Stopping TSDBLocalQueue ...  [ OK ]
        Stopping AckProcessor ...  [ OK ]
        Stopping Notifier ...  [ OK ]
        Stopping NotifLauncher ...  [ OK ]
        Stopping NotifEscalator ...  [ OK ]
        Stopping GenerateNotifConfig ...  [ OK ]
[ OK ]
Stopping httpd:                                            [  OK  ]
Stopping tomcat5:                                          [  OK  ]
Shutting down osa-dispatcher:                              [  OK  ]
Shutting down Oracle Net Listener ...                      [  OK  ]
Shutting down Oracle DB instance "rhnsat" ...              [  OK  ]
Shutting down Jabber router:                               [  OK  ]
Done.
Starting rhn-satellite...
Starting Jabber services                                   [  OK  ]
Starting Oracle Net Listener ...                           [  OK  ]
Starting Oracle DB instance "rhnsat" ...                   [  OK  ]
Starting osa-dispatcher:                                   [  OK  ]
Starting tomcat5:                                          [  OK  ]
Starting httpd:                                            [  OK  ]
Starting Monitoring ...
        Starting InstallSoftwareConfig ...  [ OK ]
        Starting GenerateNotifConfig ...  [ OK ]
        Starting NotifEscalator ...  [ OK ]
        Starting NotifLauncher ...  [ OK ]
        Starting Notifier ...  [ OK ]
        Starting AckProcessor ...  [ OK ]
        Starting TSDBLocalQueue ...  [ OK ]
[ OK ]
Starting MonitoringScout ...
        Starting NPBootstrap ...  [ OK ]
        Starting SputLite ...  [ OK ]
        Starting Dequeuer ...  [ OK ]
        Starting Dispatcher ...  [ OK ]
[ OK ]
Starting rhn-search...
Starting cobbler daemon:                                   [  OK  ]
Starting RHN Taskomatic...
Done.

verified in stage on xen5
Comment 16 Brandon Perkins 2009-09-10 14:49:17 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html
Comment 17 Jan Hutař 2015-09-18 17:46:35 EDT
Maybe this was related to bug 1170064?

Note You need to log in before you can comment on or make changes to this bug.