Bug 492173 - Random font after returning to text mode
Summary: Random font after returning to text mode
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ben Skeggs
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 492722 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-03-25 18:15 UTC by Jan ONDREJ
Modified: 2009-03-29 22:40 UTC (History)
10 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2009-03-27 20:18:30 UTC


Attachments (Terms of Use)
Poor photo of the console after stopping X (422.85 KB, image/jpeg)
2009-03-26 11:26 UTC, Jared Smith
no flags Details

Description Jan ONDREJ 2009-03-25 18:15:39 UTC
Description of problem:
After testing new nouveau driver using Live CD for test-day, when tryed to startx and then exit from graphics environment, my font in text mode was broken. There was some random "|" visible on whole screen.

By running "setfont" command as any user without parameters fixed my font and I can normally work with my PC. Second startx works well, but returning to text mode breaks my font again.

Version-Release number of selected component (if applicable):
Live CD from test-day:
  https://fedoraproject.org/wiki/QA/Test_Days/2009-03-26

How reproducible:
always (tested 2 times), but still return from startx, switching to CTRL+ALT+F2 works without problem.

  
Actual results:
|||||||||||||||
||||on whole screen

Expected results:
normal font

Additional info:
My smolt profile ID: 6638ff1f-19dc-4578-ba2e-5907f8de5839

Comment 1 Craig Robson 2009-03-25 23:11:35 UTC
I see this too.
Smolt:http://www.smolts.org/client/show/?uuid=pub_a2ad8b5d-b422-43f5-84d1-d0607e2dfcb7

I didn't see this until the second time I stopped the xorg.  I then started and stopped it s3veral more times and it came back with normal fonts.

Comment 2 Gene Stuckey 2009-03-25 23:38:02 UTC
I see this as well with a Quadro NVS 135M.

Smolt:
  http://www.smolts.org/client/show/pub_cd9ee5b7-022f-4a39-a281-4bd9c1594c27

First time I stopped Xorg, worked fine. Second time I saw the vertical lines. I started/stopped Xorg a few more times and continued to see the lines.

Comment 3 Ted Roche 2009-03-26 01:04:15 UTC
I saw the same with a Quadro NVS140M. 

Smolt:

http://www.smolts.org/client/show/pub_70c4ea86-a7ce-4498-9168-3ae50886e18a

Comment 4 Ben Skeggs 2009-03-26 02:15:10 UTC
You guys all appear to be on G80-series cards, so hopefully I just fixed this in xorg-x11-drv-nouveau-0.0.12-16.20090326git01cee29.fc11.

There's RPMs up http://koji.fedoraproject.org/koji/taskinfo?taskID=1259057 for testing :)

Comment 5 Craig Robson 2009-03-26 03:24:38 UTC
I installed the and xorg-x11-drv-nouveau-0.0.12-16.20090326git01cee29.fc11.x86_64.rpm over the live CD and I didn't have the problem.  I didn't have time to shutdown and run the test another time.

Comment 6 Jared Smith 2009-03-26 11:25:41 UTC
I'm seeing this as well on a GeForce 8600M GT (rev a1) on an Apple MacBook Pro.  I was able to take a picture, and will test the updated nouveau driver (on top of the LiveCD) later today.

Comment 7 Jared Smith 2009-03-26 11:26:53 UTC
Created attachment 336779 [details]
Poor photo of the console after stopping X

Sorry about the poor quality -- this is a photo of the console after stopping X for the first time.

Comment 8 Jared Smith 2009-03-27 01:25:45 UTC
The updated RPM from Koji does solve this problem on my system.  I tested the Nouveau Test Day LiveCD with the updated xorg-x11-drv-nouveau driver (the .16 version) and it worked great!

Comment 9 Adam Williamson 2009-03-27 20:18:30 UTC
The build that fixes this is tagged for dist-f11, so it's effectively in rawhide: it'll be in as soon as the beta freeze is lifted. so, closing. thanks for testing!

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 10 Ben Skeggs 2009-03-29 22:40:46 UTC
*** Bug 492722 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.