This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 492199 - ifdown on nVidia CK804 (rev f3) NIC doesn't work
ifdown on nVidia CK804 (rev f3) NIC doesn't work
Status: CLOSED DUPLICATE of bug 532593
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.7
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Ivan Vecera
Red Hat Kernel QE team
:
Depends On:
Blocks: 513692
  Show dependency treegraph
 
Reported: 2009-03-25 16:36 EDT by Dave Maley
Modified: 2009-11-20 03:14 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 513692 (view as bug list)
Environment:
Last Closed: 2009-11-20 03:13:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
upstream patch (1.23 KB, patch)
2009-03-25 16:41 EDT, Dave Maley
no flags Details | Diff
add phy_power_down parameter (1.87 KB, patch)
2009-07-24 16:40 EDT, Dave Maley
no flags Details | Diff
reset phy state on resume (562 bytes, patch)
2009-07-24 16:41 EDT, Dave Maley
no flags Details | Diff

  None (edit)
Description Dave Maley 2009-03-25 16:36:57 EDT
Description of problem:
doing an ifdown on an interface using the below nic does not work properly:

80:0a.0 Ethernet controller: nVidia Corporation CK804 Ethernet Controller (rev f3)

The customer noticed this problem when he switched down one of the interfaces in a bond (using ifconfig ethX down). The IP address is deassigned from the interface, but the link is up and the kernel keeps using this interface as the current active one in the bond.  As the result, the connectivity via the bond interface is lost.

The customer has also reproduced the problem w/out bonding being involved.


Version-Release number of selected component (if applicable):
Initially seen w/ 2.6.9-67.0.22, also reproduced on 2.6.9-78.EL.


How reproducible:
every time


Steps to Reproduce:
1. ifdown ethX
2.

  
Actual results:
physical link remains


Expected results:
interface/link shutdown completely


Additional info:
Customer has confirmed that the problem is resolved w/ the following upstream patch:

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=cb52deba12f27af90a46d2f8667a64888118a888
Comment 1 Dave Maley 2009-03-25 16:41:38 EDT
Created attachment 336702 [details]
upstream patch

this is identical to the upstream patch, all I've done is adjust it to apply cleanly to latest 4.7.z (-78.0.17.EL).
Comment 5 Ivan Vecera 2009-07-17 05:08:04 EDT
Applying only this patch causes several problems:
1. Older drivers can't bring up the link on reboot after using this driver.
2. Other operating systems (windows) can't bring up the link either.
3. Some BIOSen with link-testing features get broken too.

Upstream bugzillas:
https://bugzilla.redhat.com/show_bug.cgi?id=496964
https://bugzilla.kernel.org/show_bug.cgi?id=13072
https://bugzilla.redhat.com/show_bug.cgi?id=497052
https://bugzilla.redhat.com/show_bug.cgi?id=494844

At least two additional patches are needed:
1. Fix resume from hibernation regression
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=35a7433c789ba6df6d96b70fa745ae9e6cac0038

2. Add phy_power_down parameter, leave phy powered up by default (v2)
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=5a9a8e32ebe269c71d8d3e78f9435fe7729f38e9
Comment 6 Dave Maley 2009-07-24 00:01:11 EDT
Ivan - I've just realized that the patch I proposed here has already been included in 4.8 (-89) as part of your forcedeth 0.62 rebase (bug 479408).  I opened this bug the day after it was committed to the 4.8 tree, and unfortunately I'd done my code review a couple days earlier and thus I missed the commit.  Apologies for the confusion.

However as you noted in comment 5 the 2 additional patches are needed.  I plan to provide the customer who reported this w/ a test kernel (-89 + 2 patches from comment 5) to have them test/confirm on their systems which were experiencing problems.
Comment 8 Dave Maley 2009-07-24 16:40:47 EDT
Created attachment 355095 [details]
add phy_power_down parameter
Comment 9 Dave Maley 2009-07-24 16:41:42 EDT
Created attachment 355096 [details]
reset phy state on resume
Comment 10 RHEL Product and Program Management 2009-07-30 11:24:30 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 11 Ivan Vecera 2009-11-20 03:13:59 EST
The appropriate patches were already sent (bug #532593). Although the mentioned bug reports different issue, I'm closing this bug as duplicate as the patches are the same.

*** This bug has been marked as a duplicate of bug 532593 ***

Note You need to log in before you can comment on or make changes to this bug.