Bug 492219 - Recent updates have broken xterm
Recent updates have broken xterm
Status: CLOSED DUPLICATE of bug 491813
Product: Fedora
Classification: Fedora
Component: xterm (Show other bugs)
All Linux
low Severity urgent
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-03-25 18:26 EDT by Michael Forrest
Modified: 2009-03-26 04:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-03-26 04:59:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michael Forrest 2009-03-25 18:26:41 EDT
Description of problem:
xterm 242-2 and 242-3 (from rawhide) both hang indefinitely before displaying main window.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Update to libX11-1.1.5-1.fc10
2. Try to run xterm or uxterm

Actual results:
Both xterm and uxterm indefinitely before displaying main window

Expected results:
The main vt100 widget displays as per normal.

Additional info:
This obviously could be a bug in libX11, but gnome-terminal and other gtk apps all appear to fo be functioning normally.

"strace" shows xterm process is stuck in a select:

read(3, "\1\0\234\0\0\0\0\0f\1\0\0\0\0\0\0\20\0\0\0\0\0\0\0\2101\352\10\0\0\0\0"..., 4096) = 32
read(3, 0x85279dc, 4096)                = -1 EAGAIN (Resource temporarily unavailable)
select(4, [3], [3], NULL, NULL)         = 1 (out [3])
writev(3, [{"\30\1\6\0.\0\0\7i\1\0\0f\1\0\0f\1\0\0\0\0\0\0"..., 24}], 1) = 24
select(4, [3], [], NULL, NULL
Comment 1 Michael Forrest 2009-03-25 18:50:16 EDT
The hang in the select occurs without the main window displaying at all.
Comment 2 Jindrich Novy 2009-03-26 04:59:06 EDT
Closing as duplicate of the libX11-1.1.5-1.fc10 failure tracker.

Just out of curiosity, is it fixed by upgrade to libX11-1.2-3.fc11 in rawhide?

*** This bug has been marked as a duplicate of bug 491813 ***

Note You need to log in before you can comment on or make changes to this bug.