Bug 492229 - [nouveau] Totem playback using X11/Xshm/Xv is erratic in background
[nouveau] Totem playback using X11/Xshm/Xv is erratic in background
Status: CLOSED DUPLICATE of bug 492227
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-25 20:03 EDT by Paul W. Frields
Modified: 2009-03-26 21:27 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-26 21:27:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul W. Frields 2009-03-25 20:03:50 EDT
Package: xorg-x11-drv-nouveau-0.0.12-15.20090323git4067ab4.fc11.x86_64

Device: 01:00.0 VGA compatible controller [0300]: nVidia Corporation GeForce 8400M GS [10de:0427] (rev a1)

Using the Live image for QA test day 2009-03-26, as prepared on 2009-03-25.  Totem works great in the foreground, but behind a Firefox window produces erratic video.  As the foreground Firefox window is moved over the Totem window, it looks as if the video is "resizing" inside its container widget, in a manner of speaking, but the output is unintelligible.  When the Totem window is brought back to the foreground, the output immediately becomes clear and correct again.

The problem also appears when *more than one window* like a GNOME Terminal is placed in the foreground over the Totem window.  Firefox triggers the problem by itself every time.  A lone GNOME Terminal window does not trigger the problem.

Some screenshots illustrating can be found here:

http://pfrields.fedorapeople.org/images/nouveau/

I'll attach them to the bug if that's more appropriate.
Comment 1 Stewart Adam 2009-03-25 21:39:35 EDT
I can confirm this issue as well. I also get the same graphical corruption when dragging the video window 1/2 off the screen to the left or right.
Comment 2 Craig Robson 2009-03-25 23:32:30 EDT
This is probably a duplicate of what I saw, Bug 492227.

I found that if I didn't cover the video from top to bottom with the new window, it didn't fail.  Ie. If I only covered a the video with with a corner of another window it didn't fail.
Comment 3 Paul W. Frields 2009-03-26 21:27:56 EDT
Agreed, marking as dupe.

*** This bug has been marked as a duplicate of bug 492227 ***

Note You need to log in before you can comment on or make changes to this bug.