Bug 492227 - xvideo garbled when another window overlaps top to bottom
xvideo garbled when another window overlaps top to bottom
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
: 492229 492428 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-25 19:46 EDT by Craig Robson
Modified: 2009-03-27 16:18 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-27 16:18:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Video Working (1.10 MB, image/png)
2009-03-25 19:47 EDT, Craig Robson
no flags Details
Video Not Working (1.24 MB, image/png)
2009-03-25 19:48 EDT, Craig Robson
no flags Details

  None (edit)
Description Craig Robson 2009-03-25 19:46:39 EDT
Description of problem:

When playing a video using xvideo the display is fine when another window partially covers the video window.  If the covering window covers all the way from top to bottom then the video is mixed up.  Covering from left to right works correctly.


Version-Release number of selected component (if applicable):


How reproducible: Every time.


Steps to Reproduce:
1. Set gstream to xvideo.
2. Play a video in totem.
3. Partially cover the video top to bottom with another window.
  
Actual results:
Video it mixed up.


Expected results:
Video plays correctly.

Additional info:
Even the test video in the gstream control does plays incorrectly when covered.
Comment 1 Craig Robson 2009-03-25 19:47:22 EDT
Created attachment 336724 [details]
Video Working
Comment 2 Craig Robson 2009-03-25 19:48:21 EDT
Created attachment 336725 [details]
Video Not Working
Comment 3 J Gallagher 2009-03-26 12:34:21 EDT
I notice the problem too, in the F11 nouveau livecd test for xvideo.

It also happens if you move the video window partially off the screen left or right.

I tested on a Geforce 8600GT M
Comment 4 Reto Schneider 2009-03-26 13:13:13 EDT
Same here. I'm using the Test-Day-Live-CD. Tested on Geforce 8600GT
Comment 5 Jason Farrell 2009-03-26 18:08:48 EDT
ditto on 8800GT
Comment 6 Helge Deller 2009-03-26 18:54:18 EDT
same here on Quadro NVS 140M / F11 nouveau livecd test for xvideo.
Comment 7 Ben Skeggs 2009-03-26 18:58:33 EDT
Thanks everyone!  I'm fairly sure I've found the problem on here, I'll check today to see how non-G80 cards fare as it's likely the effect them too.  Will link to a fixed RPM once it's done :)
Comment 8 Ivo Anjo 2009-03-26 19:09:54 EDT
Same here on a 8600 GT (0402)
Comment 9 Ben Skeggs 2009-03-26 19:44:38 EDT
*** Bug 492428 has been marked as a duplicate of this bug. ***
Comment 10 Paul W. Frields 2009-03-26 21:27:56 EDT
*** Bug 492229 has been marked as a duplicate of this bug. ***
Comment 11 Ben Skeggs 2009-03-26 22:08:51 EDT
Can you guys try the build at http://koji.fedoraproject.org/koji/buildinfo?buildID=95521, it should fix the issue.
Comment 12 Paul W. Frields 2009-03-27 08:59:24 EDT
I booted the Test Day Live image again, and installed the updated x86_64 package from the koji link above.  That update makes things work beautifully here, thanks Ben.

I'm setting this to MODIFIED, but since this is Craig's bug, he should try it out too, and if things work out I think this can be closed as RAWHIDE.
Comment 13 Ivo Anjo 2009-03-27 11:10:38 EDT
I'd say this fixes it for me too.
I noticed that if I drag a window around fast over the overlay the redraw trail is a bit noticeable, but besides that (which is not very noticeable) it's working fine.
Comment 14 Craig Robson 2009-03-27 11:43:10 EDT
The new RPM fixes this for me.

Note You need to log in before you can comment on or make changes to this bug.