This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 492244 - [nouveau] Killing X results in garbled screen
[nouveau] Killing X results in garbled screen
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-25 23:48 EDT by Stewart Adam
Modified: 2009-03-29 13:36 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-29 13:35:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stewart Adam 2009-03-25 23:48:36 EDT
Description of problem:
After booting the 2009-03-25 Test Day Live CD, I tried to switch to the 3rd runlevel. It worked, but X didn't terminate so I ran 'killall gnome-session'. That didn't do much either, so I finally ran 'killall X' which did work, but the machine froze and the display started displaying random characters in different colors (see picture)

Version-Release number of selected component (if applicable):
Fedora Test Day 2009-03-25 Live CD

How reproducible:
Unknown (only tried once)

Steps to Reproduce:
1. su -
2. init 3
3. killall gnome-session && killall X
  
Actual results:
'init 3' doesn't kill X, but once 'killall gnome-session && killall X' is executed the computer returns to text mode but is unresponsive and displays random characters in different colors

Expected results:
init 3 does kill X and VT switch happens without video glitches


Additional info:
I have a video ready as well - if you'd like to see it, let me know what format you prefer and I'll upload it to my website.
Comment 1 Ben Skeggs 2009-03-25 23:57:44 EDT
Hey.  The corrupted text mode is probably a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=492173.  If you're able to test the build referenced by that bug and report, that'd be great, thanks!

"init 3" not responding (sometimes it works for me, sometimes it doesn't) doesn't seem to be a nouveau issue.
Comment 2 Yaakov Nemoy 2009-03-28 13:38:28 EDT
When doing the restart X test, i got the same results, but only once. After typing in startx again and killing it, the terminal was fine.
Comment 3 Stewart Adam 2009-03-29 13:35:40 EDT
New RPM works perfectly. Just a note though, switching to VTs makes X have the same weird corruption as reported in bug 492241, but on the entire screen not just in a vertical band.
Comment 4 Stewart Adam 2009-03-29 13:36:07 EDT
Oops, forgot to change the resolution category...

Note You need to log in before you can comment on or make changes to this bug.