Bug 492261 - xterm works as root, not as a normal user
xterm works as root, not as a normal user
Status: CLOSED DUPLICATE of bug 491813
Product: Fedora
Classification: Fedora
Component: xterm (Show other bugs)
10
i686 Linux
low Severity urgent
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-26 04:55 EDT by Natxo Asenjo
Modified: 2009-03-31 09:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-31 09:38:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
attachment with results of $ strace -o xterm.log xterm (59.85 KB, application/octet-stream)
2009-03-26 04:55 EDT, Natxo Asenjo
no flags Details

  None (edit)
Description Natxo Asenjo 2009-03-26 04:55:16 EDT
Created attachment 336764 [details]
attachment with results of  $ strace -o xterm.log xterm

Description of problem: cannot start xterm as normal user; as root there is no problem.


Version-Release number of selected component (if applicable):
X.Org 6.8.99.903(242)

How reproducible: in a gnome desktop use Alt-F2 to run application, enter xterm and press enter. Nothing happens. Open a gnome-terminal, type xterm [enter], nothing happens. 

In a gnome-terminal, su to root (su - , enter root password), type xterm, you get a xterm. 

Selinux is in permissive mode (does not change a thing from targeted mode)
Steps to Reproduce:
1. open gnome-terminal
2. su - to root
3. type xterm, then it works; under a normal user it does not work
  
Actual results:
xterm is borked for a normal user. I cannot use the citrix client because of this, I need to elevate privileges to be able to run programs that in fedora 9 run perfectly fine with the users privileges.

Expected results:
I expect xterm to work as a normal user.

Additional info:
attachment with results of strace -o xterm.log xterm
Comment 1 Miroslav Lichvar 2009-03-31 09:38:36 EDT

*** This bug has been marked as a duplicate of bug 491813 ***

Note You need to log in before you can comment on or make changes to this bug.