Bug 49233 - keytab-lilo does not work
keytab-lilo does not work
Status: CLOSED DUPLICATE of bug 19225
Product: Red Hat Linux
Classification: Retired
Component: lilo (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-07-17 06:20 EDT by David Balažic
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-07-17 06:20:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description David Balažic 2001-07-17 06:20:03 EDT
Description of Problem:

The keytab-lilo program does not work. It should create a mapping file 
from US keyboard to wahever I choose , but it always creates a 1:1 mapping.

How Reproducible:


$ keytab-\
lilo /lib/kbd/.../us.mkap.gz /lib/kbd/.../i386/qwertz/slovene.kmap.gz > 

This produces a 1:1 mapping instead of correct one ( 'z' and 'y' swapped 
and other changes ). Tested by using "od -t d1 slovene.ktl" and by 
installing it and using it ( vi /etc/lilo.conf # add line "keytable 
= /boot/slovene.ktl lilo" ; lilo ; reboot )

Same thing with de.kmap.gz. I also gunzipped the kmap files and tried 
them. Same result.

"keytab-lilo -p 123=121 ...."
works as expected

Additional Information:
The docs mention keytab-lilo.pl but keytab-lilo is an ELF binary,
what is up with that ?
Comment 1 Jeremy Katz 2002-06-04 02:29:51 EDT

*** This bug has been marked as a duplicate of 19225 ***

Note You need to log in before you can comment on or make changes to this bug.