Bug 49242 - anaconda "install ended abnormally" occurs abruptly
Summary: anaconda "install ended abnormally" occurs abruptly
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
high
high
Target Milestone: ---
Assignee: Matt Wilson
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 49304 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-17 12:31 UTC by Chris Runge
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-01 19:00:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Runge 2001-07-17 12:31:07 UTC
Fairfax (beta 2)

Description of Problem:

During a graphical NFS installation on a Dell Latitude CPx laptop connected
 to a docking station and an external monitor, anaconda bombs out
unexpectedly with the message "install ended abnormally" sometime after
package installation.

How Reproducible:

Reproducible when connected to docking station and external monitor;
haven't had the problem when standalone.

Steps to Reproduce:
1. Connect laptop to docking station and external monitor
2. NFS graphical install
3a. First time, selected Laptop install option, Autopartition, and install
GRUB on /dev/hda2 (not MBR). I went through the install routine and watched
the packages start to install. I then left the computer. When I came back
the GUI had gone and the console displayed the message:

"install ended abnormally"

Nothing else besides the normal filesystem unmounting messages was present.
On VC3 the message displayed at the bottom was:

* GRUB command root (hd0,1)
install /grub/i386-redhat/stage1 d (hd0,1) /grub/i386-redhat/stage2 p
(hd0,1)/grub/grub.conf

3b. Thinking the problem was with grub on /dev/hda2 instead of the MBR I
repeated the install, but selected GRUB to go on the MBR. This time I sat
by the machine and watched it. GRUB was installed corectly. However, when I
went to manually select my monitor (Dell M791) and then clicked [Next],
anaconda installed crashed and gave the same "install ended abnormally"
message. The last thing on VC3 was a similar GRUB command.

Actual Results:


Expected Results:


Additional Information:

Comment 1 Michael Fulbright 2001-07-17 15:43:53 UTC
Sounds like fsset.py python heisenbug.

Comment 2 Glen Foster 2001-07-17 19:00:09 UTC
This defect considered SHOULD-FIX for Fairfax gold-release.

Comment 3 Matt Wilson 2001-07-18 22:37:58 UTC
*** Bug 49304 has been marked as a duplicate of this bug. ***

Comment 4 Jeremy Katz 2001-08-10 03:02:12 UTC
Fixed in CVS


Note You need to log in before you can comment on or make changes to this bug.