Bug 492428 - Video corruption while moving one window over playing totem window
Video corruption while moving one window over playing totem window
Status: CLOSED DUPLICATE of bug 492227
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-26 15:47 EDT by James Laska
Modified: 2013-09-02 02:33 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-26 19:44:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (237.29 KB, text/plain)
2009-03-26 15:47 EDT, James Laska
no flags Details
nouveau-corruption.png (109.38 KB, image/png)
2009-03-26 15:47 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2009-03-26 15:47:25 EDT
Created attachment 336879 [details]
Xorg.0.log

Description of problem:

Totem plays the Test Day ogg file without problem.  I can resize the screen and do full screen.  The only time I see an issue is when I move another window over the playing video screen.


Version-Release number of selected component (if applicable):

kernel-2.6.29-0.279.rc8.git6.fc11.x86_64
xorg-x11-drv-nouveau-0.0.12-15.20090323git4067ab4.fc11.x86_64


How reproducible:
100%

Steps to Reproduce:
1. https://fedoraproject.org/wiki/QA:Testcase_nouveau_xvideo
  
Actual results:
While playing a video, the totem video screen shows corruption *only* when I move another window on top of the playing video.  Otherwise it's resizes and plays in fullscreen without error.

See attached Screenshot.

Expected results:


Additional info:
Comment 1 James Laska 2009-03-26 15:47:53 EDT
Created attachment 336880 [details]
nouveau-corruption.png
Comment 2 Ben Skeggs 2009-03-26 19:44:38 EDT
Thanks for the report, I should have this fixed today sometime.  Marking as duplicate of #492227, will update the bug there.

*** This bug has been marked as a duplicate of bug 492227 ***

Note You need to log in before you can comment on or make changes to this bug.