Bug 492483 - Error activating XKB configuration
Error activating XKB configuration
Status: CLOSED DUPLICATE of bug 483195
Product: Fedora
Classification: Fedora
Component: xorg-x11-xkb-utils (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-26 18:17 EDT by Matthieu Araman
Modified: 2009-04-09 01:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-09 01:01:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthieu Araman 2009-03-26 18:17:25 EDT
Description of problem:
error message at first x launch, using rawhide 20090326

Version-Release number of selected component (if applicable):
just installed rawhide 20090326

  
Actual results:
Error activating XKB configuration.
It can happen under various circumstances:
- a bug in libxklavier library
- a bug in X server (xkbcomp, xmodmap utilities)
- X server with incompatible libxkbfile implementation

X server version data:
The X.Org Foundation
10600000

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd



Additional info:
xprop -root| grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "evdev", "evdev", "us", "latin9", ""
_XKB_RULES_NAMES(STRING) = "evdev", "evdev", "fr", "", ""

gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
 model = 
 options = []
 layouts = []
Comment 1 Dennis Jacobfeuerborn 2009-04-01 19:37:12 EDT
I get the same error after a F11 Beta install:

[dennis@mobile ~]$ xprop -root|grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "evdev", "evdev", "us", "nodeadkeys", ""
_XKB_RULES_NAMES(STRING) = "evdev", "evdev", "de", "", ""

[dennis@mobile ~]$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
 layouts = []
 options = []
 model =
Comment 2 Peter Hutterer 2009-04-09 01:01:49 EDT

*** This bug has been marked as a duplicate of bug 483195 ***

Note You need to log in before you can comment on or make changes to this bug.