Bug 492512 - liveinst, edit partition traceback
liveinst, edit partition traceback
Status: CLOSED DUPLICATE of bug 492086
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-27 01:39 EDT by Warren Togami
Modified: 2009-03-27 05:48 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-27 05:48:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
full error saved (16.86 KB, text/plain)
2009-03-27 01:40 EDT, Warren Togami
no flags Details

  None (edit)
Description Warren Togami 2009-03-27 01:39:31 EDT
LiveCD x86_64 from March 26th, 2009.

* Run Live installer.
* Let it configure partitions using whole disk.
* Double-click on a partition to attempt to change it.
* Traceback

anaconda None exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/formats/fs.py", line 1015, in _deviceCheck
    if not ":" in devspec:
  File "/usr/lib/anaconda/storage/formats/fs.py", line 1023, in _setDevice
    self._deviceCheck(devspec)
  File "/usr/lib/anaconda/storage/formats/fs.py", line 1030, in <lambda>
    lambda f,d: f._setDevice(d),
  File "/usr/lib/anaconda/storage/formats/__init__.py", line 163, in __init__
    self.device = kwargs.get("device")
  File "/usr/lib/anaconda/storage/formats/fs.py", line 150, in __init__
    DeviceFormat.__init__(self, *args, **kwargs)
  File "/usr/lib/anaconda/iw/partition_ui_helpers_gui.py", line 199, in createFSTypeMenu
    format = device_formats[name]()
  File "/usr/lib/anaconda/iw/partition_dialog_gui.py", line 321, in __init__
    availablefstypes = restrictfs)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1118, in editPartition
    restrictfs = restrictfs)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 976, in newCB
    self.editPartition(device, isNew=1)
TypeError: argument of type 'NoneType' is not iterable

Local variables in innermost frame:
self: <storage.formats.fs.NFS object at 0x2cbc950>
devspec: None
Comment 1 Warren Togami 2009-03-27 01:40:25 EDT
Created attachment 336955 [details]
full error saved
Comment 2 Radek Vykydal 2009-03-27 05:48:47 EDT

*** This bug has been marked as a duplicate of bug 492086 ***

Note You need to log in before you can comment on or make changes to this bug.