Bug 492548 - kernel bug in nouveau driver
kernel bug in nouveau driver
Status: CLOSED DUPLICATE of bug 492492
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-03-27 08:09 EDT by Helge Deller
Modified: 2009-03-27 13:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-03-27 13:54:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Helge Deller 2009-03-27 08:09:39 EDT
Result of Nouveau QA/Test Days/2009-03-26:

Kernel was booted with this kernel option:

This happened while switching back and forth between Xorg window (dual-head setup) and text console.

------------[ cut here ]------------
WARNING: at lib/dma-debug.c:479 check_unmap+0x2bc/0x3c9() (Not tainted)
Hardware name: 6457VF4
nouveau 0000:01:00.0: DMA-API: device driver frees DMA memory with wrong function [device address=0x000000002fb73000] [size=4096 bytes] [mapped as page] [unmapped as single]
Modules linked in: fuse rfcomm bridge stp llc bnep sco l2cap sunrpc ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables ipv6 cpufreq_ondemand acpi_cpufreq dm_multipath uinput thinkpad_acpi hwmon ppdev pcspkr joydev i2c_i801 iTCO_wdt iTCO_vendor_support ricoh_mmc yenta_socket rsrc_nonstatic snd_hda_codec_analog snd_hda_intel snd_hda_codec arc4 ecb snd_hwdep snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss iwl3945 snd_mixer_oss rfkill mac80211 snd_pcm lib80211 cfg80211 snd_timer snd soundcore snd_page_alloc btusb bluetooth e1000e wmi parport_pc parport ext4 jbd2 crc16 squashfs vfat fat sdhci_pci sdhci firewire_ohci pata_acpi ata_generic mmc_core firewire_core crc_itu_t nouveau drm i2c_core video output usb_storage
Pid: 3655, comm: Xorg Not tainted 2.6.29-0.279.rc8.git6.fc11.i586 #1
Call Trace:
 [<c0430c7f>] warn_slowpath+0x7c/0xa7
 [<c040b61e>] ? save_stack_trace+0x22/0x3e
 [<c044f30e>] ? save_trace+0x37/0x84
 [<c044f3b7>] ? add_lock_to_list+0x5c/0x8e
 [<c044e5a5>] ? graph_unlock+0x64/0x70
 [<c0451254>] ? __lock_acquire+0xa30/0xad1
 [<c054a836>] ? get_hash_bucket+0x26/0x2f
 [<c054a836>] ? get_hash_bucket+0x26/0x2f
 [<c054a836>] ? get_hash_bucket+0x26/0x2f
 [<c054b12d>] check_unmap+0x2bc/0x3c9
 [<c0435887>] ? _local_bh_enable+0x8d/0x9d
 [<c054b39b>] debug_dma_unmap_page+0x5b/0x63
 [<f7da4490>] T.562+0x42/0x5f [nouveau]
 [<f7da4501>] nouveau_sgdma_clear+0x54/0x68 [nouveau]
 [<f7da42e1>] nouveau_sgdma_destroy+0x37/0x4d [nouveau]
 [<f7d1fac8>] drm_ttm_destroy+0x25/0xd7 [drm]
 [<f7d1da71>] drm_bo_destroy_locked+0xb8/0xed [drm]
 [<f7d1dbe5>] drm_bo_cleanup_refs+0x13f/0x17f [drm]
 [<f7d1da9f>] drm_bo_destroy_locked+0xe6/0xed [drm]
 [<f7d1ea3f>] drm_bo_usage_deref_locked+0x35/0x37 [drm]
 [<f7da6153>] nouveau_gem_object_del+0x20/0x2a [nouveau]
 [<f7d10737>] drm_gem_object_free+0x2d/0x5d [drm]
 [<f7d1070a>] ? drm_gem_object_free+0x0/0x5d [drm]
 [<c053fc3c>] kref_put+0x3c/0x48
 [<f7d1064e>] drm_gem_object_unreference+0x16/0x18 [drm]
 [<f7d106a1>] drm_gem_object_handle_unreference+0x23/0x26 [drm]
 [<f7d1084a>] drm_gem_close_ioctl+0x80/0x90 [drm]
 [<f7d0f6b7>] drm_ioctl+0x1b7/0x236 [drm]
 [<f7d107ca>] ? drm_gem_close_ioctl+0x0/0x90 [drm]
 [<c04b5174>] vfs_ioctl+0x5a/0x74
 [<c04b5708>] do_vfs_ioctl+0x483/0x4bd
 [<c0517b99>] ? selinux_file_ioctl+0x3f/0x42
 [<c04b5788>] sys_ioctl+0x46/0x66
 [<c0403f92>] syscall_call+0x7/0xb
---[ end trace b5d400ac9483dbd5 ]---
Comment 1 Helge Deller 2009-03-27 13:54:17 EDT

*** This bug has been marked as a duplicate of bug 492492 ***

Note You need to log in before you can comment on or make changes to this bug.