Bug 492612 - Review Request: python-chardet - Character encoding auto-detection in Python
Review Request: python-chardet - Character encoding auto-detection in Python
Status: CLOSED DUPLICATE of bug 457806
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 492613
  Show dependency treegraph
 
Reported: 2009-03-27 13:52 EDT by Andreas Osowski
Modified: 2009-05-22 12:48 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-13 02:16:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andreas Osowski 2009-03-27 13:52:37 EDT
Spec URL: 
http://fedora.mkdir.name/packages/python-chardet-1.0.1/python-chardet.spec

SRPM URL: 
http://fedora.mkdir.name/packages/python-chardet-1.0.1/python-chardet-1.0.1-1.fc10.src.rpm

Description: 
Chardet is a Python library for the auto-dection of character encoding.
It is a port of the auto-detection code in Mozilla.
Comment 1 Jason Friedland 2009-04-01 04:56:14 EDT
Hi Andreas - I'm a new packager here but some changes I thought might be required:

1. You're packaging a library, not a language:

Group: Development/Libraries

2. As per https://fedoraproject.org/wiki/Packaging:Python

BuildRequires: python

Package built fine on F10 for me.

Jason
Comment 2 Andreas Osowski 2009-04-01 07:39:41 EDT
Hello Jason,
I adapted python-chardet from python-feedparser (which is already in the repository).

1.
As python-chardet is a *python* library, it is no system / c / whatever library

Group: Development/Languages

is the correct one.

2.
Well, python-feedparser has

BuildRequires: python-devel 

and as I said, I adapted from that srpm.
python-chardet requires the /usr/lib/python2.5/config/ dir and thus needs
BuildRequires: python-devel

This obsoletes 
BuildRequires: python

Andreas
Comment 3 kushaldas@gmail.com 2009-04-13 02:16:55 EDT
Sorry , but python-chardet is already reviewed, the build got delayed.
Closing as duplicate of 457806.

*** This bug has been marked as a duplicate of bug 457806 ***

Note You need to log in before you can comment on or make changes to this bug.