Bug 492729 - No intuitive use of scrollback buffer in Fedora currently
No intuitive use of scrollback buffer in Fedora currently
Status: CLOSED DUPLICATE of bug 123504
Product: Fedora
Classification: Fedora
Component: screen (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-28 18:12 EDT by Robert Scheck
Modified: 2009-09-25 08:42 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-25 08:42:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2009-03-28 18:12:40 EDT
Description of problem:
There's currently no intuitive use of the scrollback buffer in Fedora currently.

Version-Release number of selected component (if applicable):
screen-4.0.3-12

How reproducible:
Everytime, see above and below.

Steps to Reproduce:
1. yum install screen
2. screen
3. cd /etc && ls -l
4. Try to use "Shift+PgUp" to get the scrollback buffer - doesn't work.
  
Actual results:
There's currently no intuitive use of the scrollback buffer in Fedora currently.

Expected results:
My colleague suggests the following changes to the default screen configuration 
file, please evaluate and change maybe for the next screen package build:

[root@localhost ~]# diff -u /etc/screenrc.orig /etc/screenrc
--- /etc/screenrc.orig  2009-01-29 10:36:01.000000000 +0100
+++ /etc/screenrc       2009-01-29 11:05:53.000000000 +0100
@@ -63,7 +63,7 @@
 # we do not want the width to change to 80 characters on startup:
 # on suns, /etc/termcap has :is=\E[r\E[m\E[2J\E[H\E[?7h\E[?1;3;4;6l:
 termcap xterm 'is=\E[r\E[m\E[2J\E[H\E[?7h\E[?1;4;6l'
-terminfo xterm 'is=\E[r\E[m\E[2J\E[H\E[?7h\E[?1;4;6l'
+#terminfo xterm 'is=\E[r\E[m\E[2J\E[H\E[?7h\E[?1;4;6l'

 #
 # Do not use xterms alternate window buffer.
@@ -145,7 +145,7 @@

 #80/132 column switching must be enabled for ^AW to work
 #change init sequence to not switch width
-termcapinfo  xterm Z0=\E[?3h:Z1=\E[?3l:is=\E[r\E[m\E[2J\E[H\E[?7h\E[?1;4;6l
+#termcapinfo  xterm Z0=\E[?3h:Z1=\E[?3l:is=\E[r\E[m\E[2J\E[H\E[?7h\E[?1;4;6l

 # Make the output buffer large for (fast) xterms.
 #termcapinfo xterm* OL=10000
[root@localhost ~]#
Comment 1 Robert Scheck 2009-05-10 19:17:59 EDT
Miroslav, ping?
Comment 2 Miroslav Lichvar 2009-05-11 03:14:56 EDT
Are you sure it won't break something else? Also, binding shift+{up,down} keys to screen scrollback buffer could be more useful, the buffer in terminal emulator is quite confusing after switching to another virtual terminal.

I have seen a discussion on upstream list about making a better default config, maybe it would be better to discuss this upstream too.
Comment 3 Bug Zapper 2009-06-09 08:46:53 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Tomas Hoger 2009-09-16 05:56:38 EDT
Robert, have you tried un-commenting lines below this comment in the default screenrc:

# Do not use xterms alternate window buffer.
# This one would not add lines to the scrollback buffer.

With all the terminals I've used, it makes Shift-Pg{Up,Down} work.  Of course, switching screen's windows will trash that scrollback as was noted in comment #2, but is quite sufficient for me.
Comment 5 Miroslav Lichvar 2009-09-25 08:42:23 EDT
The suggested changes in comment #0 don't seem to fix this issue. I commented them out with few others in screen-4.0.3-15.fc12 though.

The problem is that xterm's alternate screen doesn't use scroll buffer. A workaround is to disable alternate screen by modifying ti string (as in comment #4) or xterm's titeInhibit resource.

*** This bug has been marked as a duplicate of bug 123504 ***

Note You need to log in before you can comment on or make changes to this bug.