Bug 492801 - /usr/bin/info fails to display top directory (and some other apparently as well)
/usr/bin/info fails to display top directory (and some other apparently as well)
Status: CLOSED DUPLICATE of bug 515402
Product: Fedora
Classification: Fedora
Component: texinfo (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
:
: 510565 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-29 15:02 EDT by Michal Jaegermann
Modified: 2009-08-06 04:12 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-06 04:12:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2009-03-29 15:02:10 EDT
Description of problem:

After typing 'info' one is left with an empty screen instead of a menu
with a status bar claiming "1 lines".

A cursory check reveals that if one knows a name of a node, say
'info gcc' or 'info gawk', then a top menu for this document is usually displayed although 'info emacs' shows only "* Menu:" with no further entries.

Emacs info-mode still ends up with full menus as expected.

Version-Release number of selected component (if applicable):
texinfo-4.13a-2.fc11

How reproducible:
always

Expected results:
A display of a top menu after 'info' like in F9 or F10 and a real menu for 'info emacs'.

Additional information:
'info emacs intro' does get "Intro" node from that document.
Comment 1 Jan Kratochvil 2009-05-04 03:30:11 EDT
info '(as)Pseudo Ops' displays only about the first 30 lines of the node.
Comment 2 Vitezslav Crhonek 2009-05-04 10:50:47 EDT
Reproduced. /usr/bin/info behaves strangely, but I didn't find out why yet.

BTW I tried build texinfo-4.13a for F-10, it doesn't work fine too. Interestingly when locally compiled, no such problem occurred...
Comment 3 Patrick O'Callaghan 2009-05-18 12:28:35 EDT
Me too. Same issue, same symptoms. This is an F11 upgrade from F10. On F10 everything worked. Looks very much like a problem with the menus.
Comment 4 Bug Zapper 2009-06-09 08:48:04 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Suvayu 2009-07-11 14:03:23 EDT
I can confirm all the symptoms word for word.

The dir file is where it is supposed to be, /usr/share/info/dir. And the info doesn't open the top node even when invoked as, info -f /usr/share/info/dir.
Comment 6 Vitezslav Crhonek 2009-08-04 08:24:08 EDT
*** Bug 510565 has been marked as a duplicate of this bug. ***
Comment 7 Michal Jaegermann 2009-08-04 16:27:54 EDT
info-4.13a-3.fc12 from the current rawhide, regardless of comment #4, suffers in the same way.  AFAICT info-4.12-4.fc10 is OK.
Comment 8 Michal Jaegermann 2009-08-04 21:16:37 EDT
Just to add to the attraction if on an F11 system I will type 'info' and with an empty info window I will try, say, "mgn<TAB><TAB> then I will see:

7 completions:
Gnupg1              GnuTLS              gnutls-serv
GNUPLOT             gnutls-cli          
Gnus                gnutls-cli-debug

and items are "selectable".  So in a sense the whole menu is there but only as a "ghost".  Only applying the above to document indices with possible few hundreds invisible entries is not that practical.
Comment 9 Vitezslav Crhonek 2009-08-06 04:12:10 EDT

*** This bug has been marked as a duplicate of bug 515402 ***

Note You need to log in before you can comment on or make changes to this bug.