Bug 492916 - SELinux is preventing restorecon (setfiles_t) "read write" unconfined_t.
SELinux is preventing restorecon (setfiles_t) "read write" unconfined_t.
Status: CLOSED DUPLICATE of bug 484370
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-30 13:57 EDT by long
Modified: 2009-03-30 14:13 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-30 14:13:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description long 2009-03-30 13:57:12 EDT
Description of problem:
I run restorecon and I get an sealert that is fairly worthless.  Doesn't tell me what file is causing the problem or anything.

Version-Release number of selected component (if applicable):
selinux-policy-targeted-3.5.13-49.fc10.noarch

How reproducible:
always

Steps to Reproduce:
1. Run /sbin/restorecon -e /home/long/mnt -R -v /home/long/pc from root account
2.
3.
  
Actual results:

Summary:

SELinux is preventing restorecon (setfiles_t) "read write" unconfined_t.

Detailed Description:

SELinux denied access requested by restorecon. It is not expected that this
access is required by restorecon and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Or you can disable
SELinux protection altogether. Disabling SELinux protection is not recommended.
Please file a bug report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi)
against this package.

Additional Information:

Source Context                unconfined_u:unconfined_r:setfiles_t:s0-s0:c0.c102
                              3
Target Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
                              023
Target Objects                socket [ unix_stream_socket ]
Source                        restorecon
Source Path                   /sbin/setfiles
Port                          <Unknown>
Host                          griffon.cc.ku.edu
Source RPM Packages           policycoreutils-2.0.57-17.fc10
Target RPM Packages           
Policy RPM                    selinux-policy-3.5.13-49.fc10
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     griffon.cc.ku.edu
Platform                      Linux griffon.cc.ku.edu
                              2.6.27.19-170.2.35.fc10.i686.PAE #1 SMP Mon Feb 23
                              13:09:26 EST 2009 i686 i686
Alert Count                   3
First Seen                    Fri 13 Mar 2009 04:29:39 PM CDT
Last Seen                     Mon 30 Mar 2009 12:54:28 PM CDT
Local ID                      70d4173b-f5ae-41a4-a8ec-94a04a552a7d
Line Numbers                  

Raw Audit Messages            

node=griffon.cc.ku.edu type=AVC msg=audit(1238435668.773:6614): avc:  denied  { read write } for  pid=23410 comm="restorecon" path="socket:[780938]" dev=sockfs ino=780938 scontext=unconfined_u:unconfined_r:setfiles_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tclass=unix_stream_socket

node=griffon.cc.ku.edu type=AVC msg=audit(1238435668.773:6614): avc:  denied  { read write } for  pid=23410 comm="restorecon" path="socket:[780938]" dev=sockfs ino=780938 scontext=unconfined_u:unconfined_r:setfiles_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tclass=unix_stream_socket

node=griffon.cc.ku.edu type=AVC msg=audit(1238435668.773:6614): avc:  denied  { read write } for  pid=23410 comm="restorecon" path="socket:[780938]" dev=sockfs ino=780938 scontext=unconfined_u:unconfined_r:setfiles_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tclass=unix_stream_socket

node=griffon.cc.ku.edu type=SYSCALL msg=audit(1238435668.773:6614): arch=40000003 syscall=11 success=yes exit=0 a0=97df230 a1=96e69c8 a2=97decc0 a3=0 items=0 ppid=23326 pid=23410 auid=500 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=pts2 ses=1076 comm="restorecon" exe="/sbin/setfiles" subj=unconfined_u:unconfined_r:setfiles_t:s0-s0:c0.c1023 key=(null)




Expected results: Either no error at all or an error message that actually tells me what file is causing the problem.


Additional info:
Comment 1 Daniel Walsh 2009-03-30 14:04:33 EDT
I believe this is a leaked file descriptor from konsole.  

KDE is leaking file descriptors that a confined application gets handed.  SELinux closes the open descriptor and reports the error.
Comment 2 Rex Dieter 2009-03-30 14:13:05 EDT

*** This bug has been marked as a duplicate of bug 484370 ***

Note You need to log in before you can comment on or make changes to this bug.