Bug 484370 - (kde-selinux) kde is leaking open file descriptors, causing SELinux AVC warnings
kde is leaking open file descriptors, causing SELinux AVC warnings
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
: 466087 471344 474819 477508 480569 490751 491462 492608 492916 495353 (view as bug list)
Depends On:
Blocks: F11Target
  Show dependency treegraph
 
Reported: 2009-02-06 09:42 EST by Steven M. Parrish
Modified: 2009-05-26 14:51 EDT (History)
20 users (show)

See Also:
Fixed In Version: 4.2.2-2.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-21 21:05:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 180785 None None None Never

  None (edit)
Description Steven M. Parrish 2009-02-06 09:42:57 EST
This is the one bug to rule them all.

Description of problem:

SELinux AVC warnings are being issued due to Konsole leaking open file descriptors


Will report this upstream, and all existing bugs and new bugs re this topic will be duped to this one.
Comment 1 Steven M. Parrish 2009-02-06 09:43:32 EST
*** Bug 471344 has been marked as a duplicate of this bug. ***
Comment 2 Steven M. Parrish 2009-02-06 09:47:56 EST
*** Bug 480569 has been marked as a duplicate of this bug. ***
Comment 3 Steven M. Parrish 2009-02-06 09:49:59 EST
*** Bug 466087 has been marked as a duplicate of this bug. ***
Comment 4 Steven M. Parrish 2009-02-06 09:51:11 EST
*** Bug 474819 has been marked as a duplicate of this bug. ***
Comment 5 Steven M. Parrish 2009-02-06 09:51:46 EST
*** Bug 477508 has been marked as a duplicate of this bug. ***
Comment 6 Kevin Kofler 2009-03-18 09:23:09 EDT
*** Bug 490751 has been marked as a duplicate of this bug. ***
Comment 7 Rex Dieter 2009-03-30 14:13:06 EDT
*** Bug 492916 has been marked as a duplicate of this bug. ***
Comment 8 Kevin Kofler 2009-04-11 19:41:02 EDT
*** Bug 492608 has been marked as a duplicate of this bug. ***
Comment 9 Rex Dieter 2009-04-11 22:58:25 EDT
Starting to think this isn't limited to konsole, per a recent comment I made to upstream report on this,

Interestingly, 
launching konsole from yakuake (started as part of session management) 
    -> no socket file descriptors
launching konsole from kickoff or krunner or yakuake (after login, not part of
session management) 
    -> open socket file descriptors
Comment 10 Rex Dieter 2009-04-13 08:49:37 EDT
*** Bug 495353 has been marked as a duplicate of this bug. ***
Comment 11 Rex Dieter 2009-04-13 15:12:35 EDT
*** Bug 491462 has been marked as a duplicate of this bug. ***
Comment 12 Rex Dieter 2009-04-19 14:28:04 EDT
Should be addressed in kdelibs-4.2.2-7

* Sun Apr 19 2009 Rex Dieter <rdieter@fedoraproject.org> 4.2.2-7
- fix and simplify the child struct disposal (kde#180785)

* Sat Apr 18 2009 Rex Dieter <rdieter@fedoraproject.org> 4.2.2-6
- squash leaky file descriptors in kdeinit (kde#180785,rhbz#484370)
Comment 13 Fedora Update System 2009-04-21 21:05:33 EDT
kdeutils-4.2.2-2.fc10, kdetoys-4.2.2-2.fc10, kdesdk-4.2.2-2.fc10, kdeplasma-addons-4.2.2-2.fc10, kdeedu-4.2.2-1.fc10, kdebase-4.2.2-2.fc10, kdeartwork-4.2.2-3.fc10, kdeadmin-4.2.2-2.fc10, kdeaccessibility-4.2.2-1.fc10, sigen-0.1.1-1.fc10, qgit-2.2-4.fc10.1, psi-0.12.1-2.fc10, kde-plasma-weather-1.0.0-3.fc10, arora-0.6-1.fc10, kde-l10n-4.2.2-1.fc10, kdegraphics-4.2.2-3.fc10, kde-i18n-3.5.10-4.fc10, kdepimlibs-4.2.2-3.fc10, oxygen-icon-theme-4.2.2-1.fc10, kdebindings-4.2.2-2.fc10, kdepim-4.2.2-3.fc10, konq-plugins-4.2.2-1.fc10, kdemultimedia-4.2.2-2.fc10, kdenetwork-4.2.2-1.fc10, kdegames-4.2.2-6.fc10, kdebase-workspace-4.2.2-3.fc10, qt-4.5.0-14.fc10, kdebase-runtime-4.2.2-4.fc10, qjackctl-0.3.4-1.fc10, qsynth-0.3.3-6.fc10, kdelibs-4.2.2-7.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Rex Dieter 2009-05-26 14:51:01 EDT
*** Bug 495353 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.