Bug 492961 - Cobbler install instructions - various corrections and things that should be documented
Cobbler install instructions - various corrections and things that should be ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Documentation (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: John Ha
Martin Minar
Fixed in the 5.4.0 Release - GA'd 201...
: Documentation
: 519416 (view as bug list)
Depends On:
Blocks: sat540-docs
  Show dependency treegraph
 
Reported: 2009-03-30 18:07 EDT by Michael DeHaan
Modified: 2016-07-03 20:54 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-28 10:55:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael DeHaan 2009-03-30 18:07:04 EDT
(Talking with zeus, it appears I wasn't pinged on the Cobbler+Satellite documentation review, so I'm doing that now.  There are numerous errors we want to correct, but there are also various useful features in the Sat integrate we do not document indicated towards the bottom of this ...)

From my review of http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Network_Satellite/5.3.0/html/Reference_Guide/ch-cobbler.html

In the first section, "content channel management" is not something Cobbler does, per se, so I'd just replace that with "installation environment management".

"Automation of kickstart file creation using kickstart import" should say "cobbler import", though that's not the Satellite way to do it, so we should probably strike that line.

In 11.1.11, "the following lists the services and configuration files" implies that it lists all of the things it checks below, but the section below is not complete, so I'd say say "lists some of the services and configuration files"

In the 11.1.11 section, the setup process for configurating cobbler settings is done at Satellite install time, so the user will not need to set this things initially, and we should mention that (or not ask them to set it)

In 11.1.3, we don't list a complete DHCP file.  We probably should to show context -- a sample one that defines a range and an address section can be shown in about 10-15 lines.  What you have listed is not sufficient to DHCP a system.

In 11.1.13 list item 4, the path given is a Fedora path.  The path is "/tftpboot/pxelinux.0" on RHEL 4/5, though probably not for RHEL 6.  Should also add "cobbler makes sure this file is in the right place" or equivalent language there -- so the user doesn't try to put that file there themselves.  It might be simpler to say "Finally the DHCP server retrieves the bootloader, which is pxelinux.0" and not mention the path since cobbler takes care of that.

In 11.1.4 "change disable = yes line to disable = yes" should read in the last part "disable = no"

In 11.1.5.1, again we have a Fedora specific path.  The RHEL 4/5 path is "/var/lib/tftpboot"

In 11.1.5, under "For Cobbler" remove the section about 25150

In 11.1.5, change the "For Koan" text to "For Cobbler and Koan XMLRPC".  

In 11.1.6, cahnge "One all the prerequisites are met" to imply that there may still be some warnings/messages there that the user does not need to correct, i.e. "to your satisification" etc.   The user may not be able to make check 100% silent depending on their configuration and what they want to do.

Remove the sentence startwith with "First, ensure that" and remove the instruction to run cobbler sync.   (If it doesn't, it's a Satellite bug)

In general

Cobbler buildiso was not documented, which is very useful to customers who want to install bare metal in places where they can't PXE, and we should document it.

Cobbler replicate was not documented, though we mention it earlier in the documentation section

--netboot-enabled flags and how to reinstall an existing system (possibly using the Sat UI, or using cobbler on the command line) for PXE was not documented.

PXE menu behavior was not documented (about how you get a list of all the profiles to install if you haven't assigned a system to PXE boot to a specific profile)

The cobbler CLI for editing commands was not mentioned.

We have no pointers to http://cheetahtemplate.org or examples of where to find more information about templating, we should direct folks to the cobbler Wiki at least.

There isn't any documentation about what parts of cobbler "aren't" supported, not sure if we want to mention what those are or not.

"koan --replace-self" is not documented.

In the virtualization section, koan virtualization options to install guests via the CLI are not mentioned.
Comment 1 Brandon Perkins 2009-03-30 23:21:51 EDT
Past sat530-docs freeze, punting to next release triage.
Comment 2 Clifford Perry 2009-04-20 15:27:43 EDT
Need to consider this input and review - do we fix English only stuff.
Comment 3 Clifford Perry 2009-04-21 12:18:59 EDT
To my knowledge, we are not supporting (as in you can call GSS for help) DHCP, PXE, and command line/direct usage of Cobbler. It is using cobbler in the background with Satellite UI driving the usage of cobbler so the items mentioned as missing, to me is fine - since they are not supported, people can use the cobbler community to do things beyond the scope of what we provide access to doing. 

A lot of this stuff which is incorrect is minor and/or while we should fix, would cause thrashing in re-doing English and translations. I feel that if/when we do a 5.3.1 release we pick up this bug to fix inaccuracies in the doc. 

Cliff.
Comment 12 Clifford Perry 2010-10-28 10:55:47 EDT
The 5.4.0 RHN Satellite and RHN Proxy release has occurred. This issue has been resolved with this release. 


RHEA-2010:0801 - RHN Satellite Server 5.4.0 Upgrade
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10332

RHEA-2010:0803 - RHN Tools enhancement update
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10333

RHEA-2010:0802 - RHN Proxy Server 5.4.0 bug fix update
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10334

RHEA-2010:0800 - RHN Satellite Server 5.4.0
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10335

Docs are available:

http://docs.redhat.com/docs/en-US/Red_Hat_Network_Satellite/index.html 

Regards,
Clifford
Comment 13 Clifford Perry 2011-01-19 12:21:42 EST
*** Bug 519416 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.