Bug 493099 - Input misdirected in tabbed applications
Input misdirected in tabbed applications
Status: CLOSED DUPLICATE of bug 492956
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-31 12:09 EDT by Alex Hudson (Fedora Address)
Modified: 2009-03-31 12:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-31 12:19:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Hudson (Fedora Address) 2009-03-31 12:09:39 EDT
Description of problem:

When running tabbed applications - such as gedit, gnome-terminal, etc - most of my keyboard input appears to be going into the last tab, not the one that currently has focus/is visible.

"Command" keys like enter, cursor movement etc., go to the correct tab. Other keys - letters, for example - go to the last tab, no matter what. Hence only the last tab is usable.

Apologies if this is a window manager/other bug rather than toolkit.

Version-Release number of selected component (if applicable):

gtk2-2.16.0-1.fc11.x86_64
gedit-2.26.0-1.fc11.x86_64
gnome-terminal-2.26.0-1.fc11.x86_64

How reproducible:

Always.

Steps to Reproduce:
1. Start up gedit
2. Open a new tab
3. Go back to first tab, start typing
  
Actual results:

Nothing appears in the first tab; going to the second tab we see the characters we typed.

Expected results:

The stuff we type goes into the first tab.

Additional info:

Doesn't appear to affect firefox.
Comment 1 Matthias Clasen 2009-03-31 12:19:11 EDT
I think this is an ibus issue that should be fixed in ibus-1.1.0.20090331-1

*** This bug has been marked as a duplicate of bug 492956 ***

Note You need to log in before you can comment on or make changes to this bug.