Bug 493133 - (segfault_ntop) NTOP Segmentation Fault
NTOP Segmentation Fault
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: ntop (Show other bugs)
el5
All Linux
low Severity medium
: ---
: ---
Assigned To: Huzaifa S. Sidhpurwala
Fedora Extras Quality Assurance
ActualBug
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-31 14:27 EDT by Abhishek Singh
Modified: 2010-09-24 11:52 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-24 11:52:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
GDB trace of ntop (without any startup paramter) (10.70 KB, text/plain)
2009-04-01 05:00 EDT, Abhishek Singh
no flags Details

  None (edit)
Description Abhishek Singh 2009-03-31 14:27:21 EDT
I'm using NTOP on a CentOS 5.2 (x86_64) machine. I installed ntop using the epel repository. When I run ntop, it starts well, but after a few minutes it crashes giving a segmentation fault.

The version of ntop I am using is ntop-3.3.8-1.el5.rf, as returned by "rpm -q ntop".

Whenever I start ntop with or without any parameters, it crashes after few minutes. At some time, it takes more time to crash, at other ntop crashes almost instantly.

I saw similar bug filing, and the issue was said to be resolved in the new version, but for me it is still haunting me.

I ran gdb over ntop and the trace is attached along with. The trace indicates a bug/problem in util.c
Comment 1 Huzaifa S. Sidhpurwala 2009-04-01 00:03:31 EDT
Can you attach the gdb traceback on the bugzilla?
Comment 2 Abhishek Singh 2009-04-01 05:00:42 EDT
Created attachment 337471 [details]
GDB trace of ntop (without any startup paramter)
Comment 3 BJ Dierkes 2009-07-11 14:54:06 EDT
Can you verify that you are in fact using the Fedora EPEL packages for ntop?  I installed from epel-5-stable and show that the current version is:

[root@el5 ~]# rpm -q ntop
ntop-3.3.6-6.el5

[root@el5 ~]# rpm -qi ntop | grep Vendor
Version     : 3.3.6                             Vendor: Fedora Project <http://bugzilla.redhat.com/bugzilla>
Comment 4 C.Lee Taylor 2009-07-27 19:07:13 EDT
Greetings ...

 Would like to report, that I just installed ntop-3.3.6-6.el5 on CentOS 5.3 x86_64 and seem to be having the same problem, that ntop seems to be segfaulting after s short period of time.

 I wonder if updating the packages to 3.3.10 might not help with this problem?

Thanks
Mailed
LeeT
Comment 5 Jose Pedro Oliveira 2009-08-29 20:45:05 EDT
Hi,

I also had segfault problems with ntop-3.3.6. I only managed to get some stability with version 3.3.9 (built from fedora ntop-3.3.9-3).

/jpo
Comment 6 Jose Pedro Oliveira 2009-08-29 20:49:12 EDT
(In reply to comment #4)
> ...
> 
>  I wonder if updating the packages to 3.3.10 might not help with this problem?

Unfortunately version 3.3.10 requires libevent 1.4 and RHEL only ships version 1.1.  But version 3.3.9 can be built (upgrade request in #476561).

/jpo
Comment 7 Huzaifa S. Sidhpurwala 2009-10-26 02:00:09 EDT
3.3.9 is in testing currently, can you guys test it and let me know if you still get the segfault?
Thanks.
Comment 8 Jose Pedro Oliveira 2009-11-20 17:07:14 EST
+1 for pushing (see bug #476561 comment 15)
Comment 9 Jose Pedro Oliveira 2009-12-13 17:11:32 EST
Can this ticket be closed?

Note: I still haven't seen version 3.3.9 crash so far.
Comment 10 Mark Chappell 2010-09-24 11:52:05 EDT
On the grounds that Jose reports that this fix his crashing ntop and there has been no response from the original requester I'm closing off this bug, feel free to reopen if you're still having a problem with ntop crashing.

Note You need to log in before you can comment on or make changes to this bug.