Bug 493140 - anaconda crash - replace existing linux
anaconda crash - replace existing linux
Status: CLOSED DUPLICATE of bug 491348
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:72822de01d7ed50f5...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-31 14:45 EDT by Jurgen Kramer
Modified: 2009-04-25 06:04 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-31 15:07:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (97.57 KB, text/plain)
2009-03-31 14:45 EDT, Jurgen Kramer
no flags Details
Attached traceback automatically from anaconda. (95.11 KB, text/plain)
2009-04-01 06:36 EDT, Jóhann B. Guðmundsson
no flags Details
Attached traceback automatically from anaconda. (88.33 KB, text/plain)
2009-04-02 05:34 EDT, Satyabrata Maitra
no flags Details
Attached traceback automatically from anaconda. (385.46 KB, text/plain)
2009-04-02 15:50 EDT, Gireesh Sreekantan
no flags Details
Attached traceback automatically from anaconda. (75.92 KB, text/plain)
2009-04-04 17:39 EDT, Izzy
no flags Details
Attached traceback automatically from anaconda. (155.00 KB, text/plain)
2009-04-20 15:25 EDT, Rajagopal Ramamoorthy
no flags Details
Attached traceback automatically from anaconda. (70.55 KB, text/plain)
2009-04-25 06:04 EDT, kamal47thakur
no flags Details

  None (edit)
Description Jurgen Kramer 2009-03-31 14:45:02 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.38 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/site-packages/parted/disk.py", line 181, in addPartition
    constraint.getPedConstraint()):
  File "/usr/lib/anaconda/storage/partitioning.py", line 754, in allocatePartitions
    constraint=constraint)
  File "/usr/lib/anaconda/storage/partitioning.py", line 553, in doPartitioning
    allocatePartitions(disks, partitions)
  File "/usr/lib/anaconda/storage/partitioning.py", line 191, in doAutoPartition
    exclusiveDisks=anaconda.id.storage.clearPartDisks)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1317, in nextClicked
    self.anaconda.dispatch.gotoNext()
PartitionException: Unable to satisfy all constraints on the partition.
Comment 1 Jurgen Kramer 2009-03-31 14:45:11 EDT
Created attachment 337385 [details]
Attached traceback automatically from anaconda.
Comment 2 Jurgen Kramer 2009-03-31 14:50:23 EDT
While attempting a fresh re-install (not upgrade) this crash happened when I selected to automatically replace the existing Linux system (in this case F11 rawhide).

I tried it a second time with the same result.

BTW nice to see that the first anaconda text screen now starts in hires text mode :).
Comment 3 Chris Lumens 2009-03-31 15:07:00 EDT

*** This bug has been marked as a duplicate of bug 491348 ***
Comment 4 Jóhann B. Guðmundsson 2009-04-01 06:36:44 EDT
Created attachment 337482 [details]
Attached traceback automatically from anaconda.
Comment 5 Jóhann B. Guðmundsson 2009-04-01 06:50:46 EDT
Hum this is weird and somehow I ended cc to this one 

My traceback happend when choosing a remaining free disk space
Comment 6 Satyabrata Maitra 2009-04-02 05:34:56 EDT
Created attachment 337758 [details]
Attached traceback automatically from anaconda.
Comment 7 Gireesh Sreekantan 2009-04-02 15:50:38 EDT
Created attachment 337891 [details]
Attached traceback automatically from anaconda.
Comment 8 Izzy 2009-04-04 17:39:14 EDT
Created attachment 338182 [details]
Attached traceback automatically from anaconda.
Comment 9 Rajagopal Ramamoorthy 2009-04-20 15:25:56 EDT
Created attachment 340413 [details]
Attached traceback automatically from anaconda.
Comment 10 kamal47thakur 2009-04-25 06:04:36 EDT
Created attachment 341307 [details]
Attached traceback automatically from anaconda.

Note You need to log in before you can comment on or make changes to this bug.