Bug 493224 - Beta Live CD install fails on installation of bootloader
Beta Live CD install fails on installation of bootloader
Status: CLOSED DUPLICATE of bug 492727
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-31 19:43 EDT by Bob Agel
Modified: 2009-04-10 19:41 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-01 10:58:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Agel 2009-03-31 19:43:46 EDT
Description of problem:Did custom partitioning setup, selected to install bootloader on /dev/sdb2.  Installation completes until: An error occurred mounting device /dev/sda1 as /: mount failed: (2, None). This is a fatal error and the install cannot continue.

Press <Enter> to exit the installer.

Have attempted as ext3 and as ext4; same results.  5 other distros are installed and alpha had installed properly on the same partition.


Version-Release number of selected component (if applicable):


How reproducible: Boot Live CD, attempt install.  Fail.
At least one other member of FedoraForum.org reports exactly the same issue on the Forum today.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info: For fun, attempted to boot the beta afterwards, using configfile entry.  Failed.  Possible (weak possible) connection:  After Live CD boots, SELinux immediately reports something's denied.  Didn't investigate that.
Comment 1 Bob Agel 2009-03-31 19:47:16 EDT
Edit: Sorry - typo there: "mounting device /dev/sda1" should have been "mounting device /dev/sda2"
Comment 2 Bob Agel 2009-03-31 19:51:04 EDT
Edit: Sorry - typo there: "mounting device /dev/sda1" should have been "mounting device /dev/sdb2"
Comment 3 Hobbes 2009-03-31 20:23:27 EDT
The same thing happen to me:

After finish copying the image to the hdd (sda) I recieve this message on the post-installation process:

An error occurred mounting device /dev/sda1 as /: mount failed: (2, None). This is a fatal error and the install cannot continue.

Press <Enter> to exit the installer.

I already try to install it with the / partition as ext3, ext4 and nothing seems to help.

More info from the vt:

INFO : moving (1) to step postinstallconfig

INFO : doing post-install fs mangling

INFO : going to do resize

INFO : mount SELinux context for mountpoint /mnt/sysimage to False

This HDD already has a /home directory sda6 ext4 (ubuntu)

I hope this will shed more light on this bug.
Comment 4 John Cox 2009-03-31 22:04:24 EDT
same here with sda4 on two different machines.
going to try the DVD install.
Comment 5 Bob Agel 2009-03-31 22:26:08 EDT
Just tried the DVD install. It's also a bork.  Houston, we've got a problem!
Comment 6 Casey Jones 2009-03-31 23:38:03 EDT
Decided to get my hands dirty, and get my Gentoo foo on.

So I found the filesystem isn't completely borked. I can mount the created filesystem just fine in the LiveCD (sda4 for me). It would not mount in Gentoo though, I believe it was seeing the filesystem as ext4, but I created it as ext3, this may be the culprit.

I snooped around a bit in the filesystem Anaconda created after mounting it in the LiveCD, I noticed /boot didn't have an initrd, so I created one. I didn't know the exact kernel version, so I used:

mkinitrd initrd-beta.img 2.6.29*

I used 2.6.29*, because again I didn't know the exact version, but this may have caused me some problems, I'll get to that in a second.

So I went into Gentoo and set up Grub to boot it since it had a kernel and a initrd now. (I checked other directories too, and they had things in there)
It mounted the kernel just fine, and loaded the initrd, but stopped on this error:

modprobe: FATAL: could not load /lib/modules/2.6.29-0.258.2.3.rc8.git2.fc11.i586/modules.dep: No such file or directory

This might have been a product of my flaky initrd creation, I don't know if that is the exact version, but I thought I tried something similar to that...

It's getting late, and I'm tired, so I'll take another look at this tomorrow. Maybe somebody else can expand on what I did and get a workaround going.
Comment 7 francois rigaut 2009-04-01 10:49:47 EDT
+1 here. same error.
I can also confirm that even though I formatted "/" as ext3, it gets reported as ext4 by gparted (booted in another distro).
Comment 8 Chris Lumens 2009-04-01 10:58:38 EDT

*** This bug has been marked as a duplicate of bug 492727 ***
Comment 9 Jayne Samuel-Walker 2009-04-10 19:41:43 EDT
+1 here. same error.

I can also confirm that even though I formatted "/" as ext3, it gets reported
as ext4 by gparted (booted in Ubuntu).

Note You need to log in before you can comment on or make changes to this bug.