Bug 492727 - [anaconda] aborts because liveinst accepts ext3 for root volume but formats as ext4
[anaconda] aborts because liveinst accepts ext3 for root volume but formats a...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
: 493139 493206 493224 493374 493461 493948 494050 495234 496465 497060 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-28 18:02 EDT by Joachim Frieben
Modified: 2009-11-12 11:27 EST (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-02 12:23:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (15.05 KB, text/plain)
2009-04-06 10:33 EDT, IBM Bug Proxy
no flags Details
anaconda log before this call trace (9.90 KB, text/plain)
2009-04-06 10:34 EDT, IBM Bug Proxy
no flags Details

  None (edit)
Description Joachim Frieben 2009-03-28 18:02:53 EDT
Description of problem:
When installing a system using the "Nouveau Test Day" live CD with anaconda updated to release 11.5.0.38-1, ext3 has been chosen for the root volume (custom partitioning). Anaconda accepts the input, formats all volumes flagged correspondingly and then copies the live image to the hard disk. However, when the installer proceeds to performing the final stage, an error message pops up,

  "An error occurred mounting device /dev/mapper/VolGroup00-LogVol00 as
   /: mount failed: (2, None). This is a fatal error and the install
   cannot continue.",

and the installer aborts.

Version-Release number of selected component (if applicable):
anaconda-11.5.0.38-1

How reproducible:
Always.

Steps to Reproduce:
1. Launch liveinst.
2. Choose ext3 for root volume.
  
Actual results:
After copying the live image to the hard disk, the installer aborts because the root volume cannot be mounted.

Expected results:
Installer proceeds to finishing the new setup.

Additional info:
- A further trial reveals that the root volume has been actually formatted
  as an ext4 file system and not as an ext3 one as chosen and accepted by
  the partitioning tool.
- Choosing ext4 instead of ext3 allows to perform the install without
  problem.
- Either ext3 is inadmissible, then liveinst has to reject this choice
  explicitly, or it has to format the volume as an ext3 one which would
  have allowed to mount the root volume after the copy stage correctly.
Comment 1 Chris Lumens 2009-04-01 10:58:25 EDT
*** Bug 493139 has been marked as a duplicate of this bug. ***
Comment 2 Chris Lumens 2009-04-01 10:58:38 EDT
*** Bug 493224 has been marked as a duplicate of this bug. ***
Comment 3 Chris Lumens 2009-04-01 11:44:25 EDT
*** Bug 493374 has been marked as a duplicate of this bug. ***
Comment 4 Jeremy Katz 2009-04-01 16:08:50 EDT
We used to do the changing behind the user's back (eg, if you selected ext2 instead of ext3).  With the storage rewrite, we seem to have lost that.  On the plus side, it's now a little easier to actually check in the sanity checking and give you an indication when you do your installation that you need to select ext4 (or whatever the live image is) instead.  

Patch to do so sent for comments, should be in rawhide in a day or three
Comment 5 Jeremy Katz 2009-04-01 16:09:13 EDT
*** Bug 493206 has been marked as a duplicate of this bug. ***
Comment 6 Chris Lumens 2009-04-01 16:55:21 EDT
*** Bug 493461 has been marked as a duplicate of this bug. ***
Comment 7 Casey Jones 2009-04-01 16:58:58 EDT
Thanks for looking into this Jeremy.  I've found a little information that may
or may no help you.

I created an ext3 partition using fdisk and mke2fs, and I ran Anaconda and told
it not to format the partition, but just to mount / to it, and it still managed
to try converting it to ext4 unsuccessfully.

I don't understand how it does that if it's not supposed to be formatting
anything.
Comment 8 francois rigaut 2009-04-01 20:22:10 EDT
same here: I formatted the root partition in ext3 from another linux distro (using gparted). Then I install, but asked it *not* to format the "/" partition. I got the same "can't mount" error at the end of the install, and checking back, the partition is now appearing as ext4. So it formatted it, or changed it to ext4 somehow.
Comment 9 Jeremy Katz 2009-04-01 22:09:29 EDT
(In reply to comment #7)
> I don't understand how it does that if it's not supposed to be formatting
> anything.  

You can't not do a format of the rootfs with the live install -- the way the live install works is that we copy over the rootfs from the livecd as a direct block copy and then resize to fill the size you wanted.
Comment 10 Casey Jones 2009-04-01 22:54:35 EDT
So if you do a non-live install, you don't have to format?  Does the DVD do non-live installs?  I haven't really used Fedora extensively since before the LiveCDs came out.

Could there be another way to do the install?  Being a Gentoo user, you download a tarball and extract it to your rootfs, and really all it does is dump all the files and directories onto it.

Couldn't Fedora just do something like that?  So instead of formatting the filesystem, just dump the files onto it?  Is there anything that Anaconda does that would make this impossible?
Comment 11 Jeremy Katz 2009-04-02 12:23:46 EDT
Fixed in git
Comment 12 Hobbes 2009-04-02 15:12:10 EDT
Is there a rawhide ISO built with the fix implemented?
Comment 13 Chris Lumens 2009-04-03 09:53:37 EDT
*** Bug 493948 has been marked as a duplicate of this bug. ***
Comment 14 Chris Lumens 2009-04-06 10:22:51 EDT
*** Bug 494050 has been marked as a duplicate of this bug. ***
Comment 15 IBM Bug Proxy 2009-04-06 10:33:55 EDT
Created attachment 338337 [details]
dmesg
Comment 16 IBM Bug Proxy 2009-04-06 10:34:05 EDT
Created attachment 338338 [details]
anaconda log before this call trace
Comment 17 Chris Lumens 2009-04-13 09:43:15 EDT
*** Bug 495234 has been marked as a duplicate of this bug. ***
Comment 18 Chris Lumens 2009-04-20 09:56:35 EDT
*** Bug 496465 has been marked as a duplicate of this bug. ***
Comment 19 Chris Lumens 2009-04-22 09:47:39 EDT
*** Bug 497060 has been marked as a duplicate of this bug. ***
Comment 20 Anonymous account 2009-11-12 11:27:14 EST
This is not fixed.  Fedora 11 liveCD. :(

Note You need to log in before you can comment on or make changes to this bug.