Bug 493244 - xrandr failure
xrandr failure
Status: CLOSED DUPLICATE of bug 493368
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-01 00:11 EDT by Jerry Amundson
Modified: 2009-04-02 17:53 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-02 17:39:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
System log files (/var/log/{secure,messages,audit,Xorg.0.log}) (24.53 KB, text/plain)
2009-04-01 09:55 EDT, James Laska
no flags Details
Failure notification of the display settings tool (14.61 KB, image/png)
2009-04-01 13:58 EDT, Joachim Frieben
no flags Details
Dmesg output after switching rotation to "left" (75.95 KB, text/plain)
2009-04-02 17:01 EDT, Maciej Grela
no flags Details
Xorg.0.log after switching rotation to 'left'. (288.64 KB, text/plain)
2009-04-02 17:01 EDT, Maciej Grela
no flags Details

  None (edit)
Description Jerry Amundson 2009-04-01 00:11:40 EDT
Description of problem:
https://fedoraproject.org/wiki/QA:Testcase_radeon_rotate
xrandr failure

Version-Release number of selected component (if applicable):


How reproducible:
more than once

Steps to Reproduce:
1.livecd 
2.gnome-display-properties
3.change Rotation, hit apply
  
Actual results:
fuzzy, offset stuff

Expected results:
pretty stuff

Additional info:
Screen 0: minimum 320 x 200, current 1280 x 1024, maximum 4096 x 4096
VGA-0 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 338mm x 270mm
   1280x1024      75.0*    60.0
   1024x768       75.1     70.1     60.0
   832x624        74.6
   800x600        72.2     75.0     60.3     56.2
   640x480        72.8     75.0     66.7     60.0
   720x400        70.1
DVI-0 disconnected (normal left inverted right x axis y axis)
Comment 1 Jerry Amundson 2009-04-01 00:33:54 EDT
Left ( and I assume Right) is garbled.
Upside down is, go figure, upside-down, but "no saved backup" - desktop timeouts the "revert" prompt, exits, then autologs-in with an upside down desktop. Hi-f'ing-larious! :-)
Even running gnome-display-properties (upside-down, natch) does not change rot.
Comment 2 James Laska 2009-04-01 09:55:52 EDT
Created attachment 337527 [details]
System log files (/var/log/{secure,messages,audit,Xorg.0.log})

Experiencing this problem as well.  Attaching log files (/var/log/{secure,messages,audit,Xorg.0.log})

* The screen is garbled for left/right rotation, but looks fine for normal and upside-down.

* When I try to change to another tty to run xrandr manually, it appears that X crashes and returns me to the gdm login prompt
Comment 3 Joachim Frieben 2009-04-01 11:52:52 EDT
Same problem here for QA:Testcase_radeon_rotate:
- Rotate left leads to a garbled display. A screenshot taken at this very
  moment by pressing "Print Screen" looks ok however when displayed a
  posteriori.
- Rotate "upside_down" works but when the timeout for confirming the change
  has elapsed, then the display settings applet reports that it cannot
  switch back to an old configuration, and thus, the desktop stays flipped.
  When enforcing rotate "normal" through the applet, then the session
  terminates abruptly. The only way to restore the normal aspect is to edit
  $HOME/.config/monitors.xml by hand, preferably in a VT, and to restore
  <rotation>normal</rotation>.
  
  Screen 0: minimum 320 x 200, current 1280 x 1024, maximum 4096 x 4096
  VGA-0 connected 1280x1024+0+0 (normal left inverted right x axis y axis)
  364mm x 291mm
     1280x1024      75.0* 
     1024x768       75.1     60.0  
     800x600        75.0     60.3  
     640x480        75.0     60.0  
     720x400        70.1  
     0x0             0.0  
  DVI-0 disconnected (normal left inverted right x axis y axis)

  This is on a ATI Technologies Inc Radeon X800 SE (R430) (PCIE) [1002:554e]
Comment 4 Joachim Frieben 2009-04-01 13:58:11 EDT
Created attachment 337602 [details]
Failure notification of the display settings tool

This error notification pops up when "rotate upside_down" had been applied, and the confirmation dialog for permanent change has elapsed without user response.
Comment 5 François Cami 2009-04-01 18:18:14 EDT
    Thanks for the bug report. We have reviewed the information you have
provided above, and there is some additional information we require that will
be helpful in our diagnosis of this issue. 

    Please attach your X server log file (/var/log/Xorg.*.log) and the output
of "dmesg" to the bug report as individual *uncompressed, text/plain* file
attachments using the bugzilla file attachment link below.

    We will review this issue again once you've had a chance to attach this
information. 

    Thank you in advance. 

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Maciej Grela 2009-04-02 17:01:06 EDT
Created attachment 337922 [details]
Dmesg output after switching rotation to "left"
Comment 7 Maciej Grela 2009-04-02 17:01:35 EDT
Created attachment 337924 [details]
Xorg.0.log after switching rotation to 'left'.
Comment 8 Maciej Grela 2009-04-02 17:01:55 EDT
Hi,

I have the exact same issue on a Mobility FireGL 9000 chip (testing done for Fedora test day -> http://fedoraproject.org/wiki/QA:Testcase_radeon_rotate). Switching rotation to left causes the screen to show garbage. I've attached dmesg and Xorg.0.log for my case.
Comment 9 François Cami 2009-04-02 17:39:11 EDT
Thanks a lot for the information and the logs.

Closing as DUP of # 493368 .

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 493368 ***

Note You need to log in before you can comment on or make changes to this bug.