Bug 493368 - Rotated screen garbled
Rotated screen garbled
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
: 493244 493309 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-01 11:24 EDT by Chris Schumann
Modified: 2009-04-18 18:38 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-18 18:38:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log file after rotation and attempt to rotate back (67.43 KB, text/plain)
2009-04-02 09:52 EDT, Chris Schumann
no flags Details
dmesg output after rotation (41.54 KB, text/plain)
2009-04-02 09:53 EDT, Chris Schumann
no flags Details
Xorg.log (50.44 KB, text/plain)
2009-04-02 10:55 EDT, Nathanael Noblet
no flags Details
Xorg (106.35 KB, text/plain)
2009-04-02 10:55 EDT, Nathanael Noblet
no flags Details

  None (edit)
Description Chris Schumann 2009-04-01 11:24:39 EDT
Description of problem:
Test Day Radeon, Testcase_radeon_rotate. Rotate of primary display causes screen to be corrupted. Attempting to access console causes all screens to turn off.

Version-Release number of selected component (if applicable):
Test Day Radeon iso

How reproducible:
Every time

Steps to Reproduce:
1. Boot from Test Day Radeon CD
2. Run gnome-display-properties
3. Rotate primary display left and Apply
  
Actual results:
Garbled screen.

Expected results:
Rotated desktop.

Additional info:
Smolt hardware profile: http://www.smolts.org/client/show/pub_76127e40-8685-4f9d-b8da-fc91596c5b84
Comment 1 Chris Schumann 2009-04-01 11:26:37 EDT
With only laptop display, here is output of xrandr:
Screen 0: minimum 320 x 200, current 1400 x 1050, maximum 4096 x 4096
VGA-0 disconnected (normal left inverted right x axis y axis)
DVI-0 disconnected (normal left inverted right x axis y axis)
LVDS connected 1400x1050+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
                  50.0*+

With laptop and external display:
Screen 0: minimum 320 x 200, current 1680 x 1050, maximum 4096 x 4096
VGA-0 connected 1680x1050+0+0 (normal left inverted right x axis y axis) 474mm x 296mm
   1680x1050      60.0*+
   1280x1024      75.0  
   1024x768       75.1     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        72.8     75.0     66.7     60.0  
   720x400        70.1  
   0x0             0.0  
DVI-0 disconnected (normal left inverted right x axis y axis)
LVDS connected 1400x1050+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
                  50.0*+

Primary display is garbled whether external display is connected or not. Nothing displays on external display ("Input not supported" displays on external monitor).
Comment 2 Nathanael Noblet 2009-04-01 12:00:12 EDT
identical problem (X1350 PRO) 

When I rotate, The screen isn't correct at all, I have artifacts everywhere, not all windows are visible. When I attempt to set the rotation back, X crashes? I'm back at an automatic login screen (unrotated) which then logins to the same messed up screen as before. No errors in dmesg/messages
Comment 3 Chris Schumann 2009-04-01 14:55:48 EDT
On ThinkPad T60 with X1400/RV515 chip, rotated display is visible, but has artifacts: system menus appear on top and bottom of screen. Rotating back ends desktop session, but it restarts with normal rotation.
Comment 4 Chris Schumann 2009-04-01 14:57:26 EDT
(In reply to comment #3)
> On ThinkPad T60 with X1400/RV515 chip, rotated display is visible, but has
> artifacts: system menus appear on top and bottom of screen. Rotating back ends
> desktop session, but it restarts with normal rotation.  

Actually, rotating back just ends the session. After logging in, it restarts rotated, and rotating back ends the session again.
Comment 5 François Cami 2009-04-01 18:04:48 EDT
    Thanks for the bug report. We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue. 

    Please attach your X server log file (/var/log/Xorg.*.log) and the output of "dmesg" to the bug report as individual *uncompressed, text/plain* file attachments using the bugzilla file attachment link below. Posting a link to your smolt profile would be helpful as well.
    
    We will review this issue again once you've had a chance to attach this information. 

    Thank you in advance. 

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Chris Schumann 2009-04-02 09:52:52 EDT
Created attachment 337816 [details]
Xorg log file after rotation and attempt to rotate back

I rotated left, got a garbled screen. I attempted to tab back to the rotation dropdown, select Normal, tab back to Apply and activate it, but I'm not sure if I actually did that because the screen remained garbled. I used ssh to connect to the machine (starting sshd and opening the firewall before the rotation attempt) and capture these files.

The smolt profile link is in the original bug report.
Comment 7 Chris Schumann 2009-04-02 09:53:32 EDT
Created attachment 337817 [details]
dmesg output after rotation
Comment 8 Nathanael Noblet 2009-04-02 10:55:17 EDT
Created attachment 337832 [details]
Xorg.log

Since xorg crashed, I assume this would be the second log as the first is moved to .old
Comment 9 Nathanael Noblet 2009-04-02 10:55:55 EDT
Created attachment 337833 [details]
Xorg

As X crashed, I would assume this is the original log moved to .old
Comment 10 Chris Schumann 2009-04-02 11:02:13 EDT
(In reply to comment #9)
> Created an attachment (id=337833) [details]
> Xorg
> 
> As X crashed, I would assume this is the original log moved to .old  

X did not crash. I believe there was a kernel issue of some sort.

In any case, there was no other Xorg log file, such as Xorg.1.log or any other file that starts with X in /var/log/.
Comment 11 Nathanael Noblet 2009-04-02 11:16:11 EDT
Well, not for the original rotation no, X didn't crash. However when I tried to return to normal output, X died. I got the login screen again (non-rotated), at which point it auto logged me back in, to a garbled rotated screen. Attempting to set it back yet again X dies/crashes for me...
Comment 12 Chris Schumann 2009-04-02 11:32:03 EDT
(In reply to comment #11)
> Well, not for the original rotation no, X didn't crash. However when I tried to
> return to normal output, X died. I got the login screen again (non-rotated), at
> which point it auto logged me back in, to a garbled rotated screen. Attempting
> to set it back yet again X dies/crashes for me...  

My apologies Nathaniel.

I thought your post was a reply to my log post. I'm still new at bugzilla and didn't notice you posted your log file to add to the information here. I'll try to be more aware in the future.

To repair the rotation issue, you can log in to a console and edit ~username/.config/monitors.xml and change the <rotation> setting to "normal". I had to do that on a LiveUSB I'm using on another laptop.

For bugzappers: If I have this same or similar issue on another machine, should I also post those log files and smolt link here, or start another bug? (Machine is ThinkPad T60 with Radeon X1400 chip.)
Comment 13 François Cami 2009-04-02 16:28:40 EDT
If you are sure that the issues are identical, please post additional
logs here, otherwise feel free to open a different bug.

Thanks for the logs, switching to ASSIGNED.

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 14 François Cami 2009-04-02 17:39:03 EDT
*** Bug 493309 has been marked as a duplicate of this bug. ***
Comment 15 François Cami 2009-04-02 17:39:11 EDT
*** Bug 493244 has been marked as a duplicate of this bug. ***
Comment 16 Joachim Frieben 2009-04-15 06:57:36 EDT
On an ATI Technologies Inc Radeon X800 SE (R430) (PCIE) rev 0, rotating the desktop by 90 and 180 degrees is fully working now as opposed to the Radeon Test Day spin. Installed packages include:
- kernel-2.6.29.1-70.fc11.x86_64
- xorg-x11-drv-ati-6.12.2-2.fc11.x86_64
- xorg-x11-server-Xorg-1.6.1-1.fc11.x86_64
Comment 17 François Cami 2009-04-18 18:38:37 EDT
Joachim,

Thanks for testing the fix.

Closing.

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.