Bug 493256 - F10 virt-manager needs to depend on the latest python-virtinst: "Permission denied: '/var/lib/libvirt/boot/virtinst-.treeinfo.XIYNd_"
F10 virt-manager needs to depend on the latest python-virtinst: "Permission d...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
: 498762 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-01 02:09 EDT by Jens Petersen
Modified: 2009-09-15 03:36 EDT (History)
6 users (show)

See Also:
Fixed In Version: 0.6.1-3.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-15 03:36:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2009-04-01 02:09:32 EDT
Description of problem:
When trying to do an install via "Network install tree" I get a backtrace about 

Version-Release number of selected component (if applicable):
virt-manager-0.6.1-1.fc10

How reproducible:
every time

Steps to Reproduce:
1. try to do a network install of rawhide:

2.
3.
  
Actual results:
Unable to complete install '<type 'exceptions.OSError'> [Errno 13] Permission denied: '/var/lib/libvirt/boot/virtinst-.treeinfo.XIYNd_'
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/create.py", line 717, in do_install
    dom = guest.start_install(False, meter = meter)
  File "/usr/lib/python2.5/site-packages/virtinst/Guest.py", line 730, in start_install
    self._prepare_install(meter)
  File "/usr/lib/python2.5/site-packages/virtinst/FullVirtGuest.py", line 315, in _prepare_install
    distro = self.os_distro)
  File "/usr/lib/python2.5/site-packages/virtinst/DistroManager.py", line 269, in prepare
    self._prepare_kernel_and_initrd(guest, distro, meter)
  File "/usr/lib/python2.5/site-packages/virtinst/DistroManager.py", line 235, in _prepare_kernel_and_initrd
    arch=arch)
  File "/usr/lib/python2.5/site-packages/virtinst/DistroManager.py", line 109, in acquireKernel
    scratchdir=scratchdir, arch=arch)
  File "/usr/lib/python2.5/site-packages/virtinst/DistroManager.py", line 90, in _storeForDistro
    if store.isValidStore(fetcher, progresscb):
  File "/usr/lib/python2.5/site-packages/virtinst/OSDistro.py", line 200, in isValidStore
    if self._hasTreeinfo(fetcher, progresscb):
  File "/usr/lib/python2.5/site-packages/virtinst/OSDistro.py", line 66, in _hasTreeinfo
    tmptreeinfo = fetcher.acquireFile(".treeinfo", progresscb)
  File "/usr/lib/python2.5/site-packages/virtinst/ImageFetcher.py", line 98, in acquireFile
    tmpname = self.saveTemp(file, prefix=base + ".")
  File "/usr/lib/python2.5/site-packages/virtinst/ImageFetcher.py", line 43, in saveTemp
    (fd, fn) = tempfile.mkstemp(prefix="virtinst-" + prefix, dir=self.scratchdir)
  File "/usr/lib64/python2.5/tempfile.py", line 302, in mkstemp
    return _mkstemp_inner(dir, prefix, suffix, flags)
  File "/usr/lib64/python2.5/tempfile.py", line 236, in _mkstemp_inner
    fd = _os.open(file, flags, 0600)
OSError: [Errno 13] Permission denied: '/var/lib/libvirt/boot/virtinst-.treeinfo.XIYNd_'
'

Expected results:
no backtrace

Additional info:
This has been happening for a while now...
I am not sure about in rawhide, and don't have a bare metal rawhide box with vt right now.
Comment 1 Mark McLoughlin 2009-04-03 06:32:45 EDT
Jens, does this work with SELinux in permissive mode? If so, could you post the SELinux errors? Thanks
Comment 2 Cole Robinson 2009-04-06 15:42:46 EDT
Also, what virtinst version are you using?

Are you launching virt-manager as root?
Comment 3 Jens Petersen 2009-04-07 05:57:49 EDT
(In reply to comment #1)
> Jens, does this work with SELinux in permissive mode?

My F10 box is essentially permissive for running virt...


(In reply to comment #2)
> Also, what virtinst version are you using?

python-virtinst-0.400.0-5.fc10

> Are you launching virt-manager as root?  

Yes, I give the root passwd to access the local libvirtd.
Comment 4 Cole Robinson 2009-05-03 13:19:46 EDT
*** Bug 498762 has been marked as a duplicate of this bug. ***
Comment 5 Cole Robinson 2009-05-03 13:21:34 EDT
Can you reproduce with the latest version of python-virtinst from updates testing?
Comment 6 Jens Petersen 2009-05-04 21:02:59 EDT
(In reply to comment #5)
> Can you reproduce with the latest version of python-virtinst from updates
> testing?  

No that seems to fix it, thanks.
Comment 7 Cole Robinson 2009-05-04 21:26:59 EDT
I'll update virt-manager in updates-testing to depend on the latest python-virtinst.
Comment 8 Fedora Update System 2009-09-14 12:30:32 EDT
virt-manager-0.6.1-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/virt-manager-0.6.1-3.fc10
Comment 9 Fedora Update System 2009-09-15 03:36:49 EDT
virt-manager-0.6.1-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.