Bug 498762 - virtinstall backtrace: [Errno 13] Permission denied: '/var/lib/libvirt/boot/virtinst-.treeinfo.wI6HFv'
virtinstall backtrace: [Errno 13] Permission denied: '/var/lib/libvirt/boot/v...
Status: CLOSED DUPLICATE of bug 493256
Product: Fedora
Classification: Fedora
Component: python-virtinst (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-02 23:38 EDT by Jens Petersen
Modified: 2009-05-03 13:19 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-03 13:19:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2009-05-02 23:38:24 EDT
Description of problem:
Often when I try to do an install from virt-manager I run into a backtrace

Version-Release number of selected component (if applicable):
0.6.1-1.fc10

Steps to Reproduce:
1. net install rawhide
  
Actual results:
Unable to complete install '<type 'exceptions.OSError'> [Errno 13] Permission denied: '/var/lib/libvirt/boot/virtinst-.treeinfo.wI6HFv'
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/create.py", line 717, in do_install
    dom = guest.start_install(False, meter = meter)
  File "/usr/lib/python2.5/site-packages/virtinst/Guest.py", line 730, in start_install
    self._prepare_install(meter)
  File "/usr/lib/python2.5/site-packages/virtinst/FullVirtGuest.py", line 315, in _prepare_install
    distro = self.os_distro)
  File "/usr/lib/python2.5/site-packages/virtinst/DistroManager.py", line 269, in prepare
    self._prepare_kernel_and_initrd(guest, distro, meter)
  File "/usr/lib/python2.5/site-packages/virtinst/DistroManager.py", line 235, in _prepare_kernel_and_initrd
    arch=arch)
  File "/usr/lib/python2.5/site-packages/virtinst/DistroManager.py", line 109, in acquireKernel
    scratchdir=scratchdir, arch=arch)
  File "/usr/lib/python2.5/site-packages/virtinst/DistroManager.py", line 90, in _storeForDistro
    if store.isValidStore(fetcher, progresscb):
  File "/usr/lib/python2.5/site-packages/virtinst/OSDistro.py", line 200, in isValidStore
    if self._hasTreeinfo(fetcher, progresscb):
  File "/usr/lib/python2.5/site-packages/virtinst/OSDistro.py", line 66, in _hasTreeinfo
    tmptreeinfo = fetcher.acquireFile(".treeinfo", progresscb)
  File "/usr/lib/python2.5/site-packages/virtinst/ImageFetcher.py", line 98, in acquireFile
    tmpname = self.saveTemp(file, prefix=base + ".")
  File "/usr/lib/python2.5/site-packages/virtinst/ImageFetcher.py", line 43, in saveTemp
    (fd, fn) = tempfile.mkstemp(prefix="virtinst-" + prefix, dir=self.scratchdir)
  File "/usr/lib64/python2.5/tempfile.py", line 302, in mkstemp
    return _mkstemp_inner(dir, prefix, suffix, flags)
  File "/usr/lib64/python2.5/tempfile.py", line 236, in _mkstemp_inner
    fd = _os.open(file, flags, 0600)
OSError: [Errno 13] Permission denied: '/var/lib/libvirt/boot/virtinst-.treeinfo.wI6HFv'
'

Expected results:
no backtrace
Comment 1 Cole Robinson 2009-05-03 13:19:46 EDT

*** This bug has been marked as a duplicate of bug 493256 ***

Note You need to log in before you can comment on or make changes to this bug.